Samba problem

Issues related to configuring your network
Posts: 4
Joined: 2017/12/18 11:48:35

Samba problem

Postby XP_2600 » 2018/01/09 12:03:24

I have a problem with samba, i can mount the share normally from other linux box, i can access it from any windows 10 computer not member of domain, but when i try to access the share from a member of domain Windows computer i cannot open the share keeps refusing the username/password.
my samba config file is like this:

Code: Select all

workgroup = mygroup
netbios name = mybox
security = user
#valid users = nhstudent
guest account = nobody
map to guest = bad user
log level = 2
ntlm auth = no
lanman auth = no
client ntlmv2 auth = yes

comment = Data
path = /export
guest ok = no
read only = no
valid users = root, share1
writable = yes

I can login using the valid users from other linux boxes and from windows so there is no problem with the accounts of course, any help will be appreciated, thanks.

Posts: 54
Joined: 2014/12/23 11:54:42

Re: Samba problem

Postby pwd » 2018/01/09 12:16:52

check logs, maybe domain server force some unsported authentication mode
"God, root, what is difference?"

Posts: 4
Joined: 2017/12/18 11:48:35

Re: Samba problem

Postby XP_2600 » 2018/01/12 22:34:29

OK thanks, any idea which level of logging logs everything ?

Posts: 13
Joined: 2018/01/12 01:36:06

Re: Samba problem

Postby Chirpychirps77 » 2018/01/15 02:02:25

Logging levels are 0-10 for Samba. I believe you can alter the logging to just a specific user (so the logging doesn't tax your system so heavily). Maybe create a separate test user just for this purpose.