Logitech G700 wireless mouse not detected

Issues related to hardware problems
Post Reply
mazellan
Posts: 5
Joined: 2018/01/25 19:42:28

Logitech G700 wireless mouse not detected

Post by mazellan » 2018/01/25 19:56:37

Hi, I have a logitech G700 wireless mouse which can be used with cable too. It works fine with the cable plugged in, but not wireless. One solution is ofc to use the cable... but I like it better wireless :) Any ideas? I'm not so good at linux. Did some searching. dmesg gives the following output:

Code: Select all

[  381.617438] usb 5-2: USB disconnect, device number 2
[  412.272659] usb 5-2: new full-speed USB device number 3 using uhci_hcd
[  412.435799] usb 5-2: New USB device found, idVendor=046d, idProduct=c06b
[  412.435804] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  412.435807] usb 5-2: Product: G700 Laser Mouse
[  412.435810] usb 5-2: Manufacturer: Logitech
[  412.435812] usb 5-2: SerialNumber: B176040C0037
[  412.455153] input: Logitech G700 Laser Mouse as /devices/pci0000:00/0000:00:1a.2/usb5/5-2/5-2:1.0/input/input19
[  412.455746] hid-generic 0003:046D:C06B.0005: input,hidraw0: USB HID v1.11 Mouse [Logitech G700 Laser Mouse] on usb-0000:00:1a.2-2/input0
No change if I unplug/plug in the receiver. I can't see it being mounted as a device in /dev either. Before I switched to centos I was running ubuntu 14.04, and there the wireless part worked ok.

User avatar
TrevorH
Forum Moderator
Posts: 24092
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Logitech G700 wireless mouse not detected

Post by TrevorH » 2018/01/25 20:29:28

Is the xorg-x11-drv-evdev package installed?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

mazellan
Posts: 5
Joined: 2018/01/25 19:42:28

Re: Logitech G700 wireless mouse not detected

Post by mazellan » 2018/01/25 21:03:32

Yes it was;

Code: Select all

Package xorg-x11-drv-evdev-2.10.5-2.1.el7.x86_64 already installed and latest version

User avatar
TrevorH
Forum Moderator
Posts: 24092
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Logitech G700 wireless mouse not detected

Post by TrevorH » 2018/01/25 21:18:55

Is that dmesg fragment from when you plugged it in direct or from the wireless receiver?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

mazellan
Posts: 5
Joined: 2018/01/25 19:42:28

Re: Logitech G700 wireless mouse not detected

Post by mazellan » 2018/01/26 05:37:35

It was when I plugged in it directly. I get nothing when I plug in/pull out the receiver.

User avatar
TrevorH
Forum Moderator
Posts: 24092
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Logitech G700 wireless mouse not detected

Post by TrevorH » 2018/01/26 10:38:05

Then that's where the problem lies. Try a different socket. You should see something like

[1723782.507350] logitech-djreceiver 0003:046D:C52B.0031: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-2.4.1.2/input2
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

mazellan
Posts: 5
Joined: 2018/01/25 19:42:28

Re: Logitech G700 wireless mouse not detected

Post by mazellan » 2018/02/05 17:27:01

Sry for late response, been away. Trevor, it was as simple as you suggested, unplug and then plug in in a different slot :oops: Now it works

Post Reply