Need CPU support in 6.6

Issues related to hardware problems
Post Reply
Statue
Posts: 3
Joined: 2018/02/12 20:27:17

Need CPU support in 6.6

Post by Statue » 2018/02/12 20:31:24

We are trying to install CentOS 6.6 x64 on a system with a Core i7-7700K (motherboard is a Gigabyte GA-Z270X-UD3). The installer hesitates in the ACPI section, then kernel-panics before I can enter any options. If I install the OS on a different system, then move the boot drive to this system, I get the message:

Detected CPU family 6 model 158
UNSUPPORTED HARDWARE DEVICE: Intel CPU model

We need this to work in 6.6, because our SAN client software doesn't support any later 6.x version. 6.9 does install, but the SAN client doesn't function properly with that Linux version.

chemal
Posts: 423
Joined: 2013/12/08 19:44:49

Re: Need CPU support in 6.6

Post by chemal » 2018/02/12 22:55:49

Buy an old board and an old CPU that 6.6 can deal with: https://access.redhat.com/support/policy/intel.

pjsr2
Posts: 343
Joined: 2014/03/27 20:11:07

Re: Need CPU support in 6.6

Post by pjsr2 » 2018/02/13 14:46:09

6.6 was released in October 2014. Look for hardware that was on the market in or before summer 2014. Any more modern hardware (board, graphics, CPU, network cards and so on) won't fly when you intend to install 6.6.

Alternatively, run 6.6 as a virtual machine.

User avatar
TrevorH
Forum Moderator
Posts: 23653
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Need CPU support in 6.6

Post by TrevorH » 2018/02/13 14:55:23

Can't help thinking that your better option would be to fix the SAN client!
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Statue
Posts: 3
Joined: 2018/02/12 20:27:17

Re: Need CPU support in 6.6

Post by Statue » 2018/02/14 19:08:32

Anyone have any real answers? We can't buy older boards to fix the problem. We can't fix the SAN client - it is the Stornext client from Quantum. Is there a way to add the CPU to whatever file contains the supported CPU IDs so it installs? The CPU is backwards-compatible, and we don't need any new features of it. Intel has a patch, but there's no way to install it - the patch only installs on an already-running system (when I contacted Gigabyte and Intel, they say to contact CentOS). Chemal: I like how the CPU list only contains 20 compatible processors, including one i3 processor and Xeons. I guess it's not compatible with the Atom series, Pentium D-series, Celeron-D series, Avoton, or other Core processors.

User avatar
avij
Forum Moderator
Posts: 2681
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Need CPU support in 6.6

Post by avij » 2018/02/14 19:34:45

That "UNSUPPORTED HARDWARE DEVICE: Intel CPU model" is only a warning. You should be able to continue past that point. If it does not continue past that message, there's something in the CPU that breaks the installer, and merely adding your CPU ID to some list will not help. It would silence the warning, but the breakage would still be there.

According to the support matrix versions 5.3.1.x and above would support 6.7 (and possibly above). Perhaps you should try upgrading your client to a newer version.

chemal
Posts: 423
Joined: 2013/12/08 19:44:49

Re: Need CPU support in 6.6

Post by chemal » 2018/02/14 20:49:00

By the way: both your Z270-based motherboard and your Kaby Lake CPU aren't supported even by 6.9. Maximum for 6.9 is Skylake with some chipsets but not all. However, good support for your hardware should be in 7.4.

User avatar
TrevorH
Forum Moderator
Posts: 23653
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Need CPU support in 6.6

Post by TrevorH » 2018/02/14 22:52:51

Since the changelog for the Quantum software explicitly mentions both 6.9 and 7.4, I fail to see why it would not work.

You are also exposing yourself to literally hundreds of bugs by not upgrading. Some of those are severe including Meltdown/Spectre - the fixes for which require you to run the very latest kernels on both el6 and el7.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Statue
Posts: 3
Joined: 2018/02/12 20:27:17

Re: Need CPU support in 6.6

Post by Statue » 2018/02/16 01:24:34

System locks up after the "warning." I can't upgrade the stornext client - the deal on that is (and I know this sounds kind of backwards): A client version can connect to newer MDC versions, but not older. Our older MDCs are running 5.2.1. We're trying to use this client to transfer the data to the new MDCs, so we need to be connected to both the 5.2.1 MDCs as well as the 5.4.0.4 MDCs for the transfer. The 5.2.1 installation guide indicates the last 6.x client certified is now 6.7. I tried 6.7, and it just spontaneously reboots within 2 seconds after the installer starts with no error message.

tunk
Posts: 422
Joined: 2017/02/22 15:08:17

Re: Need CPU support in 6.6

Post by tunk » 2018/02/16 12:33:56

Will you retire the old system?
If so, I guess you had (still have?) a working system. Would it then be possible to setup the new system and use e.g. NFS to transfer the data?

Post Reply