gnome-keyring-devel.x86_64 dependency failing install on Centos 7

General support questions
Post Reply
jaypubell
Posts: 4
Joined: 2019/04/18 15:38:17

gnome-keyring-devel.x86_64 dependency failing install on Centos 7

Post by jaypubell » 2019/04/19 16:30:59

Hi,
I'm new to centos 7 and Linux in general. I managed to install Centos7 with my nvidia GPU and Davinci resolve 16 to use my machine as a video station.
I am trying to install the drivers for my EIZO CG248-4K monitor that I got from EIZO sales/service support (supposedly compatible with RHEL/Centos) and running into issue when installing it with this:

Installing gnome-keyring-devel.x86_64 and gnome-keyring-devel.i686...
Error: Nothing to do
Failed to install gnome-keyring-devel.x86_64 and gnome-keyring-devel.i686.
Failed.

Thought gnome-keyring seems to be already installed on my machine:

Installed Packages
gnome-keyring.i686 3.28.2-1.el7 @base
gnome-keyring.x86_64 3.28.2-1.el7 @base

I tried re-installing but nothing has worked so far, and Eizo support has not been of much help, can anyone help me with this?

Best,

User avatar
TrevorH
Forum Moderator
Posts: 26955
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: gnome-keyring-devel.x86_64 dependency failing install on Centos 7

Post by TrevorH » 2019/04/20 13:45:07

You don't need drivers for monitors on Linux.

What is the actual problem you are trying to fix?

You need to show the entire output from any failing commands, all the way through from the command itself that you enter, right the way through until the command prompt returns.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

jaypubell
Posts: 4
Joined: 2019/04/18 15:38:17

Re: gnome-keyring-devel.x86_64 dependency failing install on Centos 7

Post by jaypubell » 2019/04/20 14:51:45

I have two monitors, one plugged into my nvidia GTX1080 that works. My second monitor is plugged into a dedicated graphics card from Back Magic Design that works with Davinci resolve that I use for color grading. The monitor currently works through this card as well.

But this particular monitor is capable of displaying multiple color profiles and can self-calibrate. The software that allows to control it is what I am trying to install and where I'm having issues. The software is called ColorNavigator NX.

Here is the entire output:

[root@localhost ~]# '/home/jay/Downloads/nav2/ColorNavigator/install_nx.sh'
To continue installing the software you must agree to the terms of the software license agreement(eula/EULA).
Do you agree?[Y/n] : y
rm -rf /opt/EIZO/ColorNavigator NX Core/bin
rm /etc/rc5.d/S99cnnx_eacore_daemon
rm /etc/init.d/cnnx_eacore_daemon
rm -r /var/opt/EIZO/ColorNavigator NX/bin
rm -r /libs
rm /var/opt/EIZO/ColorNavigator NX/CNConfig.xml
rm /var/opt/EIZO/ColorNavigator NX/InstallOption.xml
rm /var/opt/EIZO/ColorNavigator NX/uninstall_nx.sh

gtk2-devel.x86_64
rpm-devel.x86_64
gnome-keyring-devel.x86_64
libXt.x86_64
libxml2-devel.x86_64
nss-devel.x86_64
PackageKit-gtk-module.x86_64
libcanberra-gtk2.x86_64
libusb.x86_64
gtk2-engines.x86_64
openssl.x86_64
libudev.x86_64
ld-linux.so.2
gtk2-devel.i686
libhal.so.1
rpm-devel.i686
gnome-keyring-devel.i686
libXt.i686
libDCOP.so.4
libxml2-devel.i686
nss-devel.i686
PackageKit-gtk-module.i686
libcanberra-gtk2.i686
libusb.i686
gtk2-engines.i686
openssl.i686
libudev.i686

Are you sure to install dependent packages above?[Y/n]
y
Installing ld-linux.so.2...
Package glibc-2.17-260.el7_6.4.i686 already installed and latest version
Installing gtk2-devel.x86_64 and gtk2-devel.i686...
Package gtk2-devel-2.24.31-1.el7.x86_64 already installed and latest version
Package gtk2-devel-2.24.31-1.el7.i686 already installed and latest version
Installing libhal.so.1...
Installing rpm-devel.x86_64 and rpm-devel.i686...
Package rpm-devel-4.11.3-35.el7.x86_64 already installed and latest version
Package rpm-devel-4.11.3-35.el7.i686 already installed and latest version
Installing gnome-keyring-devel.x86_64 and gnome-keyring-devel.i686...
Error: Nothing to do
Failed to install gnome-keyring-devel.x86_64 and gnome-keyring-devel.i686.
Failed.
[root@localhost ~]#


I had an update from Eizo saying this driver is only compatible with Red Hat Enterprise Linux 6 & 7. I saw online that some people were able to install it on Centos6, but couldn't find much more information.

chemal
Posts: 606
Joined: 2013/12/08 19:44:49

Re: gnome-keyring-devel.x86_64 dependency failing install on Centos 7

Post by chemal » 2019/04/20 15:41:34

https://www.eizoglobal.com/products/col ... index.html

Here they claim to have a more recent version for Red Hat Enterprise Linux 7 (64-bit). What you got seems to be an older version for Red Hat Enterprise Linux 6 (32-bit). Maybe you should ask again.

jaypubell
Posts: 4
Joined: 2019/04/18 15:38:17

Re: gnome-keyring-devel.x86_64 dependency failing install on Centos 7

Post by jaypubell » 2019/04/20 16:22:51

I sent them an email, I'll see what they say.

Thank you for looking into this

jaypubell
Posts: 4
Joined: 2019/04/18 15:38:17

Re: gnome-keyring-devel.x86_64 dependency failing install on Centos 7

Post by jaypubell » 2019/04/22 22:57:53

Just as an update, Eizo indeed sent me a newer version for ColorNavigator 7 and this version does work in CentOS 7.

Thank you for your help.

Post Reply

Return to “CentOS 7 - General Support”