Grey Screen during Install Of CentOS on VirtualBox

General support questions
Post Reply
dreafizz
Posts: 1
Joined: 2019/05/19 03:25:56
Location: Arizona

Grey Screen during Install Of CentOS on VirtualBox

Post by dreafizz » 2019/05/19 03:41:58

I am trying to Install CentOS 7 on a VirtualBox for the first time on My HP Pavillion running Windows 10 home. I have Already ensured that the Bios Enabled Virtualization so that proper installation could occur as that was an original setback. Now it seems I am all ready to go, but whenever I go to actually start the Install I get stuck on a grey screen and it will go no further. Here is what I have done so far:
Created a new virtual machine with the following settings:

Name: CentoOS 7
Type: Linux
Version: Red Hat (64-bit)
Memory Size: I chose 2048MB
Hard Disk: VDI, Dynamically Allocated, Size – 20GB

Added the ISO Image to My New Virtual Machine

Went to start install...and bam Grey screen of foreverness! :cry:
Attachments
grey screen 3.JPG
grey screen 3.JPG (26.5 KiB) Viewed 563 times
grey screen 2.JPG
grey screen 2.JPG (41.14 KiB) Viewed 563 times
grey screen issue.png
Oracle VM box specs
grey screen issue.png (222.5 KiB) Viewed 603 times
DreaFizz :mrgreen:

prabhakarpujeri
Posts: 5
Joined: 2019/05/21 15:01:05
Location: India

Re: Grey Screen during Install Of CentOS on VirtualBox

Post by prabhakarpujeri » 2019/05/22 06:42:26

try with kernel command line parameter nomodeset

EXXODIS
Posts: 2
Joined: 2019/08/01 15:03:31

Re: Grey Screen during Install Of CentOS on VirtualBox

Post by EXXODIS » 2019/08/01 15:09:41

Same problem. Trying to install CentOS-7-x86_64-DVD-1810.iso on VirtualBox (Version 6.0.4).
Everything set to default. I run it and it shows a bootscreen, then goes to a light gray screen with a blinking white cursor.
I can't type and it usually freezes. I've been running Centos 7 on my PC for the past 4 months and I now it doesn't work.
I think the problem started when I set my PC's bios settings to default on accident. So it has to be something on my computers settings, maybe?
Also, this works on my laptop, and I have used the same settings on virtualbox when I go to install CentOS 7 but it doesn't work.

Things I've Done:
-Uninstalled and re-installed VirtualBox (both ver 6.0.4 and current ver)
-Deleted and re-downloaded Centos 7 ISO
-Enables virtualization in my BIOS settings

User avatar
TrevorH
Forum Moderator
Posts: 26307
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Grey Screen during Install Of CentOS on VirtualBox

Post by TrevorH » 2019/08/01 15:26:43

Did you check the sha256sum of your downloaded file against the list in the CentOS 7.6 release notes on the wiki? How much RAM did you give your VM?
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

EXXODIS
Posts: 2
Joined: 2019/08/01 15:03:31

Re: Grey Screen during Install Of CentOS on VirtualBox

Post by EXXODIS » 2019/08/01 17:27:02

My download file is right. I've compared it to my working version on my laptop and everything with VirtualBox and the CentOS 7 file is correct. And I used the default amount of RAM, and then I've tested it at higher capacities of allocated RAM.

That means it has to be something wrong with my computer? Maybe a Windows 10 setting or something with my BIOS.

User avatar
TrevorH
Forum Moderator
Posts: 26307
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Grey Screen during Install Of CentOS on VirtualBox

Post by TrevorH » 2019/08/01 17:34:51

The only way to tell if your download is correct is to sha256sum it and check.

https://wiki.centos.org/Manuals/Release ... ntOS7.1810

I have no idea what the "default amount of RAM" is and it probably varies depending on how much you have installed on the host. You need to check it and see. The bare minimum required is 1280MB but 2GB is better.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply