Skype 8.45.0.41-1 not working

Issues related to applications and software problems
Post Reply
tedc
Posts: 17
Joined: 2007/12/09 18:27:05

Skype 8.45.0.41-1 not working

Post by tedc » 2019/05/23 16:48:29

I just updated Skype 8.45.0.41-1 on a PC running CentOS 7.6.1810 with the latest updates. Result: Skype no longer works. Uninstalled it, then installed from the rpm (which completed without error messages), and still doesn't work. Anybody else have a similar problem?

User avatar
TrevorH
Forum Moderator
Posts: 25799
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Skype 8.45.0.41-1 not working

Post by TrevorH » 2019/05/23 19:52:52

Yes, everyone that runs CentOS.

Skype have shipped an update that requires glibc 2.18 when CentOS/RHEL 8 ship with glibc 2.17. You cannot run the newer skype on CentOS 7 and you need to complain to Skype about it as there is nothing that we can do (glibc on CentOS 7 will never be anything other than 2.17).

The last known working version was skypeforlinux-8.34.0.78-1.x86_64 and I think it broke when they shipped 8.40.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

schadfield
Posts: 33
Joined: 2014/12/21 01:03:40

Re: Skype 8.45.0.41-1 not working

Post by schadfield » 2019/05/29 05:33:56

You can install Skype from here on CentOS 7: https://www.flathub.org/apps/details/com.skype.Client

odysseus
Posts: 64
Joined: 2014/09/14 16:55:22

Re: Skype 8.45.0.41-1 not working

Post by odysseus » 2019/06/03 12:11:14

The latest release of CentOS supports the latest release of Skype.

User avatar
TrevorH
Forum Moderator
Posts: 25799
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Skype 8.45.0.41-1 not working

Post by TrevorH » 2019/06/03 14:48:31

More accurately it looks like they have rebuilt it so it no longer depends on a newer glibc than we ship so skype now supports running on CentOS 7 again.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply