CentOS 6 - Warning: Group development-tools does not exist.

General support questions
Post Reply
postcd
Posts: 19
Joined: 2014/10/11 11:45:27

CentOS 6 - Warning: Group development-tools does not exist.

Post by postcd » 2019/08/10 12:04:19

OS:
CentOS 6.10 64bit

Tried commands:
yum install @development-tools
yum groupinstall development-tools

Result:
Warning: Group development-tools does not exist.

There are base, extras, updates and bootstrap EPEL repos

This is a few years old server, maybe not all updates are there.

I want to ask for help on how to fix it? Thank you in advance

User avatar
TrevorH
Forum Moderator
Posts: 26300
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6 - Warning: Group development-tools does not exist.

Post by TrevorH » 2019/08/10 14:02:39

Code: Select all

[root@c6test ~]# yum grouplist | grep -i devel
   Additional Development
   Desktop Platform Development
   Development tools
   Server Platform Development
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
jlehtone
Posts: 2237
Joined: 2007/12/11 08:17:33
Location: Finland

Re: CentOS 6 - Warning: Group development-tools does not exist.

Post by jlehtone » 2019/08/11 11:27:18

The "short" group names:

Code: Select all

# yum -v grouplist | grep -i devel
   Additional Development (additional-devel)
   Desktop Platform Development (desktop-platform-devel)
   Development tools (development)
   Server Platform Development (server-platform-devel)
Two valid names for that group:

Code: Select all

yum groupinfo "Development tools"
yum groupinfo development

postcd
Posts: 19
Joined: 2014/10/11 11:45:27

Re: CentOS 6 - Warning: Group development-tools does not exist.

Post by postcd » 2019/08/14 14:12:08

Hello both and thanks for the reply. I tried:

# yum groupinstall "Development tools"

That ended in error:

Code: Select all

Transaction Check Error:
  file /usr/share/man/man7/stappaths.7.gz from install of systemtap-devel-2.9-9.el6.x86_64 conflicts with file from package systemtap-runtime-2.9-7.el6.x86_64
  file /usr/share/man/man7/stappaths.7.gz from install of systemtap-client-2.9-9.el6.x86_64 conflicts with file from package systemtap-runtime-2.9-7.el6.x86_64
This is my grouplist:

# yum -v grouplist | grep -i devel

Code: Select all

   Additional Development (additional-devel)
   Development tools (development)
   Desktop Platform Development (desktop-platform-devel)
   Server Platform Development (server-platform-devel)
Then i tried: "yum groupinstall development" and same error. So i searched and tried:

yum update systemtap\*;yum upgrade systemtap\*

but:

Code: Select all

Transaction Check Error:
  package systemtap-runtime-2.9-9.el6.x86_64 is already installed
I was running "yum info systemtap-runtime" and "yum info systemtap-client" and it said Repo is base and Installed.

I tried to remove it: yum remove systemtap-client systemtap-devel

it removed:

Code: Select all

  Erasing    : systemtap-2.9-7.el6.x86_64                                                                                                                                                1/3
  Erasing    : systemtap-client-2.9-7.el6.x86_64                                                                                                                                         2/3
  Erasing    : systemtap-devel-2.9-7.el6.x86_64
but yum groupinstall development which triggers installation of new systemptap packages continue to complain:

Code: Select all

Transaction Check Error:
  file /usr/share/man/man7/stappaths.7.gz from install of systemtap-devel-2.9-9.el6.x86_64 conflicts with file from package systemtap-runtime-2.9-7.el6.x86_64
  file /usr/share/man/man7/stappaths.7.gz from install of systemtap-client-2.9-9.el6.x86_64 conflicts with file from package systemtap-runtime-2.9-7.el6.x86_64

User avatar
TrevorH
Forum Moderator
Posts: 26300
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6 - Warning: Group development-tools does not exist.

Post by TrevorH » 2019/08/14 14:55:11

file /usr/share/man/man7/stappaths.7.gz from install of systemtap-devel-2.9-9.el6.x86_64 conflicts with file from package systemtap-runtime-2.9-7.el6.x86_64
You appear to already have systemtap-runtime-2.9-7.el6.x86_64 installed. Remove it first.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

postcd
Posts: 19
Joined: 2014/10/11 11:45:27

Re: CentOS 6 - Warning: Group development-tools does not exist.

Post by postcd » 2019/08/14 15:24:36

yes, that worked.

yum remove systemtap-runtime

Code: Select all

Removed:
systemtap-runtime.x86_64 0:2.9-7.el6
systemtap-runtime.x86_64 0:2.9-9.el6                                                                 
yum groupinstall development
then succeeded.

Thank you! :idea:

Post Reply