Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Issues related to hardware problems
Post Reply
vijayvithal
Posts: 4
Joined: 2018/04/17 15:50:27

Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by vijayvithal » 2019/09/20 15:10:31

The listing from various commands is as below

Code: Select all

lspci -nn|grep -i net
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
02:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)

grep -i 168c /lib/modules/$(uname -r)/modules.*|grep -i 0042
/lib/modules/3.10.0-1062.1.1.el7.x86_64/modules.alias:alias pci:v0000168Cd00000042sv*sd*bc*sc*i* ath10k_pci

 iwconfig
lo        no wireless extensions.

enp1s0    no wireless extensions.


 rfkill list
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: acer-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no


lsb_release -a
LSB Version:	:core-4.1-amd64:core-4.1-noarch
Distributor ID:	CentOS
Description:	CentOS Linux release 7.7.1908 (Core)
Release:	7.7.1908
Codename:	Core


uname -a
Linux Dyumnin 3.10.0-1062.1.1.el7.x86_64 #1 SMP Fri Sep 13 22:55:44 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


User avatar
toracat
Forum Moderator
Posts: 7388
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by toracat » 2019/09/20 23:49:25

Is the module ath10k_pci listed in lsmod?
Do you see any errors/hints in dmesg?
CentOS Forum FAQ

darkballs
Posts: 1
Joined: 2019/09/21 03:40:44

Re: Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by darkballs » 2019/09/21 03:49:25

I just installed CentOS 7.7 on a machine using this WiFi card and I am experiencing the same issue.

My card is listed under lspic and lshw:

Code: Select all

$ sudo lshw -C network

  *-network                 
       description: Network controller
       product: QCA9377 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 31
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=ath10k_pci latency=0
       resources: irq:134 memory:b4200000-b43fffff
And the drivers are shown here from lsmod:

Code: Select all

$ lsmod | grep ath10k

ath10k_pci             47418  0 
ath10k_core           325711  1 ath10k_pci
ath                    33542  1 ath10k_core
mac80211              718956  1 ath10k_core
cfg80211              632335  3 ath,mac80211,ath10k_core
Does this information shed light on any issues? I can give more output if needed.

vijayvithal
Posts: 4
Joined: 2018/04/17 15:50:27

Re: Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by vijayvithal » 2019/09/21 06:44:08

lsmod returns

Code: Select all

lsmod|grep ath
ath10k_pci             47418  0 
ath10k_core           325711  1 ath10k_pci
ath                    33542  1 ath10k_core
mac80211              718956  1 ath10k_core
cfg80211              632335  3 ath,mac80211,ath10k_core

hmm.... dmesg indicates some error

Code: Select all

dmesg|grep ath
[   16.870430] ath10k_pci 0000:02:00.0: irq 43 for MSI/MSI-X
[   16.870514] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   17.243408] ath10k_pci 0000:02:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 11ad:08a6
[   17.243419] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[   17.244339] ath10k_pci 0000:02:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[   20.318059] ath10k_pci 0000:02:00.0: unable to read from the device
[   20.318070] ath10k_pci 0000:02:00.0: could not execute otp for board id check: -110
[   20.318076] ath10k_pci 0000:02:00.0: failed to get board id from otp: -110
[   20.318171] ath10k_pci 0000:02:00.0: could not probe fw (-110)


ricardomaguiar
Posts: 2
Joined: 2019/09/23 14:35:53

Re: Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by ricardomaguiar » 2019/09/23 14:37:58

I have the same problem.
did you solve this problem?

Dennis2
Posts: 1
Joined: 2016/11/30 08:48:24

Re: Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by Dennis2 » 2019/09/23 19:06:51

Since no one has posted a fix here is a link to another forum with a fix.

https://www.linuxquestions.org/question ... ost6039859

Dennis

dcmb
Posts: 1
Joined: 2019/09/23 14:55:08

Re: Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by dcmb » 2019/09/23 23:49:15

Same here. If anyone knows the solution, please share. My laptop is Lenovo Ideapad 330, wifi card also Atheros QCA9377. Everything worked fine before latest update.

edit:
Thank you Dennis. I didn't see your post yesterday. Removing firmware-6.bin and notice_ath10k_firmware-6.txt worked! Yeaaah:))

vijayvithal
Posts: 4
Joined: 2018/04/17 15:50:27

Re: Wifi Qualcomm Atheros QCA9377 stopped working after upgrade to centos 7.7

Post by vijayvithal » 2019/09/24 12:21:12

@darkballs, @ricardomaguiar, @dcmb,
I tried the fix listed by @Dennis2 and it worked for me.

Post Reply

Return to “CentOS 7 - Hardware Support”