Missing epel packages

Issues related to applications and software problems and general support
haiopeis
Posts: 1
Joined: 2019/09/25 11:38:16

Missing epel packages

Post by haiopeis » 2019/09/25 11:41:26

Hi,

it looks like there are some packages missing compared to CentOS 7.
In my case: tig and etckeeper
Does anyone know which repo I have to activate for them?

Thanks

User avatar
TrevorH
Forum Moderator
Posts: 27152
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Missing epel packages

Post by TrevorH » 2019/09/25 20:19:30

Many developers for EPEL rely on having a CentOS machine on which to build and test packages. That means that the process is a bit horse and cart so one has to be there for the other to be provided. Hopefully now that CentOS 8 is out, EPEL will catch up fairly quickly.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

MartyCZ
Posts: 6
Joined: 2018/04/18 15:46:28

Re: Missing epel packages

Post by MartyCZ » 2019/09/27 15:35:26

I am waiting too. I need httpd-itk, opendkim, opendmarc and postgrey. ;)

simaqs
Posts: 3
Joined: 2019/09/25 06:10:41

Re: Missing epel packages

Post by simaqs » 2019/09/30 03:53:16

I need ntfs-3g!

schadfield
Posts: 43
Joined: 2014/12/21 01:03:40

Re: Missing epel packages

Post by schadfield » 2019/09/30 11:02:51

I lost gajim, KeePass2, sshpass, optipng, duplicity. No Qt4 means Beyond Compare won't run.

On the other hand I have newer versions of a bunch of other packages and I got my NetBeans + GlassFish development environment up and running pretty quickly so I can continue with the day job.

ikewinski
Posts: 1
Joined: 2019/10/01 15:26:17

Re: Missing epel packages

Post by ikewinski » 2019/10/01 15:28:15

Is there a way to get notices when packages are added to EPEL?

In addition to opendkim, I'm looking for dovecot-pigeonhole

simaqs
Posts: 3
Joined: 2019/09/25 06:10:41

Re: Missing epel packages

Post by simaqs » 2019/10/01 23:05:02

simaqs wrote:
2019/09/30 03:53:16
I need ntfs-3g!
I used the fedora28’s package and it worked!

User avatar
centminmod
Posts: 44
Joined: 2014/07/12 14:28:06
Location: Brisbane, Australia
Contact:

Re: Missing epel packages

Post by centminmod » 2019/10/02 00:40:31

ikewinski wrote:
2019/10/01 15:28:15
Is there a way to get notices when packages are added to EPEL?

In addition to opendkim, I'm looking for dovecot-pigeonhole
EPEL 8 info might be at https://fedoraproject.org/wiki/Infrastr ... 020/EPEL-8

EPEL 8 issue tracker https://pagure.io/epel/
Issue tracker for EPEL (Extra Packages for Enterprise Linux)
The EPEL trac is meant for tracking work needed on packages in the various EPEL repositories. Items to be reported are problems with packages over-riding core RHEL/CentOS packages, packages needed to be branched to EPEL, clarifications on policy that need to be dealt with in weekly meetings, and agendas of weekly meetings. Problems NOT to be reported are bugs in packages. These need to be filed in ​Red Hat Bugzilla.
and I assume the same for EPEL 8 https://fedoraproject.org/wiki/EPEL/FAQ ... _EPEL-6.3F
Why isn't a package in EPEL-7 when it is in EPEL-6?
Packages are not automatically branched for each EPEL version. Each package must be branched by a packager for each particular release, and packagers may or may not be interested in EPEL-7 while they were interested in EPEL-6. If you are an EPEL-7 user and you want an EPEL-7 branch, it's a good idea to ask the existing EPEL or Fedora maintainer. This lets the current maintainer know that there are real users who would benefit from the package (instead of simply guessing at the size of the user base).

The preferred method of asking a maintainer for an EPEL-7 branch is to file a ticket in bugzilla against the "el6" version of your package. If there is no el6 version, use the Rawhide version instead.

If you want to check the current ownership of a package (perhaps to contact the owner directly), you can search pkgdb. You can also use zodbot on IRC to query pkgdb on your behalf:

wp.rauchholz
Posts: 112
Joined: 2016/11/20 11:58:45

Re: Missing epel packages

Post by wp.rauchholz » 2019/10/04 16:06:52

simaqs wrote:
2019/09/30 03:53:16
I need ntfs-3g!
That fixed it fir me:
https://linuxconfig.org/how-to-install- ... n-redhat-8

simaqs
Posts: 3
Joined: 2019/09/25 06:10:41

Re: Missing epel packages

Post by simaqs » 2019/10/05 12:13:13

I also need rtorrent and I faild to build it!

Post Reply

Return to “CentOS 8 - General Support”