Server refused to allocate pty

General support questions
Post Reply
jvdwesthuizen
Posts: 4
Joined: 2019/10/04 22:41:42

Server refused to allocate pty

Post by jvdwesthuizen » 2019/10/04 22:52:25

Hi,

I'm running asterisk on a centos6.6 in a proxmox virtual inviroment, I moved the container from 1 node to anotehr and now I'm getting this error: "server refused to allocate pty", tried a couple of things but wasn't successful.

Any help would be appreciated.

Thanks.

User avatar
TrevorH
Forum Moderator
Posts: 27125
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Server refused to allocate pty

Post by TrevorH » 2019/10/04 22:57:00

You shouldn't be running CentOS 6.6 in the first place! It's from 2014 so is now 5 years old and absolutely riddled with high severity security bugs. You should be running yum update on a regular basis - like weekly - not once every 5 years!

The current version is 6.10 and only has about 1 more year of life left in it. You'll want to be looking at migrating to 7 or 8 sooner rather than later.

Run yum update to get up to date, reboot and see if the issue persists.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

jvdwesthuizen
Posts: 4
Joined: 2019/10/04 22:41:42

Re: Server refused to allocate pty

Post by jvdwesthuizen » 2019/10/05 23:33:36

Hi,

Thanks for the reply and update.

I followed your advice but it's still the same after the update and reboot, still getting the error when trying to ssh directly.

Any other option I can try to fix this?

Thanks.

jvdwesthuizen
Posts: 4
Joined: 2019/10/04 22:41:42

Re: Server refused to allocate pty

Post by jvdwesthuizen » 2019/10/08 09:52:51

Hi,

So I think I messed up here, asterisk is not showing as it should and if I login it logs me out.

Can I revert back to the previous version, jsut for now or what option s do I have?

Thanks.

aks
Posts: 2859
Joined: 2014/09/20 11:22:14

Re: Server refused to allocate pty

Post by aks » 2019/10/08 16:54:41

Hell it's been such a long time now. In C6 I think it's still mingetty who allocations the them - perhaps have a look in /etc/inittab (but be careful), otherwise have a look in the mingetty rpm for config files (and if it's not mingetty then it'll probably be a package with tty in the name).

jvdwesthuizen
Posts: 4
Joined: 2019/10/04 22:41:42

Re: Server refused to allocate pty

Post by jvdwesthuizen » 2019/10/20 22:12:20

Hi,

Fixed the login issues but still have the tty issue when ssh'ing into the vm.

What other options could I try to fix this.

Thanks in advance.

aks
Posts: 2859
Joined: 2014/09/20 11:22:14

Re: Server refused to allocate pty

Post by aks » 2019/10/23 17:40:55

If you stil don't have enough ttys increase them (but also understand why this is the case) - see previous post(s)

Post Reply

Return to “CentOS 6 - General Support”