[SOLVED] ImageMagick 6.8

Issues related to applications and software problems
Post Reply
marcoza
Posts: 22
Joined: 2012/12/07 00:02:32

[SOLVED] ImageMagick 6.8

Post by marcoza » 2013/05/13 10:18:35

Hi,
I want to open this topic because after long research, trying in every mode I have trouble installing last version of Image Magick on CentOS 6.4.

First of all after quick base repository check I found that the version of ImageMagick available is 6.5.4.7-6.el6_2 and php-pecl is 3.1.0-0.9.RC2.el6.remi from Remi repository.

The version of Pecl is fine for me but ImageMagick is too outdated.


So I proceed following this three directions:

1. I configured Remi repository and launch this command:
yum --enablerepo=remi install ImageMagick2

which give following output

No package ImageMagick2 available.

-------------------------------------------------------------------------------------------------------

2. I downloaded the RPM directly from ImageMagick website v. 6.8 for both ImageMagick and ImageMagick-devel for 64bit
Tried to install both with this command:
yum localinstall ImageMagick-6.8.5-6.x86_64.rpm
yum localinstall ImageMagick-devel-6.8.5-6.x86_64.rpm

Both failed with this output

Error: Package: ImageMagick-6.8.5-6.x86_64 (/ImageMagick-6.8.5-6.x86_64)
Requires: libltdl.so.3()(64bit)
Error: Package: ImageMagick-6.8.5-6.x86_64 (/ImageMagick-6.8.5-6.x86_64)
Requires: libImath.so.4()(64bit)
Error: Package: ImageMagick-6.8.5-6.x86_64 (/ImageMagick-6.8.5-6.x86_64)
Requires: libIex.so.4()(64bit)
Error: Package: ImageMagick-6.8.5-6.x86_64 (/ImageMagick-6.8.5-6.x86_64)
Requires: libHalf.so.4()(64bit)
Error: Package: ImageMagick-6.8.5-6.x86_64 (/ImageMagick-6.8.5-6.x86_64)
Requires: libIlmImf.so.4()(64bit)
You could try using --skip-broken to work around the problem
** Found 25 pre-existing rpmdb problem(s), 'yum check' output follows:
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of ImageMagick = ('0', '6.8.5', '6')
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of ImageMagick-libs = ('0', '6.8.5', '6')
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of bzip2-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of freetype-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of ghostscript-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of jasper-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of lcms-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libICE.so.6()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libSM.so.6()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libX11-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libXext-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libXext.so.6()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libXt-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libXt.so.6()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libfftw3.so.3()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libfontconfig.so.1()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libgomp.so.1()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libgomp.so.1(GOMP_1.0)(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libgomp.so.1(OMP_1.0)(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libjpeg-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of liblcms.so.1()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libltdl.so.3()(64bit)
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of libtiff-devel
ImageMagick-devel-6.8.5-6.x86_64 has missing requires of pkgconfig
php54w-mcrypt-5.4.15-1.w6.x86_64 has installed conflicts php-mcrypt = ('0', '5.4.15', '1.w6'): php54w-mcrypt-5.4.15-1.w6.x86_64

-------------------------------------------------------------------------------------------------------

3. Last thing I tried is following the guide of dberebi on this post https://www.centos.org/modules/newbb/viewtopic.php?topic_id=35496&forum=38&post_id=160054#forumpost160054

I installed the kbsingh-CentOS-Misc repo, but after launching this command
yum install ImageMagick.x86_64 ImageMagick-devel.x86_64

what I get on list is still:
ImageMagick x86_64 6.5.4.7-6.el6_2 base 1.7 M



Please help me solve this and install ImageMagick 6.8 with Pecl 3.1 :-?


Thanks in advance
Marco

User avatar
toracat
Forum Moderator
Posts: 7356
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

[SOLVED] ImageMagick 6.8

Post by toracat » 2013/05/13 16:53:28

If you are already using the remi repository, you might want to check out what they offer as 'ImageMagick-last' . It's version is 6.8.3.9-1.el6 and sounds as if this is a newer version of ImageMagick. (???)

marcoza
Posts: 22
Joined: 2012/12/07 00:02:32

Re: ImageMagick 6.8

Post by marcoza » 2013/05/13 17:25:27

Hi Akemi,
thank you very much for the suggestion, I was trying to install obsolete remi package ImageMagick2.
I launched command

yum --enablerepo=remi install ImageMagick-last

and correctly installed ImageMagick 6.8.4.6-1.el6.remi



Now the problem is php-pecl-imagick. I launch this command:

yum --enablerepo=remi install php-pecl-imagick

Which mean to install php-pecl-imagick 3.1.0-0.9.RC2.el6.remi, the problem is that when installation process start it will be interrupted by the following error:

ERROR with rpm_check_debug vs depsolve:
php(zend-abi) = 20100525-x86-64 is needed by php-pecl-imagick-3.1.0-0.9.RC2.el6.remi.x86_64
php(api) = 20100412-x86-64 is needed by php-pecl-imagick-3.1.0-0.9.RC2.el6.remi.x86_64
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
php54w-mcrypt-5.4.15-1.w6.x86_64 has installed conflicts php-mcrypt = ('0', '5.4.15', '1.w6'): php54w-mcrypt-5.4.15-1.w6.x86_64


So I have made a quick check and I have installed php54w-common from webtatic which should include both php-api and php-zend-abi.

I don't understand where is the issue but installation of imagick don't want to go further.


Thanks in advance for any help.
Marco :-) :-)

User avatar
TrevorH
Forum Moderator
Posts: 26129
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: ImageMagick 6.8

Post by TrevorH » 2013/05/13 18:17:54

You cannot mix and match your php packages, you have to take them all from the same repo.

marcoza
Posts: 22
Joined: 2012/12/07 00:02:32

Re: ImageMagick 6.8

Post by marcoza » 2013/05/13 19:02:16

Trevor,
you are right ;-) I made a big mistake, I now removed webatic php version and reinstalled remi version, than fire php-pecl package, and it work wonderful !


Thanks again
Marco

:-)

Post Reply