juniper vpn

General support questions

juniper vpn

Postby slaterson » 2011/08/02 04:59:20

just installed centos 6, x86_64. i am testing centos in an effort to get my employer's vpn up and running in something other than windows. we use juniper vpn, so far i've installed oracle jre successfully (64 bit). next, i tried the vpn, which downloaded and 'installed' the client as expected, however it doesn't actually connect. after doing some searching, i found that ncsvc, the network connect client, can be tested from the command line. when i run it, i get a missing library error:

bash: ./ncsvc: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

sure enough, /lib/ld-linux.so.2 is missing. there is a /lib64/ld-linux-x86-64.so.2, of course. after some more searching, i found some info that pointed to installing glibc.i686 using yum. there doesn't seem to be a package for this... i also found some notes regarding how to add a 32 bit repo by adding the following to /etc/yum.repos.d/CentOS-Base.repo:

[base32]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=i386&repo=os
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

i tried this, no luck.

has anyone got the juniper vpn working in centos 6? i need help... feels like i'm close.
slaterson
 
Posts: 1
Joined: 2011/08/02 04:48:59

Re: juniper vpn

Postby r_hartman » 2011/08/02 09:57:27

Welcome to the CentOS fora. New users are encouraged to follow the links in my signature.

Don't know juniper, and don't have a CentOS box available at the moment, but on a RHEL6.1 box I do have that library:
Code: Select all
# yum provides \*/ld-linux.so.2
Loaded plugins: rhnplugin
glibc-2.12-1.7.el6.i686 : The GNU libc libraries
Repo        : base
Matched from:
Filename    : /lib/ld-linux.so.2

<snip quite a few entries>

glibc-2.12-1.25.el6.i686 : The GNU libc libraries
Repo        : installed
Matched from:
Filename    : /lib/ld-linux.so.2

So it's provided by glibc.i686

Code: Select all
# yum list installed glibc
Loaded plugins: rhnplugin
Installed Packages
glibc.i686                                     2.12-1.25.el6                                   @rhel-x86_64-server-6
glibc.x86_64                                   2.12-1.25.el6                                   @rhel-x86_64-server-6

Both glibc's come from the x86_64 repository, as shown.

The library reference itself is a symbolic link:
Code: Select all
# ls -l /lib/ld-linux.so.2
lrwxrwxrwx 1 root root 10 Jun  6 12:47 /lib/ld-linux.so.2 -> ld-2.12.so


Hope this helps.
r_hartman
 
Posts: 701
Joined: 2009/03/23 15:08:11
Location: Netherlands

juniper vpn

Postby simpfeld » 2011/08/02 09:59:29

We have the Juniper SSL VPN working on RHEL6. So should be no real problem on Centos 6 I'd have thought.

The Juniper SSL VPN used to not support 64 bit Java, maybe that's been fixed. But given the until very recent problems with getting a good 64 bit flash we tend to use 32 bit firefox on 64 bit machines. Your repo looks the right sort of thing but I guess you'll need the updates repo too.

My notes for Fedora (which is pretty much how we got RHEL6 working), say:

Remove firefox.x86_64 and installed firefox.i686 (and dependencies).

For SSL VPN we also installed libXtst.i686 and xterm (I think 64 bit is fine for this).

yum install libcurl.i686 gtk2-engines.i686 alsa-plugins-pulseaudio.i686 PackageKit-gtk-module.i686 (and dependencies)

For 32 bit Google Chrome, we also needed pam.i686 (just for information).


Then on top this 32 bit firefox we use the standard 32 bit Java.

Might help you.
simpfeld
 
Posts: 21
Joined: 2008/07/11 17:51:50


Return to CentOS 6 - General Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 5 guests