Unable to create partitionable Raid1

General support questions

Unable to create partitionable Raid1

Postby bearbo » 2011/08/16 20:20:25

Hello,

I previously was able to install CentOS 5 on a partitionable raid1 following this instruction:http://wiki.centos.org/HowTos/Install_On_Partitionable_RAID1.

Recently, I just installed a CentOS 6 on a new system, and was trying to follow the same instruction, but was stuck at step 5. When I tried to mount the array using:

bash-4.1# mount /dev/md_d0p1 /mnt/sysimage
mount: you must specify the filesystem type

Earlier in the process, when I was creating the raid, mdadm was complaining that a partition table already existed on /dev/sda:

bash-4.1# mdadm --create --level=1 --raid-devices=2 /dev/md_d0 /dev/sda missing
mdadm: partition table exists on /dev/sda but will be lost or meangless after creating array
mdadm: Note: this array ahs metadata ath the start and may not be suitable as a boot device. If you plan to store '/boot' on this device please ensure that your boot-loader understand md/v1.x metadata, or use --metadata=0.98
Continue creating array? y
mdadm: Defaulting to version 1.2 metadata
mdadm: array /dev/md_d0 started
bash-4.1#

I don't know if these two are related.

Any help is appreciated!!
bearbo
 
Posts: 9
Joined: 2011/08/16 20:13:23

Unable to create partitionable Raid1

Postby WhatsHisName » 2011/08/17 01:06:09

Have not looked into it, but I assume mdadm natively supports partitionable arrays under EL6.

From the madam manpage:

-a, --auto{=yes,md,mdp,part,p}{NN}

Instruct mdadm how to create the device file if needed, possibly allocating an unused minor number. "md" causes a non-partitionable array to be used (though since Linux 2.6.28, these array devices are in fact partitionable). "mdp", "part" or "p" causes a partitionable array (2.6 and later) to be used. "yes" requires the named md device to have a ’standard’ format, and the type and minor number will be determined from this. With mdadm 3.0, device creation is normally left up to udev so this option is unlikely to be needed.

Reviewing the RHEL 6.1 Technical Notes, I see no specific mention of the feature.
User avatar
WhatsHisName
 
Posts: 1524
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: Unable to create partitionable Raid1

Postby bearbo » 2011/08/17 16:46:44

As I mentioned, I was able to follow those instruction under CentOS 5.5. Is there any reason (or indication) that the feature was removed?
bearbo
 
Posts: 9
Joined: 2011/08/16 20:13:23

Re: Unable to create partitionable Raid1

Postby bearbo » 2011/08/18 18:33:55

Bump. Please help!
bearbo
 
Posts: 9
Joined: 2011/08/16 20:13:23

Re: Unable to create partitionable Raid1

Postby bearbo » 2011/08/22 17:09:12

I was able to create the array with the "--metadata=0.98" option and mount it. However I'm encountering more problems :-(

When I tried to patch the mkinitrd, I got this error:
patching file mkinitrd
Hunk #1 FAILED at 420.
Hunk #2 FAILED at 611.
Hunk #3 FAILED at 635.
Hunk #4 FAILED at 1703.
4 out of 4 hunks FAILED -- saving rejects to file mkinitrd.rej

Is patching of mkinitrd still necessary? Even without successful patch of mkinitrd, I seem to be able to boot with md_d0, which looks promising. But upon booting, mdadm --detail /dev/_md_d0 shows this:
/dev/md_d0:
Version : 0.90
Creation Time : Sat Aug 20 01:25:39 2011
Raid Level : raid1
Array Size : 488386496 (465.76 GiB 500.11 GB)
Used Dev Size : 488386496 (465.76 GiB 500.11 GB)
Raid Devices : 2
Total Devices : 1
Preferred Minor : 0
Persistence : Superblock is persistent

Update Time : Sun Aug 21 09:38:47 2011
State : clean, degraded
Active Devices : 1
Working Devices : 1
Failed Devices : 0
Spare Devices : 0

UUID : 3cbc70d5:a3d81de3:bfe78010:bc810f04
Events : 0.239

Number Major Minor RaidDevice State
0 8 0 0 active sync /dev/sda
1 0 0 1 removed

It seems to think that /dev/sdb is removed, for whatever reason.

I don't know if the two issues are linked, but any help is very appreciated!
bearbo
 
Posts: 9
Joined: 2011/08/16 20:13:23


Return to CentOS 6 - General Support

Who is online

Users browsing this forum: No registered users and 5 guests