Multimedia Broke

General support questions including new installations

Multimedia Broke

Postby abednegoyulo » 2009/04/03 01:13:46

Currently I do not know if this is a bug or I have a misconfigured system or missing some other packages.

After upgrading my desktop to 5.3, this includes removing gstreamer-plugins-bad that is provided by rpmforge because of conflicts with the official gstreamer-plugins-good, some media formats are no longer supported. I do not know whether the problem is on the official gstreamer-plugins-good(unsupported formats) or in the packages which came from rpmforge(does not play well with the official gstreamer-plugins-good package).

I have configured the official repos as stated in the wiki and configured rpmforge to have a priority of 11. I also used the instructions on the wiki for multimedia.

I tried excluding the gstreamer-plugins-good but some apps, totem and gnome-applets, depend on gstreamer-plugins-good. I continued with the removal. Excluded gstreamer-plugins-good from the base and updates repo. Installed gstreamer-plugins-bad from rpmforge. Restarted my system. After logging in, errors popped up indicating some applets cannot run or missing. I tried playing some 3gp, mpg, and ogg formats. After double clicking on them they still don't play. Because of this, I uninstalled the gstreamer-plugins-bad, removed gstreamer-plugins-good from exclude list. Installed gstreamer-plugins-good, totem, and gnome-applets, and then rebooted. No errors popped up and ended up to square one.

What is strange is ogg videos can't even be played, although thumbnails are visible. I grabbed the file from http://www.elphel.com/3fhlo/samples/333_samples/

$ file m021_300_1_70.ogg
m021_300_1_70.ogg: Ogg data, Theora video

$ mplayer m021_300_1_70.ogg
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU E6850 @ 3.00GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing m021_300_1_70.ogg.
[Ogg] stream 0: video (Theora v3.2.0), -vid 0
Ogg file format detected.
VIDEO: [theo] 1280x1024 24bpp 29.490 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[theora @ 0xd1ef10]Missing extradata!
Could not open codec.
VDecoder init failed :(
Opening video decoder: [theora] Theora/VP3
VDec: vo config request - 1280 x 1024 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 1280x1024 => 1280x1024 Planar YV12
aspect: Warning: no suitable new res found!
aspect: Warning: no suitable new res found!
Selected video codec: [theora] vfm: theora (Theora (free, reworked VP3))
==========================================================================
Audio: no sound
Starting playback...
aspect: Warning: no suitable new res found!
X11 error: BadAlloc (insufficient resources for operation)


MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.

$ totem m021_300_1_70.ogg
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 46 error_code 11 request_code 140 minor_code 19)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

Any advice on what should I do next? Can anyone verify this?

Thanks!
abednegoyulo
 
Posts: 550
Joined: 2007/12/26 06:24:38
Location: 127.0.0.2 44013

Multimedia Broke

Postby pschaff » 2009/04/03 21:50:22

Works-for-me:

$ rpm -q mplayer totem gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-bad
mplayer-1.0-0.40.rc1try2.el5.rf.x86_64
totem-2.16.7-4.el5.x86_64
totem-2.16.7-4.el5.i386
gstreamer-plugins-base-0.10.20-3.el5.i386
gstreamer-plugins-base-0.10.20-3.el5.x86_64
gstreamer-plugins-good-0.10.9-1.el5_3.1.x86_64
gstreamer-plugins-bad-0.10.8-1.el5.rf.x86_64

I think Dag fixed it yesterday after a report from one of our luminaries:

http://lists.rpmforge.net/pipermail/use ... 02272.html
pschaff
Retired Moderator
 
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Multimedia Broke

Postby abednegoyulo » 2009/04/04 02:35:20

Great! I will be updating my desktop in the office as soon as I get my hands on it. I thought the good plugin replaced the bad plugin which also got me thinking that why did check_obsoletes did not detect it.

Thanks pschaff for the info!
abednegoyulo
 
Posts: 550
Joined: 2007/12/26 06:24:38
Location: 127.0.0.2 44013

Re: Multimedia Broke

Postby abednegoyulo » 2009/04/07 07:38:18

It still broken after updating. After searching using google, I found that some experienced this while using desktop effects. Disabling desktop effects confirms the solution. It just puzzles me that why was it was working before the upgrade. After some more googling, I found that using some -vo options worked for them. After trying out every suggestions I found that -vo x11 works for me. Right now multimedia is working just perfect while running desktop effects. The only thing that is left to do is find the equivalent setting on GUI for -vo x11.
abednegoyulo
 
Posts: 550
Joined: 2007/12/26 06:24:38
Location: 127.0.0.2 44013


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 5 guests