Update fails with "Package does not match intended download"

General support questions including new installations

Update fails with "Package does not match intended download"

Postby jjrowan » 2009/04/04 13:50:13

I have many servers running CentOS 5. I noticed yesterday many had a notification
that updates were available. I clicked update and they all fail using the GUI. When
I run yum update it shows packages to be upgraded and asks me to confirm. I enter
yes but Yum fails on the first package. I wonder if this has something to do with the
release of 5.3?

I get the same failure if I run a yum upgrade too.


Total download size: 465 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): kernel-2.6.18-128. 100% |=========================| 15 MB 00:06
http://centos.mirror.nac.net/5.3/update ... 5.i686.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
http://ftp.lug.udel.edu/pub/centos/5.3/ ... 5.i686.rpm: [Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.newnanutilities.org/pub/c ... 5.i686.rpm: [Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.rit.edu/centos/5.3/updat ... 5.i686.rpm: [Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.stanford.edu/yum/pub/cent ... 5.i686.rpm: [Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.usc.edu/pub/linux/distri ... 5.i686.rpm: [Errno 9] Requested Range Not Satisfiable
Trying other mirror.


Error Downloading Packages:
kernel - 2.6.18-128.1.6.el5.i686: failure: RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm from updates: [Errno 256] No more mirrors to try.
jjrowan
 
Posts: 80
Joined: 2005/09/10 13:07:15

Re: Update fails with "Package does not match intended download"

Postby pschaff » 2009/04/04 13:57:50

Try "yum clean all" then try again.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Update fails with "Package does not match intended download"

Postby jjrowan » 2009/04/04 15:23:47

I ran yum clean all on three different 5.2 servers.
After that I ran yum upgrade on one and that appears to be upgrading.
On the other two I ran the graphical update and it stalls while downloading packages. I ran yum update on another and it failed with
Error Downloading Packages:
kernel - 2.6.18-128.1.6-el5.i686: failure: RPM5/kernel-2.8.18-128.1.6.el5.i686.rpm from updates: [Errno 256] No more mirrors to try.


I tried posting a JPG screen capture of the problem but when I tried posting an error was encountered:

Error Returned While Uploading
Failed opening directory with write permission: /var/www/html/oldwebcopy.centos.org/uploads/newbb
jjrowan
 
Posts: 80
Joined: 2005/09/10 13:07:15

Re: Update fails with "Package does not match intended download"

Postby jjrowan » 2009/04/04 17:20:59

After yum clean all then yum upgrade the failure appeared again.
Yum had downloaded (324/324) then displayed the error:

(322/324): mesa-libGL-6.5 100% |=========================| 9.7 MB 00:03
(323/324): oprofile-0.9.3 100% |=========================| 2.1 MB 00:00
(324/324): stunnel-4.15-2 100% |=========================| 112 kB 00:00


Error Downloading Packages:
kernel - 2.6.18-128.1.6.el5.i686: failure: RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm from updates: [Errno 256] No more mirrors to try.

[root@tomcat ~]# uname -a
Linux tomcat.rownetco.com 2.6.18-92.1.22.el5 #1 SMP Tue Dec 16 12:03:43 EST 2008 i686 i686 i386 GNU/Linux
jjrowan
 
Posts: 80
Joined: 2005/09/10 13:07:15

Re: Update fails with "Package does not match intended download"

Postby azca » 2009/04/04 17:36:10

I ran into a similar error - "[Errno -1] Package does not match intended download Trying other mirror." - etc, that was resolved by disabling the yum fastestmirror plugin.

Might want to try that if you're using the fastestmirror plugin.
azca
 
Posts: 174
Joined: 2006/06/03 18:06:13
Location: Peoria, AZ USA

Re: Update fails with "Package does not match intended download"

Postby pschaff » 2009/04/04 18:55:14

Is there a proxy in the picture? Seems like an extraordinary number of errors. With "many servers running CentOS 5" you may want to consider setting up a local mirror for updates.

Find a mirror site near you that supports rsync, set up a directory site already populated with content from the 5.3 DVDs or CDs, then use a script like:

Code: Select all
#!/bin/bash

if [ -d /share/CentOS/5.3 ] ; then
    rsync  -avSHP --delete --exclude "local*" --exclude "isos" nearby.rsync.centos.net::CentOS/5.3/ /share/CentOS/5.3/
else
    echo "Target directory /share/CentOS/5.3 not present."
fi


On the server can use nfs to export the directories (as root):
cat >> /etc/exports
/share 192.168.1.0/24(rw,mountpoint)

Substitute your local subnet or an explicit list of IP addresses.

If NFS is not already enabled:
exportfs -a
chkconfig nfs on
service nfs start

Then on clients mount the share and set up /etc/yum.repos.d/CentOS-Base.repo like:

Code: Select all
[base]
name=CentOS-$releasever - Base
baseurl=file:/share/CentOS/$releasever/os/$basearch/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5
protect=1
priority=1
enabled=1

[updates]
name=CentOS-$releasever - Updates
baseurl=file:/share/CentOS/$releasever/updates/$basearch/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5
protect=1
priority=1
enabled=1

[extras]
name=CentOS-$releasever - Extras
baseurl=file:/share/CentOS/$releasever/extras/$basearch/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5
protect=1
priority=1
enabled=1

[centosplus]
name=CentOS-$releasever - Plus
baseurl=file:/share/CentOS/$releasever/centosplus/$basearch/
exclude=kernel*
gpgcheck=1
enabled=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5
protect=0
priority=2

[contrib]
name=CentOS-$releasever - Contrib
baseurl=file:/share/CentOS/$releasever/contrib/$basearch/
gpgcheck=1
enabled=0
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5
protect=0
priority=3


Don't forget to do:
cd /share/CentOS/
ln -s 5.3 5

Alternatively - use http to share the updates - left as an exercise for the reader.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Update fails with "Package does not match intended download"

Postby pschaff » 2009/04/04 20:44:13

This stimulated me to do the Wiki article on this subject I've been intending for some time.

http://wiki.centos.org/HowTos/CreateLocalMirror

Comments welcome.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Update fails with "Package does not match intended download"

Postby jjrowan » 2009/04/04 22:57:54

I am not sure if I am using the fastmirror plugin. How would I find out and if I am, how do I disable?
jjrowan
 
Posts: 80
Joined: 2005/09/10 13:07:15

Re: Update fails with "Package does not match intended download"

Postby toracat » 2009/04/04 23:00:12

jjrowan wrote:
I am not sure if I am using the fastmirror plugin. How would I find out and if I am, how do I disable?

You can disable it by editing the /etc/yum/pluginconf.d/fastestmirror.conf file.
User avatar
toracat
Forum Moderator
 
Posts: 6694
Joined: 2006/09/03 16:37:24
Location: California, US

Re: Update fails with "Package does not match intended download"

Postby Ric_D » 2009/04/05 12:34:01

Disabling the fastestmirror plug-in did the trick for me. Thanks.
Ric_D
 
Posts: 1
Joined: 2009/04/05 12:32:16
Location: Washington, DC, USA

Next

Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 2 guests