Not enough memory to load specified image?

General support questions

Not enough memory to load specified image?

Postby JPA2 » 2011/10/25 12:27:41

Hello, I have a Dell xps 630i with a core 2 quad cpu Q9550 @2.83 ghz x4 with 8gb of ram installed. When trying to install centos 6.0 64 bit I get this error, "not enough memory to load specified image". I'm currently running centos 5.6 with webmin and virtualmin installed. My question is why am I receiving this error? I have more than enough ram installed. I have googled this error and have also tried looking through the forum to no avail. Any suggestions would be greatly appreciated!
JPA2
 
Posts: 4
Joined: 2011/10/25 04:41:20

Re: Not enough memory to load specified image?

Postby TrevorH » 2011/10/25 12:32:56

Plenty of google hits, did you try any of the suggested solutions?

1) Disable any "memory hole" in the BIOS settings and try again
2) reset BIOS settings to defaults and try again
3) Flash latest BIOS and try again
User avatar
TrevorH
Forum Moderator
 
Posts: 9168
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Not enough memory to load specified image?

Postby JPA2 » 2011/10/25 13:49:20

I am running the latest bios version, I have tried resetting the bios to the system default, did not work, I don't see any setting for disabling any memory hole in the bios, this seems pretty extreme to run centos 6.0
I've run sereral other linux distros without issue. If there is something I am missing as far as memory hole settings in the bios please let me know. I really like centos as a server os and would like to continue to use it, the reason for the upgrade from 5.6 to 6.0 is basically to upgrade php to 5.3 along with the added benefits of the new release.
JPA2
 
Posts: 4
Joined: 2011/10/25 04:41:20

Not enough memory to load specified image?

Postby toracat » 2011/10/25 15:25:43

Possibly related to this upstream bugzilla:

https://bugzilla.redhat.com/show_bug.cgi?id=589303
User avatar
toracat
Forum Moderator
 
Posts: 6696
Joined: 2006/09/03 16:37:24
Location: California, US

Re: Not enough memory to load specified image?

Postby JPA2 » 2011/10/26 02:19:06

Well this refers to a 32bit install and says their install seemed to hang up, stop working, in my instance it is a 64 bit install and it does not hang at all, in fact it actually gets to the main install screen quickly, I receive the "Not enough memory to load the specified image error" after I select the install option. Something changed for sure between the 5.6 install and the 6.0 install as I've been running 5.6 and that install went without a hitch. Certainly some one within CentOS would have an idea as to the cause of this error. As i stated before I would like to continue to use CentOs on this machine, but it is frustrating, know that I can install another Linux distro and be back up and running in minutes. If anyone could point me in the right direction it would be deeply appreciated.
JPA2
 
Posts: 4
Joined: 2011/10/25 04:41:20

Re: Not enough memory to load specified image?

Postby TrevorH » 2011/10/26 06:08:02

If you are further through the install than I thought (it sounded like it did this as soon as the kernel started to boot in your original post), perhaps you are able to switch to VT2 where there is a console and run some commands? If you are running the GUI installer, hit Ctrl-Alt-F2 and you should find a root command prompt. Run

Code: Select all
free
dmesg | grep Memory


and see how much memory is being reported by those. The bug report that toracat found does look promising - did the workaround of specifying mem= on the kernel command line not help? There seemed to be mentions of a 64 bit install in that bug.
User avatar
TrevorH
Forum Moderator
 
Posts: 9168
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Not enough memory to load specified image?

Postby JPA2 » 2011/10/26 12:04:40

My apologies for not being more clear, I am using the GUI installer and I am able to get to the installation screen and choose "Install or upgrade " after doing so I get, loading volume vmlinuz, then loading initrd.img after which I receive the error, not enough memory to load specified image and am left with, boot: in the terminal. I tried the Crtl-Alt-F2 at the main screen of the GUI and was not able to reach a root command prompt. What I did do was pop in the hdd with centos 5.6 and run free and then dmeg | grep memory in a terminal and this is the result:

james@james-server:~$ free
total used free shared buffers cached
Mem: 8191548 886920 7304628 0 36144 297252
-/+ buffers/cache: 553524 7638024
Swap: 8384508 0 8384508
james@james-server:~$ dmesg | grep memory
[ 0.000000] initial memory mapped : 0 - 20000000
[ 0.000000] Base memory trampoline at [ffff880000096000] 96000 size 20480
[ 0.000000] init_memory_mapping: 0000000000000000-00000000cfee0000
[ 0.000000] init_memory_mapping: 0000000100000000-0000000230000000
[ 0.000000] PM: Registered nosave memory: 000000000009b000 - 000000000009c000
[ 0.000000] PM: Registered nosave memory: 000000000009c000 - 00000000000a0000
[ 0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
[ 0.000000] PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
[ 0.000000] PM: Registered nosave memory: 0000000001e00000 - 0000000001f00000
[ 0.000000] PM: Registered nosave memory: 0000000001f00000 - 0000000001f01000
[ 0.000000] PM: Registered nosave memory: 00000000cfee0000 - 00000000cfee3000
[ 0.000000] PM: Registered nosave memory: 00000000cfee3000 - 00000000cfef0000
[ 0.000000] PM: Registered nosave memory: 00000000cfef0000 - 00000000cff00000
[ 0.000000] PM: Registered nosave memory: 00000000cff00000 - 00000000f0000000
[ 0.000000] PM: Registered nosave memory: 00000000f0000000 - 00000000f2000000
[ 0.000000] PM: Registered nosave memory: 00000000f2000000 - 00000000fec00000
[ 0.000000] PM: Registered nosave memory: 00000000fec00000 - 0000000100000000
[ 0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[ 0.015617] Initializing cgroup subsys memory
[ 0.582332] Freeing initrd memory: 13424k freed
[ 9.011391] Freeing unused kernel memory: 984k freed
[ 9.011797] Freeing unused kernel memory: 20k freed
[ 9.015834] Freeing unused kernel memory: 1400k freed
james@james-server:~$

I did try to introduce the mem= argument. however I'm not able to move from boot: in the terminal window. I am unfamiliar with VT2.
I am willing to do whatever is necessary to install the os if you are willing to guide me. Thank you for your attention to this matter. It is appreciated.
JPA2
 
Posts: 4
Joined: 2011/10/25 04:41:20

Re: Not enough memory to load specified image?

Postby TrevorH » 2011/10/26 13:42:40

I am suspecting that the newer kernel in CentOS 6 is not detecting all your memory correctly so is trying to run the install in a subset of what you actually have installed. This seems to be a known problem and the bypass is to pass mem=8G or mem=8192M to the kernel on the parameters line as you invoke the boot. Unfortunately all my installs of CentOS 6 have been via a PXE boot so I have no idea what the DVD/CD boot screen looks like nor how you interrupt it at this point to add the mem= parameter to it. Hopefully someone who has actually used the DVD will help out...
User avatar
TrevorH
Forum Moderator
 
Posts: 9168
Joined: 2009/09/24 10:40:56
Location: Brighton, UK


Return to CentOS 6 - General Support

Who is online

Users browsing this forum: No registered users and 9 guests