iSCSI LUN Not Appearing as /dev/sdb

General support questions including new installations
Posts: 5
Joined: 2005/07/15 21:42:50

iSCSI LUN Not Appearing as /dev/sdb

Postby madmac63 » 2010/02/11 04:24:58

I seem to get logged into the NetApp filer fine - it shows the session, but I don't get a device.

And don't panic - the system is CentOS 5.4, but the system is named OpenVMS (don't ask . . . )

iscsiadm shows me logged into the NetApp and the session is up.

[root@OpenVMS ~]# iscsiadm -m session -P 2
Current Portal:,1000
Persistent Portal:,1000
Iface Name: default
Iface Transport: tcp
Iface Initiatorname:
Iface IPaddress:
Iface HWaddress:
Iface Netdev:
SID: 1
iSCSI Connection State: LOGGED IN
iSCSI Session State: LOGGED_IN
Internal iscsid Session State: NO CHANGE
Negotiated iSCSI params:
HeaderDigest: None
DataDigest: None
MaxRecvDataSegmentLength: 262144
MaxXmitDataSegmentLength: 65536
FirstBurstLength: 65536
MaxBurstLength: 65536
ImmediateData: Yes
InitialR2T: No
MaxOutstandingR2T: 1
[root@OpenVMS ~]#

an iscsi restart shows a successful login (and an unsuccessful one too)

[root@OpenVMS ~]# /etc/init.d/iscsi restart
Logging out of session [sid: 1, target:, port
Logout of [sid: 1, target:, portal: 172.16.14
.85,3260]: successful
Stopping iSCSI daemon:
iscsid dead but pid file exists [ OK ]
Turning off network shutdown. Starting iSCSI daemon: [ OK ]
[ OK ]
Setting up iSCSI targets: Logging in to [iface: default, target:
.netapp:sn.84278807, portal:,3260]
Logging in to [iface: default, target:, porta
Login to [iface: default, target:, portal: 17,3260]: successful
iscsiadm: Could not login to [iface: default, target:
84278807, portal:,3260]:
iscsiadm: initiator reported error (8 - connection timed out)
iscsiadm: Could not log into all portals. Err 8.
[ OK ]

so it connects successfully the first time, but not the 2nd. Methinks it's trying to connect via the loopback interface in addition to eth0

All help is appreciated.


[Moderator edited to remove the e-mail address. See following posts.]

Posts: 69
Joined: 2009/03/14 12:12:06
Location: Serbia

Re: iSCSI LUN Not Appearing as /dev/sdb

Postby DrLove73 » 2010/02/11 12:14:02

Doug, it is not smart to make your e-mail (or any other contact information) in your posts or signature. There are many people that will abuse it in a second.

Posts: 5
Joined: 2005/07/15 21:42:50

Re: iSCSI LUN Not Appearing as /dev/sdb

Postby madmac63 » 2010/02/11 14:04:45

Thanks for the reminder . . .

Also, I found out what the problem was. The NetApp admin had put my system's FQDN in the iqn string while I was using just the hostname.

Changing that fixed it.

And I found out why one login is failing - it's "saved" a login with at typo - .86 not .85, but I don't know how to use iscsiadm to delete it . . .