Xvnc crash in CentOS 5.4 x86-64

General support questions including new installations

Xvnc crash in CentOS 5.4 x86-64

Postby Hallstein » 2010/05/07 11:35:13

Hi,

When running Matlab (7.10.0.499 (R2010a), 64-bit (glnxa64)) on CentOS 5.4 using vnc, the Xvnc chrashes and this is logged in syslog:

# grep vnc /var/log/messages
May 5 15:37:47 hornsund kernel: Xvnc[7195] general protection rip:594c79 rsp:7fffa0085318 error:0
May 6 12:30:43 hornsund kernel: Xvnc[7003] general protection rip:594c79 rsp:7fff7a992608 error:0
May 6 13:48:26 hornsund kernel: Xvnc[14559]: segfault at 0000000000000050 rip 00000000005eb3c3 rsp 00007fff86db9150 error 4
May 6 14:23:32 hornsund kernel: Xvnc[10442] general protection rip:594c79 rsp:7fff88a49b98 error:0
May 6 15:33:54 hornsund kernel: Xvnc[19690]: segfault at 0000000000000000 rip 000000000059604a rsp 00007fffaa3ca520 error 4
May 7 09:03:44 hornsund kernel: Xvnc[25622] general protection rip:594c79 rsp:7fff24995008 error:0
May 7 09:11:59 hornsund kernel: Xvnc[28038]: segfault at 000000000000000f rip 0000000000594c79 rsp 00007fff204f9ee8 error 4
May 7 09:14:15 hornsund kernel: Xvnc[29088] general protection rip:594c79 rsp:7fffb653a728 error:0
May 7 09:23:46 hornsund kernel: Xvnc[29723] general protection rip:594c79 rsp:7fff45302f18 error:0
May 7 09:48:58 hornsund kernel: Xvnc[30618] general protection rip:594c79 rsp:7ffff397d188 error:0
May 7 11:35:37 hornsund kernel: Xvnc[32722] general protection rip:594c79 rsp:7fff56a8c738 error:0

CentOS is up to date as of beginning this week.
Doing a quick net check suggests HW-problem ( HP DL380 G6), but I've tested both memory and cpu(s) without errors. We also had the same problem on Scientific Linux 5.4.


Regards,

HallsteinL
Hallstein
 
Posts: 2
Joined: 2010/05/07 10:47:19

Re: Xvnc crash in CentOS 5.4 x86-64

Postby Hallstein » 2010/05/10 13:01:22

Hi,

This morning Matlab also crashed when started from the servers console. The following link seems to have a fix to what seems to be a Matlab/OpenGL problem:
http://www.mathworks.com/matlabcentral/ ... ead/158572
By starting Matlab with ">>opengl software" it seems ok.

Regards,

Hallstein
Hallstein
 
Posts: 2
Joined: 2010/05/07 10:47:19


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 1 guest