[SOLVED] network printer issue and hplip 3.10.6

General support questions including new installations
r0cket
Posts: 14
Joined: 2011/01/01 21:16:43

[SOLVED] network printer issue and hplip 3.10.6

Post by r0cket » 2011/01/13 05:00:31

I'm trying to install hp DeskJet 6500 printer on a network.

My Centos version is

Linux xxxxx 2.6.18-194.26.1.el5xen #1 SMP Tue Nov 9 13:35:30 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

Ofcourse My printer model is not showing up on the list of printer list when using ipp based configuration.


so while searching around, I came across article to install hplip at

http://home.roadrunner.com/~computertaijutsu/hplip.html

and I tried to install the following hplip version with centos.

http://sourceforge.net/projects/hplip/files/hplip/3.10.6/


Running the configure with following arguments

./configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib64 --prefix=/usr --enable-qt4 --enable-doc-build --enable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disable-policykit --disable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build

I get following error

configure: error: cannot find net-snmp support (or --disable-network-build)

But net-snmp is installed on my system,
so, I tried with disable-network-build and tried to get around the problem, the next error I get is


checking for usb_init in -lusb... no
configure: error: cannot find libusb support


Any ideas?

Thanks

scottro
Forum Moderator
Posts: 2414
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: network printer issue and hplip 3.10.6

Post by scottro » 2011/01/13 09:00:20

Unfortunately, the hplipopensource.com web page has been down now for close to a month, with no indication of what's going on save that the packages are still available.

Did you, following the rr.com article (which is mine by the way) install net-snmp-devel?

Also, openssl-devel is necessary for net-snmp-devel to be seen by hplip.

Lastly, note in the rr.com article, it suggests first trying to use the much more recent rpmforge hplip version. (Though I don't know if that ever worked with scanning either--even the more modern day Fedora's hplip doesn't seem to work with all in ones--the printing will work, but the scanning frequently won't work.)

I suppose I should mention that I'm the author of that rr.com page.

r0cket
Posts: 14
Joined: 2011/01/01 21:16:43

Re: network printer issue and hplip 3.10.6

Post by r0cket » 2011/01/15 23:59:32

Thanks for the article and I'm glad that there is community out there to support this. It has good learning curve but so far I like it.

I do have openssl-devel and net-snmp-devel

Package openssl-devel-0.9.8e-12.el5_5.7.x86_64 already installed and latest version
Package openssl-devel-0.9.8e-12.el5_5.7.i386 already installed and latest version

Package 1:net-snmp-devel-5.3.2.2-9.el5_5.1.x86_64 already installed and latest version
Package 1:net-snmp-devel-5.3.2.2-9.el5_5.1.i386 already installed and latest version

The installed version of hplip on my system is

Package hplip-1.6.7-4.1.el5.4.x86_64 already installed and latest version

I downloaded latest hplip as per your article, however, while running the ./configure from hplip-3.10.6 or hplip-3.10.9
. I get following error


checking for usb_init in -lusb... no
configure: error: cannot find libusb support


What does this error mean?

thanks

User avatar
AlanBartlett
Forum Moderator
Posts: 9320
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: network printer issue and hplip 3.10.6

Post by AlanBartlett » 2011/01/16 00:36:50

[quote]
I downloaded latest hplip as per your article, however, while running the ./configure from hplip-3.10.6 or hplip-3.10.9
I get following error


checking for usb_init in -lusb... no
configure: error: cannot find libusb support


What does this error mean?
[/quote]
I suspect that you will need to install the [i]libusb-devel[/i] package. :-)

Please try --

[code]
[b]yum install libusb-devel[/b]
[/code]

r0cket
Posts: 14
Joined: 2011/01/01 21:16:43

Re: network printer issue and hplip 3.10.6

Post by r0cket » 2011/01/17 19:23:31

Thanks Alan.

I installed lib-usb-devel and several other required packages following that. Build the hplip and installed it.

Now, I do see hplip option under System->Administration->Printers when I tried to add printer. Good thing.

However, I don't see my specific model . "Hp OfficeJet 6500 E709n" . It is a multi-function printer connected via wired ethrnet and has a fixed ip address on my home network assigned by my firewall.

So, what do I next? Are there printer specific driver files that I can use to utilize this printer?

Thanks,

scottro
Forum Moderator
Posts: 2414
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: network printer issue and hplip 3.10.6

Post by scottro » 2011/01/17 20:29:59

If you go back to the article you mentioned, it has instructions. Look in /usr/share/ppd/HP and see if there is something similar to your printer. (Hint---there is.)



I've always had trouble with RH/Gnome GUI tools.

r0cket
Posts: 14
Joined: 2011/01/01 21:16:43

Re: network printer issue and hplip 3.10.6

Post by r0cket » 2011/01/18 00:07:51

Ok, some progress but not quite there yet.

I tried two methods.

1) according to article, I tried hp-setup to install the network printer.

[code]
[root@zzz hplip-3.10.9]# which hp-setup
/usr/local/bin/hp-setup
[root@zzz hplip-3.10.9]# /usr/local/bin/hp-setup -i 192.168.1.8
Traceback (most recent call last):
File "/usr/local/bin/hp-setup", line 45, in ?
from base import device, utils, tui, models, module
File "/usr/local/share/hplip/base/device.py", line 37, in ?
import status
File "/usr/local/share/hplip/base/status.py", line 45, in ?
import hpmudext
ImportError: No module named hpmudext
[root@zzz hplip-3.10.9]# /usr/local/bin/hp-setup 192.168.1.8
Traceback (most recent call last):
File "/usr/local/bin/hp-setup", line 45, in ?
from base import device, utils, tui, models, module
File "/usr/local/share/hplip/base/device.py", line 37, in ?
import status
File "/usr/local/share/hplip/base/status.py", line 45, in ?
import hpmudext
ImportError: No module named hpmudext
[/code]
so I could not add the printer like that.

Then method #2 using the System->Administration->Printers

I used ipp method to add the printer. I added ip address 192.168.1.8 my printers ip address. Also located the .ppd file as below

[code]
[root@zzz bin]# cd /usr/share/ppd/HP/
[root@zzz HP]# ls -la *6500*
-rw-r--r-- 1 root root 4797 Jan 17 18:30 hp-deskjet_6500.ppd.gz
-rw-r--r-- 1 root root 4114 Jan 17 18:30 hp-officejet_6500_e709a.ppd.gz
-rw-r--r-- 1 root root 5097 Jan 17 18:30 hp-officejet_6500_e709n.ppd.gz
-rw-r--r-- 1 root root 4102 Jan 17 18:30 hp-officejet_6500_e710a-f.ppd.gz
-rw-r--r-- 1 root root 4798 Jan 17 18:30 hp-officejet_6500_e710n-z.ppd.gz
[root@zzz HP]#
[/code]
So I picked the right .pdd.gz "hp-officejet_6500_e709n.ppd.gz". It added printer. great! But, the test page does not print. The printer status says it is printing but the document does not seem to make it to the printer. :-?

r0cket
Posts: 14
Joined: 2011/01/01 21:16:43

Re: network printer issue and hplip 3.10.6

Post by r0cket » 2011/01/18 00:25:33

Additional info. The configure I ran to config hplip-3.10.9 was the default [b]./configure[/b].

The hp-check reports following configure options set in my install:

[code]
[configure]
network-build=yes
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.10.9.11
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=no
hpijs-only-build=no
lite-build=no
udev-acl-rules=no
hpcups-only-build=no
hpijs-only-build=no
[/code]

scottro
Forum Moderator
Posts: 2414
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: network printer issue and hplip 3.10.6

Post by scottro » 2011/01/18 01:16:27

I wish the site was still up--they had some options about removing certain programs before starting installation.

I just vaguely remember they said remove any rpm for hplip and hpijs.

When you built it, that is, when you ran make, did it complete without errors?

Did it install without errors?

I know that my method works for me and has done so on several installs. I don't know if it's a factor, but I usually do a very minimal installation and don't install Gnome, which means I don't have system-config-printer installed. Whether or not that has something that conflicts with it, I don't know.

r0cket
Posts: 14
Joined: 2011/01/01 21:16:43

Re: network printer issue and hplip 3.10.6

Post by r0cket » 2011/01/19 03:45:04

yes, it compiles without any errors.
Although I did not use the arguments provided in your article for the configure command. I just did ./configure and prepared the Makefile and other artifacts successfully.

Then make install also worked and all my binaries are available., where they should be.

A bunch of hp-* scripts are populated in /usr/local/bin by the build of hplip.

When I ran hp-check, it appears to be checking how things are installed, it reports several issues. Does your hp-check report similar issues? I'm wondering how do I get around these issues?

Checking PyQt 4.x version...
error: NOT FOUND OR FAILED TO LOAD!

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: Python DBus - Python bindings for DBus...
error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.


Current contents of '~/.hplip/hplip.conf' file:
error: Could not access file: No such file or directory

Checking 'hpmudext' I/O extension...
error: NOT FOUND OR FAILED TO LOAD! Please reinstall HPLIP and check for the proper installation of hpmudext.

Checking 'scanext' SANE scanning extension...
error: NOT FOUND OR FAILED TO LOAD! Please reinstall HPLIP and check for the proper installation of scanext.

-----------
| SUMMARY |
-----------

error: 8 errors and/or warnings.

Post Reply