Apache Error 403 - CentOS 5.2 with Apache 2.2.3

General support questions including new installations

Apache Error 403 - CentOS 5.2 with Apache 2.2.3

Postby anunciatelo0111 » 2011/01/20 07:27:32

I am installing Big Brother on a CentOS 5.2 running the default Apache 2.2.3.

When I try to access any web page I get the following error:
Forbidden

You don't have permission to access /bb/ on this server.
Apache/2.2.3 (CentOS) Server at fmsubbnix Port 80

So far I have:
1) Set the Directory options to FollowSymLinks
2) Verified all directory and file permissions are at 755
3) Set permissions temporarily to 777 and received same error so I am assuming the issue is in a config file somewhere
4) in hhtpd.conf verified is correct
5) verified the "default" directory is correct (/var/www/html)

I have read and tried several ideas in posts listed on the web but to no avail and am at a loss as to what to look for next..

Please advise!
anunciatelo0111
 
Posts: 4
Joined: 2011/01/18 04:23:07

Re: Apache Error 403 - CentOS 5.2 with Apache 2.2.3

Postby TrevorH » 2011/01/20 11:12:22

Do you have SELinux enabled and if so, have you set the selinux contexts on the files/directories you are trying to access correctly?
User avatar
TrevorH
Forum Moderator
 
Posts: 9164
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Apache Error 403 - CentOS 5.2 with Apache 2.2.3

Postby pschaff » 2011/01/20 22:04:42

Might want to try a Wiki search on selinux httpd:
http://wiki.centos.org/TipsAndTricks/ApacheVhostDir
http://wiki.centos.org/HowTos/SELinux
http://wiki.centos.org/TipsAndTricks/SelinuxBooleans

Might also want to update. Use of obsolete/unsupported releases is not recommended. 5.5 is the current release, and 5.6 upstream was released last week, so CentOS 5.6 is just around the corner. See the CentOS 5.5 Release Notes Section 4 for details on the recommended update procedure. By not updating you are implicitly accepting that you will live with numerous bugs and security issues (and associated known exploits) that have subsequently been fixed.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Apache Error 403 - CentOS 5.2 with Apache 2.2.3

Postby psbucky » 2011/01/26 03:46:30

So far I have:
1) Set the Directory options to FollowSymLinks


One of the default settings in /etc/httpd/conf goes like:


Order deny,allow
Allow from all


If your symlink is taking you to somewhere else (e.g.: /var/www/susie), then you'll be getting default access permission, which is Deny from All.

If this could be a match for your circumstance, you'll need a stanza giving proper access to the filesystem location:
psbucky
 
Posts: 4
Joined: 2011/01/26 03:05:04


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: Google [Bot] and 5 guests