[SOLVED] Update problem

General support questions including new installations

[SOLVED] Update problem

Postby Defected » 2011/04/09 01:42:54

I' getting the following on 5.5 system while trying to update it to 5.6:

Transaction Check Error:
file /usr/share/info/coreutils.info.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/locale/be/LC_MESSAGES/coreutils.mo from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/locale/hu/LC_MESSAGES/coreutils.mo from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/locale/ru/LC_MESSAGES/coreutils.mo from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/locale/vi/LC_MESSAGES/coreutils.mo from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/base64.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/basename.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/cat.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/chcon.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/chgrp.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/chmod.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/chown.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/chroot.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/cksum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/comm.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/cp.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/csplit.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/cut.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/date.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/dd.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/df.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/dir.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/dircolors.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/dirname.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/du.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/echo.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/env.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/expand.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/expr.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/factor.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/false.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/fmt.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/fold.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/groups.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/head.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/hostid.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/id.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/install.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/join.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/link.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/ln.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/logname.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/ls.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/md5sum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/mkdir.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/mkfifo.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/mknod.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/mv.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/nice.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/nl.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/nohup.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/od.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/paste.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/pathchk.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/pinky.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/pr.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/printenv.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/printf.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/ptx.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/pwd.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/readlink.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/rm.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/rmdir.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/runcon.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/runuser.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/seq.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sha1sum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sha224sum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sha256sum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sha384sum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sha512sum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/shred.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sleep.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sort.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/split.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/stat.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/stty.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/su.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sum.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/sync.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/tac.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/tail.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/tee.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/test.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/touch.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/tr.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/true.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/tsort.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/tty.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/uname.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/unexpand.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/uniq.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/unlink.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/users.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/vdir.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/wc.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/who.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/whoami.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386
file /usr/share/man/man1/yes.1.gz from install of coreutils-5.97-23.el5_6.4.x86_64 conflicts with file from package coreutils-5.97-23.el5_4.2.i386

Error Summary
-------------

I have updated 2 identical machines and everything went fine. Any ideas?
Defected
 
Posts: 37
Joined: 2009/11/08 16:03:25
Location: Greece

Re: Update problem

Postby AlanBartlett » 2011/04/09 02:31:28

By looking at those error messages, it appears that you have a 64-bit system with packages for 32-bit support.

Keeping things simple, have you performed a yum clean all and then retried the update?

If that fails, please post the output returned by --

Code: Select all
[b]rpm -qa --qf "%{N}-%{V}-%{R}.%{ARCH}\n" coreutils\* | sort[/b]
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: Update problem

Postby Defected » 2011/04/09 02:36:51

Well yes it's a x86_64 system running cpanel :-? . Yes i did "yum clean all" but the problem appears again. The output of rpm -qa --qf "%{N}-%{V}-%{R}.%{ARCH}\n" coreutils\* | sort is:

coreutils-5.97-23.el5_4.2.i386
coreutils-5.97-23.el5_4.2.x86_64

Also, i see this:

root@server ~ # rpm --verify coreutils
.M....G. /bin/su
Unsatisfied dependencies for coreutils-5.97-23.el5_4.2.i386: libacl.so.1, libacl.so.1(ACL_1.0), libattr.so.1, libattr.so.1(ATTR_1.1)
Defected
 
Posts: 37
Joined: 2009/11/08 16:03:25
Location: Greece

Re: Update problem

Postby AlanBartlett » 2011/04/09 03:02:13

Are the other two (successfully updated) systems also running cPanel? If the answer is no, then I would be suspicious of what cPanel has done with this problematic system.

I would imagine that you should be able to complete the update if you first removed the 32-bit coreutils package, re-installing it after the update is complete.
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: Update problem

Postby Defected » 2011/04/09 03:06:00

Indeed the other 2 machines are running cpanel also! Do you think it's safe to remove 32bit coreutils to run the update and then reinstall that package?
Defected
 
Posts: 37
Joined: 2009/11/08 16:03:25
Location: Greece

Re: Update problem

Postby AlanBartlett » 2011/04/09 03:18:15

If I were in your situation, I would try --

Code: Select all
[b]rpm -e --test coreutils-5.97-23.el5_4.2.i386[/b]

-- and if there are no errors --

Code: Select all
[b]rpm -e coreutils-5.97-23.el5_4.2.i386[/b]

Then proceed with the update.
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: Update problem

Postby Defected » 2011/04/09 04:10:08

I removed 32bit coreutils and updated the system to 5.6 successfully! Also there is no 32bit coreutils installed on the system now and it looks like everything is working fine. I'll have a look about when and why the 32bit version was installed.

Thanks for your support!
Defected
 
Posts: 37
Joined: 2009/11/08 16:03:25
Location: Greece

Re: Update problem

Postby lightdot » 2011/04/09 09:46:24

I've seen a similar problem when both x86_64 and i386 version of the same package were installed, but only the x86_64 update became available. Yum couldn't find the i386 update and gave a similar error. Perhaps this also happened in your case?
lightdot
 
Posts: 43
Joined: 2011/03/29 12:24:35
Location: Slovenia

Re: Update problem

Postby Defected » 2011/04/09 19:46:20

lightdot wrote:
I've seen a similar problem when both x86_64 and i386 version of the same package were installed, but only the x86_64 update became available.


Probably. I'm running another 2 identical servers (software and hardware) with centos/cpanel and one rhel5.6/cpanel and coreutils32bit is not installed on any of those. I suspect that the 32bit version was installed by cpanel software update quite a lot of time ago.
Defected
 
Posts: 37
Joined: 2009/11/08 16:03:25
Location: Greece

Re: Update problem

Postby AlanBartlett » 2011/04/09 20:51:39

You might like to have a read of this CentOS FAQ.
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Next

Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 5 guests