[SOLVED] Upgrade to Centos 5.7. No GUI.

General support questions including new installations
Post Reply
pjc123
Posts: 74
Joined: 2010/08/17 16:59:11
Contact:

[SOLVED] Upgrade to Centos 5.7. No GUI.

Post by pjc123 » 2011/09/15 18:48:45

Yet again, another Red Hat upgrade (Version 5.6 to 5.7 this time) has caused problems with my ATI HD 4770 video card. In the past it was just poor resolution problems, this time the GUI will not start at all. Centos 5.7 installed fine otherwise, because I can enter run level 3 and the log files show no other errors.

Errors from /var/log/messages:

Sep 15 13:58:26 lin1 kernel: [drm] Initialized drm 1.0.1 20051102
Sep 15 13:58:29 lin1 gdm[5250]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Sep 15 13:58:36 lin1 gdm[5286]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Sep 15 13:58:42 lin1 gdm[5290]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Sep 15 13:58:42 lin1 gdm[5208]: deal_with_x_crashes: Running the XKeepsCrashing script


Errors from Xorg.log

(EE) R500(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.

(EE) R500(0): Acceleration initialization failed
(II) R500(0): Acceleration disabled


1) First of all, can this be fixed with a proper setting or driver update? Can I run in basic VGA mode at least?

2) Second of all, I am pretty much done with this card as it pertains to Linux; it is obsolete anyway. Are nvidia based cards more compatible, or is this just a crap shoot. I do not do gaming, but I usually buy a fairly decent video card for other graphics intensive tasks.

pjc123
Posts: 74
Joined: 2010/08/17 16:59:11
Contact:

Re: Upgrade to Centos 5.7. No GUI.

Post by pjc123 » 2011/09/17 13:58:33

I set my xorg.conf file back to using the vesa driver so I can at least get a graphical screen. When I first installed version 5, only vesa would work, then when 5.6 came out the r500 driver worked (much improved screen display), and now that 5.7 is out the r500 driver no longer works and it is back to vesa. What happens when 5.8 is out....who knows?

milosb
Posts: 661
Joined: 2009/01/18 00:39:15
Location: 44 49′14″N 20 27′44″E

Re: Upgrade to Centos 5.7. No GUI.

Post by milosb » 2011/09/17 14:20:26

Why don't you try with the ELrepo kABI ATI driver which is kernel independent, hence, you don't have to reinstall driver manually once you update your kernel.

The Elrepo provides two types of driver modules: current [url=http://elrepo.org/tiki/kmod-fglrx]kmod-fglrx (current)[/url], and [url=http://elrepo.org/tiki/kmod-fglrx93]kmod-fglrx93 (the legacy driver)[/url], and one of these should solve your problems.


Regards,

pjc123
Posts: 74
Joined: 2010/08/17 16:59:11
Contact:

Re: Upgrade to Centos 5.7. No GUI.

Post by pjc123 » 2011/09/17 18:49:42

[quote]
milosb wrote:
Why don't you try with the ELrepo kABI ATI driver which is kernel independent, hence, you don't have to reinstall driver manually once you update your kernel.

The Elrepo provides two types of driver modules: current [url=http://elrepo.org/tiki/kmod-fglrx]kmod-fglrx (current)[/url], and [url=http://elrepo.org/tiki/kmod-fglrx93]kmod-fglrx93 (the legacy driver)[/url], and one of these should solve your problems.


Regards,[/quote]

Thanks, I didn't know such a beast existed. And yes, the rebuilds with updated kernels has kept me from using ATI's proprietary driver. I might just give the kABI driver a try.

milosb
Posts: 661
Joined: 2009/01/18 00:39:15
Location: 44 49′14″N 20 27′44″E

Re: Upgrade to Centos 5.7. No GUI.

Post by milosb » 2011/09/17 22:14:15

Please do so, and when you're done, please report back so we can establish the real cause of your problems. ;-)

pjc123
Posts: 74
Joined: 2010/08/17 16:59:11
Contact:

Re: [SOLVED] Upgrade to Centos 5.7. No GUI.

Post by pjc123 » 2011/10/03 19:16:16

[quote]
milosb wrote:
Please do so, and when you're done, please report back so we can establish the real cause of your problems. ;-)[/quote]

Took me a while to try the kmod-fglrx (current) driver and all I can say is WOW! I now have access to the full 1920 X 1080 resolution of my monitor and everything is super sharp and clear. Thanks for your help.

User avatar
AlanBartlett
Forum Moderator
Posts: 9319
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

[SOLVED] Upgrade to Centos 5.7. No GUI.

Post by AlanBartlett » 2011/10/03 22:52:56

Thank you for reporting back with your success.

For posterity (and on your behalf) this post is now marked [SOLVED].

Post Reply