can't find the correct kernel support pakage

General support questions including new installations

can't find the correct kernel support pakage

Postby pdsavard » 2011/12/05 21:41:10

The kernel is : 2.6.18-274.12.1.e15

But in the Kernel.org i can't find the correct devel rpm to compile the dahdi source of my asterisk. I found only the 2.6.18-274-12.e15.x86_64.rpm (without the 1) file. (i am on 64bits centos).
When I try to make the dahdi I receive this error: You do not appear to have the sources for the 2.6.18-274-12.1.e15 kernel.

any suggestion?
pdsavard
 
Posts: 2
Joined: 2011/12/05 21:38:48

Re: can't find the correct kernel support pakage

Postby abednegoyulo » 2011/12/06 02:32:16

abednegoyulo
 
Posts: 550
Joined: 2007/12/26 06:24:38
Location: 127.0.0.2 44013

Re: can't find the correct kernel support pakage

Postby pdsavard » 2011/12/06 15:12:50

this line worked for me:

$ yum install kernel-devel-$(uname -r)
pdsavard
 
Posts: 2
Joined: 2011/12/05 21:38:48

can't find the correct kernel support pakage

Postby pschaff » 2011/12/06 15:50:09

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Rather than rolling your own, you may want to check out ELRepo's kmod-dahdi and dahdi-tools packages.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 5 guests