yum install gcc from DVD

General support questions including new installations

yum install gcc from DVD

Postby chuikingman » 2011/12/30 02:39:36

Hi,
I install gcc from yum and I already config the yum to get data from DVD as I cannot
connect internet .
The DVd is work and can install Centos .

I already use "yum clean all" before install
But I still find it is missing denpendencies ..

The files is find in the dvd already....

Please advice how to fix it ...



[root@localhost CentOS]# yum install gcc
Loaded plugins: aliases, allowdowngrade, changelog, downloadonly, fastestmirror, filter-data, kernel-
: module, keys, kmod, list-data, merge-conf, priorities, protect-packages, protectbase,
: refresh-updatesd, security, tmprepo, tsflags, upgrade-helper, verify, versionlock
Loading mirror speeds from cached hostfile
* c5-media:
c5-media | 1.1 kB 00:00
Skipping filters plugin, no data
0 packages excluded due to repository protections
Reading version lock configuration
Setting up Install Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package gcc.i386 0:4.1.2-48.el5 set to be updated
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
--> Running transaction check
---> Package glibc-devel.i386 0:2.5-49 set to be updated
--> Processing Dependency: glibc = 2.5-49 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.5-49 for package: glibc-devel
--> Processing Dependency: glibc-headers for package: glibc-devel
--> Running transaction check
---> Package glibc-devel.i386 0:2.5-49 set to be updated
--> Processing Dependency: glibc = 2.5-49 for package: glibc-devel
---> Package glibc-headers.i386 0:2.5-49 set to be updated
--> Processing Dependency: glibc = 2.5-49 for package: glibc-headers
--> Finished Dependency Resolution
glibc-devel-2.5-49.i386 from c5-media has depsolving problems
--> Missing Dependency: glibc = 2.5-49 is needed by package glibc-devel-2.5-49.i386 (c5-media)
glibc-headers-2.5-49.i386 from c5-media has depsolving problems
--> Missing Dependency: glibc = 2.5-49 is needed by package glibc-headers-2.5-49.i386 (c5-media)
Error: Missing Dependency: glibc = 2.5-49 is needed by package glibc-devel-2.5-49.i386 (c5-media)
Error: Missing Dependency: glibc = 2.5-49 is needed by package glibc-headers-2.5-49.i386 (c5-media)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
[root@localhost CentOS]#
chuikingman
 
Posts: 7
Joined: 2011/12/30 02:30:19

yum install gcc from DVD

Postby TrevorH » 2011/12/30 16:44:45

Post the output from

Code: Select all
rpm -qa --qf '%{name}-%{version}.%{release}.%{arch}\n' glibc\*
User avatar
TrevorH
Forum Moderator
 
Posts: 9166
Joined: 2009/09/24 10:40:56
Location: Brighton, UK


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 5 guests