updating php

General support questions including new installations

updating php

Postby prezaeis » 2012/01/06 01:59:17

hi guys

im a total freshie when it comes to these things, but i have a server with root access, its running CentOS 5.5 x64 + ISPConfig.

I need to change the version of php (currently 5.1.6) to 5.2.17

how can i do this, i dont know much about getting the files and stuff so i kinda need like step by step manual from somewhere or maybe theres an easy way to do it?

id really appreciate ur help
prezaeis
 
Posts: 5
Joined: 2012/01/06 01:54:28

updating php

Postby pschaff » 2012/01/06 23:00:00

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Don't use obsolete/unsupported releases - 5.7 is the current release. See the CentOS 5.7 Release Notes for details. By not updating you are implicitly accepting that you will live with numerous bugs and security issues (and associated known exploits) that have subsequently been fixed.

Next step is to read about Installing Software and Repositories, and note the warnings and advice about installing and configuring the yum priorities plugin. Non-core repos should have a higher numeric value, which is a lower priority. Lower is "better" as in golf scores.

There are later PHP packages in some of the 3rd party repos, or if 5.2.17 is not a hard requirement, the CentOS repos have php53 packages as an alternative to the standard PHP. Specifically for 5.2.17 the IUS repo seems to be the best bet.

Code: Select all
# yum --disablerepo \* --enablerepo ius list php\*5.2.17\*
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * ius: mirror.rackspace.com
Available Packages
php52.i386                             5.2.17-2.ius.el5                  ius
php52-bcmath.i386                      5.2.17-2.ius.el5                  ius
php52-cli.i386                         5.2.17-2.ius.el5                  ius
php52-common.i386                      5.2.17-2.ius.el5                  ius
php52-dba.i386                         5.2.17-2.ius.el5                  ius
php52-debuginfo.i386                   5.2.17-2.ius.el5                  ius
php52-devel.i386                       5.2.17-2.ius.el5                  ius
php52-gd.i386                          5.2.17-2.ius.el5                  ius
php52-imap.i386                        5.2.17-2.ius.el5                  ius
php52-ldap.i386                        5.2.17-2.ius.el5                  ius
php52-mbstring.i386                    5.2.17-2.ius.el5                  ius
php52-mcrypt.i386                      5.2.17-2.ius.el5                  ius
php52-mhash.i386                       5.2.17-2.ius.el5                  ius
php52-mssql.i386                       5.2.17-2.ius.el5                  ius
php52-mysql.i386                       5.2.17-2.ius.el5                  ius
php52-ncurses.i386                     5.2.17-2.ius.el5                  ius
php52-odbc.i386                        5.2.17-2.ius.el5                  ius
php52-pdo.i386                         5.2.17-2.ius.el5                  ius
php52-pgsql.i386                       5.2.17-2.ius.el5                  ius
php52-psa-compat.i386                  5.2.17-2.ius.el5                  ius
php52-snmp.i386                        5.2.17-2.ius.el5                  ius
php52-soap.i386                        5.2.17-2.ius.el5                  ius
php52-tidy.i386                        5.2.17-2.ius.el5                  ius
php52-xml.i386                         5.2.17-2.ius.el5                  ius
php52-xmlrpc.i386                      5.2.17-2.ius.el5                  ius

The choices for x86_64 should be similar.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: updating php

Postby prezaeis » 2012/01/08 01:35:53

thank you so much for the reply

im hostign with host1plus and they dont have the 5.7 version as a setup template. i was stuck with choosing to install 5.5.
if i upgrade the os to 5.7 would i lose my files?
prezaeis
 
Posts: 5
Joined: 2012/01/06 01:54:28

Re: updating php

Postby prezaeis » 2012/01/08 05:43:13

whatever method i try to update the php i get the following error:


Transaction Check Error:
file /etc/my.cnf from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/charsets/cp1251.xml from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64
file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.5.19-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.4.x86_64

Error Summary
-------------


any ideas?
prezaeis
 
Posts: 5
Joined: 2012/01/06 01:54:28

Re: updating php

Postby hansolo » 2012/01/18 21:49:43

hi,

go to webtatic repo site and follow the instructions (especially at the bottom of the page under section PHP 5.2.17)

good luck
hansolo
 
Posts: 231
Joined: 2010/01/13 11:17:42
Location: SI


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 5 guests