Can not install a CentOS 5.4 Virtual Machine on Xenserver 5.0

General support questions including new installations

Can not install a CentOS 5.4 Virtual Machine on Xenserver 5.0

Postby arifdhalla » 2012/01/18 06:47:14

Hello:

I am trying to install a CentOS v5.4 Virtual machine onto my Xenserver. We have a bunch of Windows VM's that work perfectly, but for some reason I cannot install any Centos Linux VM's. Everytime I try, I get the following error: I*NVALID_SOURCE - Unable to access a required file in the specified repository: file:///tmp/nfs-repo-7VI00B/images/xen/vmlinuz.*

I get the same message whether I try installing using the Xencenter GUI or the Command line instructions as per the link: http://docs.vmd.citrix.com/XenServer/6. ... so_install

I have tried multiple images from multiple mirrors on the CentOS website. The ISO file is stored on an NFS Storage repository where all my other ISO's are stored. and Xenserver has full access to this share.

1) Does anyone have a solution for this issue?
2) Is there a specific "Xen-ready" version of CentOS that I should be using, and if so, can you point me to the download link.

Thank you

Arif
arifdhalla
 
Posts: 1
Joined: 2012/01/18 06:43:14

Re: Can not install a CentOS 5.4 Virtual Machine on Xenserver 5.0

Postby DaemonProgrammr » 2012/01/18 08:28:42

Installing CentOS on Hyper-V gave me similar (but not the same) headaches.

Eventually found out that the virtual CD-ROM didn't like the network location for some reason. (Could have been a sharing issue, but the network admin was busy..)
Anywayz. Copied the ISO to a location I could access with a drive letter. That did miracles.
DaemonProgrammr
 
Posts: 78
Joined: 2011/12/12 12:49:46

Can not install a CentOS 5.4 Virtual Machine on Xenserver 5.

Postby pschaff » 2012/01/18 14:03:03

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

5.4 is seriously obsolete and has numerous known bugs and security issues that have been fixed in subsequent updates. Obsolete releases are not supported, nor is it advisable to be installing or running them. CentOS-5.7 is the current release. See the CentOS 5.7 Release Notes for details.

CentOS-5.7 should be Xen-ready. Google upstream for more.

DaemonProgrammr wrote:
... Copied the ISO to a location I could access with a drive letter. That did miracles.

There are no driver letters on a Xen server. That's a RedmondOS thing.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 1 guest