The ImageMagick 'convert' command may not work with postscript files

General support questions including new installations

The ImageMagick 'convert' command may not work with postscript files

Postby emc2 » 2012/03/12 13:35:31

Hi guys,

I've been searching for a long time now on how to fix my convert command. It was working and stopped about a month ago.. I've found a confirmation of the problem at the redhat site but you need a subscription to access the solution.

Enviroment:

- ghostscript-8.70-14.el5
- ImageMagick-6.2.8.0-12.el5

Here is how to reproduce:

Code: Select all
[root@ home]# convert test.ps test.png
Error: /undefinedfilename in (72x72)
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push \
   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
Dictionary stack:
   --dict:1154/1684(ro)(G)--   --dict:0/20(G)--   --dict:70/200(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 8.70: Unrecoverable error, exit code 1
Error: /undefinedfilename in (72x72)
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push \
   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
Dictionary stack:
   --dict:1154/1684(ro)(G)--   --dict:0/20(G)--   --dict:70/200(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 8.70: Unrecoverable error, exit code 1
convert: no decode delegate for this image format `test.ps'.
convert: Postscript delegate failed `test.ps'.
convert: missing an image filename `test.png'.
[Moderator edit: Wrapped long lines.]

If anyone can help I would be very grateful.
emc2
 
Posts: 2
Joined: 2012/03/12 13:27:44

Re: The ImageMagick 'convert' command may not work with postscript files

Postby gmhphillips » 2012/03/12 16:03:32

Here is the Resolution from the RedHat Knowledgebase:

Resolution
As a workaround, please revert back to ImageMagick-6.2.8.0-4.el5_5.3. A permanent solution is currently under investigation.

I have the same problem and will be trying this soon.

Gregg.
gmhphillips
 
Posts: 2
Joined: 2012/03/12 15:59:55

Re: The ImageMagick 'convert' command may not work with postscript files

Postby jkhord » 2012/03/12 21:06:26

Yes, I can confirm that installing ImageMagick-6.2.8.0-4.el5_5.3 from the CentOS 5.7 tree fixes the immediate problem
jkhord
 
Posts: 29
Joined: 2010/03/10 23:54:45
Location: Washington, DC

Re: The ImageMagick 'convert' command may not work with postscript files

Postby emc2 » 2012/03/13 01:55:11

Thanks heaps guys!

For anyone else with this issue I did the following to resolve it:

Code: Select all
cd /usr/src
wget ftp://fr2.rpmfind.net/linux/centos/5.7/os/x86_64/CentOS/ImageMagick-6.2.8.0-4.el5_5.3.i386.rpm
wget ftp://fr2.rpmfind.net/linux/centos/5.7/os/x86_64/CentOS/ImageMagick-6.2.8.0-4.el5_5.3.x86_64.rpm
wget ftp://fr2.rpmfind.net/linux/centos/5.7/os/x86_64/CentOS/ImageMagick-devel-6.2.8.0-4.el5_5.3.i386.rpm
wget ftp://fr2.rpmfind.net/linux/centos/5.7/os/x86_64/CentOS/ImageMagick-devel-6.2.8.0-4.el5_5.3.x86_64.rpm

yum erase ImageMagick

yum --nogpgcheck install \
ImageMagick-6.2.8.0-4.el5_5.3.i386.rpm \
ImageMagick-6.2.8.0-4.el5_5.3.x86_64.rpm \
ImageMagick-devel-6.2.8.0-4.el5_5.3.i386.rpm \
ImageMagick-devel-6.2.8.0-4.el5_5.3.x86_64.rpm
emc2
 
Posts: 2
Joined: 2012/03/12 13:27:44

The ImageMagick 'convert' command may not work with postscri

Postby pschaff » 2012/03/13 12:16:33

If those are official CentOS packages they should be signed so "--nogpgcheck" should not be required, nor should it be necessary to download the packages manually. This worked for me:

Code: Select all
yum --noplugins --enablerepo C5.7-base downgrade ImageMagick-6.2.8.0-4.el5_5.3 ImageMagick-devel-6.2.8.0-4.el5_5.3


The "--noplugins" is necessary for me because yum-priorities is installed and priorities are not defined for the repos in /etc/yum.repos.d/CentOS-Vault.repo.

Note also that exclude=ImageMagick* should be added to the [base] and [updates] repos to avoid the downgraded versions from being overwritten by the later versions on the next "yum update".
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: The ImageMagick 'convert' command may not work with postscript files

Postby jkhord » 2012/03/13 14:36:10

of course this just became very difficult to do because CentOS 5.7 just disappeared from all public mirrors overnight
jkhord
 
Posts: 29
Joined: 2010/03/10 23:54:45
Location: Washington, DC

Re: The ImageMagick 'convert' command may not work with postscript files

Postby pschaff » 2012/03/13 15:17:50

That's why my procedure above uses the CentOS-Vault repo.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: Yahoo [Bot] and 11 guests