youtube videos do not play

General support questions including new installations

youtube videos do not play

Postby dime » 2012/04/08 10:22:47

hi,
centos 5.8
gnome desktop
updated to date
firefox esr 10.0.3

since a few days i cannot play youtube videos presented on the youtube page any more....
in the video screen a black field comes up, nothing happens from that.
the preview stills are shown, but clicking on them loads that 'black screen'
i can download the file though (through downloadhelper).

is anybody having this same problem?
is it a centos issue?
or is it a 'dime' issue? ;-)

thanks.
dime
 
Posts: 108
Joined: 2010/01/27 09:48:11

Re: youtube videos do not play

Postby AlanBartlett » 2012/04/08 16:15:40

My hint -- Check your flash player plugin.

Do you use RPMforge / Repoforge for your updates?
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: youtube videos do not play

Postby dime » 2012/04/08 21:49:51

i get the package updater message on top right of my screen with something like 'x updates available'
i do the updates from that and do the updates that are offered.
so i cannot answer your question as i do not know where these actually do come from.
(alway thought they were from 'Centos Mother Base' ;-)
dime
 
Posts: 108
Joined: 2010/01/27 09:48:11

Re: youtube videos do not play

Postby AlanBartlett » 2012/04/09 00:20:07

Whilst in Firefox, I enter about:plugins in the Address Bar. In the list returned, I see --

Code: Select all
Shockwave Flash

    File:        nswrapper_64_64.libflashplayer.so
    Version:     Shockwave Flash 11.1 r102

MIME Type                    Description          Suffixes

application/x-shockwave-flash    Shockwave Flash       swf
application/futuresplash        FutureSplash Player   spl

Querying the installed package, I see --

Code: Select all
[ajb@Duo2 ~]$ rpm -q flash-plugin
flash-plugin-11.1.102.63-0.1.el6.rf.x86_64

Yes, a package from Repoforge (was formally known as RPMforge). Finally, the required symlink --

Code: Select all
[ajb@Duo2 ~]$ rpm -ql flash-plugin | grep so$
/usr/lib64/flash-plugin/libflashplayer.so
/usr/lib64/kde4/kcm_adobe_flash_player.so
[ajb@Duo2 ~]$ ll /usr/lib64/mozilla/plugins/libflashplayer.so
lrwxrwxrwx. 1 root root 41 Mar 16 22:49 /usr/lib64/mozilla/plugins/libflashplayer.so -> /usr/lib64/flash-plugin/libflashplayer.so
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

youtube videos do not play

Postby pschaff » 2012/04/09 01:15:08

There are also packages available directly from Adobe. In any case, if you don't know where your updates are coming from, provide more information about your system by running "./getinfo.sh package" and showing us the output file.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: youtube videos do not play

Postby dime » 2012/04/09 08:36:14

that does not work on my system:

[root@xyz]# ./getinfo.sh package
bash: ./getinfo.sh: No such file or directory
[root@xyz]#


and the other suggested query gives:

[root@xyz]# rpm -q flash-plugin
flash-plugin-11.2.202.228-release
[root@xyz]#
dime
 
Posts: 108
Joined: 2010/01/27 09:48:11

Re: youtube videos do not play

Postby pschaff » 2012/04/09 15:12:45

dime wrote:
bash: ./getinfo.sh: No such file or directory

You failed to read the link.

and the other suggested query gives:
[root@xyz]# rpm -q flash-plugin
flash-plugin-11.2.202.228-release

You are using the Adobe package. Check that the symbolic link exists, as Alan showed in post #4. I'm not sure if the Adobe package creates it or not.

If still having trouble it might be worth trying the RPMforge package.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: youtube videos do not play

Postby dime » 2012/04/15 11:10:37

update to my problem (that still persists):

XXXXXXXXXX

following alan's suggestions:

[aaa@bbb ~]$ su
Password:
[root@bbb]# rpm -q flash-plugin
flash-plugin-11.2.202.233-release
[root@bbb]#


[root@bbb]# rpm -ql flash-plugin | grep so$
/usr/lib/flash-plugin/libflashplayer.so
/usr/lib/kde4/kcm_adobe_flash_player.so
[root@bbb]#


[root@bbb]# ll /usr/lib/mozilla/plugins/libflashplayer.so
lrwxrwxrwx 1 root root 39 Apr 14 00:00 /usr/lib/mozilla/plugins/libflashplayer.so -> /usr/lib/flash-plugin/libflashplayer.so
[root@bbb]#

(NOTE: i do have 'lib' instead of 'lib64')

XXXXXXXXXX

following phil's suggestions:

(and after reading the link)

"provide more information about your system by running "./getinfo.sh package" and showing us the output file."

the output file is linked to:
http://members.multimania.nl/driepoot99 ... I30428.txt

XXXXXXXXXX

after the most recent update package manager offered (2 days ago, flash was one of the packages), i still cannot see the youtube videos (as i mentioned in the first post), nor videos in other websites.

hope the info above brings some sort of solution.
dime
 
Posts: 108
Joined: 2010/01/27 09:48:11

Re: youtube videos do not play

Postby pschaff » 2012/04/15 12:35:16

I can't see anything wrong there. You have i386/32-bit so /usr/lib/ is correct. Just tried the latest Adobe flash-player package on 5.8 x86_64 and it works correctly, so I suspect i386 should as well. Something else must be wrong. I do note that you have the yum-priorities plugin installed, but have not configured any priorities, so all repos will default to 99 - the lowest. This means, for instance, that the flash-plugin version you get could come from either Adobe or RPMforge depending on which looks to yum like the later version number.

Since you say it stopped working a few days ago, I'd suggest reviewing /var/log/yum.log and see what was installed just before the time it stopped working. If you have done any other changes, particularly things such as Source Installs, they may also be suspect.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: youtube videos do not play

Postby dime » 2012/04/16 07:55:01

thank you for that answer.


when i choose 'Tools' and 'Add-Ons', i get this screen:
http://members.multimania.nl/driepoot99 ... ins1_b.jpg

when i choose the link on top of the page, i get this:
http://members.multimania.nl/driepoot99 ... ins2_b.jpg

when you look at the red text about 'Java', it seems someone/somewhat has disabled my Java....
could this be related to my problem?

when 'yes',
how do i re-activate Java?
dime
 
Posts: 108
Joined: 2010/01/27 09:48:11

Next

Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 4 guests