[SOLVED] Yum reinstall problem

General support questions including new installations

[SOLVED] Yum reinstall problem

Postby watoo » 2012/04/19 09:52:56

Hello

I encountered some difficulties to reinstall yum on centOS 5.5

I searched on google and I found some similar procedures (like http://wiki.openvz.org/Install_yum) which indicate that I need to reinstall manually yum-fastestmirror and yum paquets

Here is what I get when I try to install them:
Code: Select all
[root@test yum]# rpm -Uvh yum-fastestmirror-1.1.16-14.el5.centos.1.noarch.rpm
error: dependences required:
yum >= 3.0 is required to yum-fastestmirror-1.1.16-14.el5.centos.1.noarch

[root@test yum]# rpm -Uvh yum-3.2.22-26.el5.centos.noarch.rpm
error: dependences required:
yum-fastestmirror is required to yum-3.2.22-26.el5.centos.noarch


So I don't know which paquet I need to install because they depend on each other


Thank you, I got lost with this yum :(
watoo
 
Posts: 2
Joined: 2012/04/19 07:44:38

Re: Yum reinstall problem

Postby markkuk » 2012/04/19 09:55:41

If packages have mutual dependencies you must install them at the same time, with a single command:
Code: Select all
rpm -Uvh yum-fastestmirror-1.1.16-14.el5.centos.1.noarch.rpm yum-3.2.22-26.el5.centos.noarch.rpm
markkuk
 
Posts: 682
Joined: 2007/09/07 10:56:28
Location: Finland

Re: Yum reinstall problem

Postby watoo » 2012/04/19 14:45:45

Thank you so much, that's works :)
watoo
 
Posts: 2
Joined: 2012/04/19 07:44:38

[SOLVED] Yum reinstall problem

Postby pschaff » 2012/04/19 14:48:14

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Thanks for reporting back. Marking this thread [SOLVED] for posterity.

Please do note that CentOS-5.5 is obsolete, insecure, and unsupported. A "yum update" to get to 5.8 is highly recommended; however, you may first want to read:

Other Voices
When CentOS Is Not CentOS
Broken Virtual Server
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - General Support

Who is online

Users browsing this forum: No registered users and 1 guest