[SOLVED] Installer reboots installer!

General support questions

[SOLVED] Installer reboots installer!

Postby knowayhack » 2012/02/19 00:02:21

Hi, I should start by saying that I'm very new to tech/computers in general, even newer to Linux (but already hooked :-) and yet again even newer to CentOS.

Been using Ubuntu based distros with varying degrees of sucess on various machines for several months, but have never come across this particular problem before.
I've googled and tried searching the forum here with different terms but the only reference I can find to the issue I'm experiencing is this Red Hat Bugzilla entry:

https://bugzilla.redhat.com/show_bug.cgi?id=761087

To be honest, none of the info on this page means much to me in my newbie naivety!
What happens is: the install seems to go perfectly - gets to the end, tells me to reboot to complete installation. When I do so, I just end up back at the installer desktop, I thought maybe I could do yum update from the terminal there to sort it out somehow, but there seems to be no way to run a root command from the install desktop terminal - I just keep getting told off and reported! I'm officially baffled!

Hardware wise, i'm on an Asus A53e, which is dual-booting Xubuntu & Windows. But I kind of doubt it's a hardware issue, as I have the same problem trying to install in VirtualBox and dual-booting on my Mac. Also I have the same issue trying to install Fedora, which I assume is because both distros use the same installer? Anaconda? But as I said, never had this problem with any Ubuntu based distros - or Debian or OpenSuse for that matter.

Apologies if this is a fairly common, easily rectified bug,(it kind of seems as though it must be - I feel like somewhere along the line I'm probably just doing, or failing to do something really stupid!) but as I said, I have tried for sometime to find a solution, and am really keen to try running a Red Hat related distro as my ultimate (and at this point clearly very distant!) goal is to get Red Hat certified. As you can probably gather - i've got rather a long way to go! Lol!

And advice/light shedding would be greatly appreciated.
knowayhack
 
Posts: 4
Joined: 2012/02/18 23:25:39

Re: Installer reboots installer!

Postby TrevorH » 2012/02/19 01:22:01

The bug you pointed to is on a PowerPC machine so probably not related.

Silly question time: you did remove the CD/DVD from the drive when prompted?
User avatar
TrevorH
Forum Moderator
 
Posts: 9167
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installer reboots installer!

Postby knowayhack » 2012/02/19 01:45:58

I did indeed...

Using Pendrive Linux Yumi Multibooter USB stick on the Asus and some random EFI hack thing to get Linux booting off a USB on a Lionized Macbook - both of which work fine on un-anacondaed distros!

Also, I have the exact same issue trying to install in a VM on any host OS (Xubunu, Windows, MacOS)......v.weird.

Cheers for the response though :-) Any other ideas?
knowayhack
 
Posts: 4
Joined: 2012/02/18 23:25:39

[SOLVED] Installer reboots installer!

Postby pschaff » 2012/02/19 20:31:22

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Not clear - are you installing from USB media? If so you need to remove the USB stick or change the boot device order.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Installer reboots installer!

Postby knowayhack » 2012/02/19 21:46:30

Thanks for the welcome.
I am indeed installing from USB media and I always remove the stick after the installation, yet I still end up back at an installer desktop!
Same thing in VirtualBox.
knowayhack
 
Posts: 4
Joined: 2012/02/18 23:25:39

Re: Installer reboots installer!

Postby pschaff » 2012/02/19 22:24:44

Not quite sure what you mean by "installer desktop" as the installer is not a desktop. I suspect you have installed from the LiveCD or LiveDVD, and indeed the installed system would be expected to replicate the Live media, as it just puts the image on the disk and makes a few changes to boot/run from there. If you want a custom install then use the installation DVD1 media and not the Live media, or just add/remove packages to get the configuration you want.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Installer reboots installer!

Postby knowayhack » 2012/02/20 00:50:29

Aha!
Yup, I think this may have been my problem - somehow just installed the LiveCD - which is what I meant by the "installer desktop" - lol! Still not too clued up on terminology i'm afraid!
Just tried it once more in VirtualBox and found that if I press f12 before it boots I get into my installation but by default it just boots the LiveCD - which is whats been confusing me.
I shall have a wee play in the VM for a bit before taking the plunge on actual hardware again as my current Xubuntu is running really nice at the moment. Thanks very much for the help :-)
knowayhack
 
Posts: 4
Joined: 2012/02/18 23:25:39

Re: [SOLVED] Installer reboots installer!

Postby pschaff » 2012/02/20 14:01:11

You are welcome. Thanks for reporting back. Marking this thread [SOLVED] for posterity. I suggest you try a full install or two from DVD1 in the VM before tackling real hardware.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 6 - General Support

Who is online

Users browsing this forum: No registered users and 8 guests