Install PHP4, old repository?

Issues related to software problems.

Install PHP4, old repository?

Postby TheScorpio » 2007/12/18 11:32:47

Hi dear friends,

Is it possible to install PHP 4 on CentOS 5.0 by using a special/old repository? A customer can't upgrade yet, although we now it isn't supported any more at the end of the year.

Kind regards!

Bob
TheScorpio
 
Posts: 5
Joined: 2007/11/22 15:01:37

Re: Install PHP4, old repository?

Postby Lenard » 2007/12/18 12:30:15

One can try rebuilding from the source rpm, for example:

http://mirror.chpc.utah.edu/pub/centos/ ... .4.src.rpm

rpmbuild --rebuild --recompile php-4.3.9-3.22.4.src.rpm

Then install the resulting binary php rpm: rpm -i php-4.3.9-3.22.4*.rpm
Lenard
 
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: Install PHP4, old repository?

Postby TheScorpio » 2007/12/18 13:06:30

Thanks for the quick reply.
I had to install yum install rpm-build redhat-rpm-config as well.

I get the following messages;
warning: user mockbuild does not exist - using root
............
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
cat: /usr/include/httpd/.mmn: No such file or directory
error: Failed build dependencies:
bzip2-devel is needed by php-4.3.9-3.22.4.i386
curl-devel >= 7.9 is needed by php-4.3.9-3.22.4.i386
db4-devel is needed by php-4.3.9-3.22.4.i386
expat-devel is needed by php-4.3.9-3.22.4.i386
gmp-devel is needed by php-4.3.9-3.22.4.i386
aspell-devel >= 0.50.0 is needed by php-4.3.9-3.22.4.i386
httpd-devel >= 2.0.46-1 is needed by php-4.3.9-3.22.4.i386
libjpeg-devel is needed by php-4.3.9-3.22.4.i386
libpng-devel is needed by php-4.3.9-3.22.4.i386
pam-devel is needed by php-4.3.9-3.22.4.i386
pcre-devel is needed by php-4.3.9-3.22.4.i386
libtool >= 1.4.3 is needed by php-4.3.9-3.22.4.i386
libc-client-devel is needed by php-4.3.9-3.22.4.i386
cyrus-sasl-devel is needed by php-4.3.9-3.22.4.i386
openldap-devel is needed by php-4.3.9-3.22.4.i386
postgresql-devel is needed by php-4.3.9-3.22.4.i386
unixODBC-devel is needed by php-4.3.9-3.22.4.i386
net-snmp-devel is needed by php-4.3.9-3.22.4.i386
elfutils-devel is needed by php-4.3.9-3.22.4.i386
libxslt-devel >= 1.0.18-1 is needed by php-4.3.9-3.22.4.i386
libxml2-devel >= 2.4.14-1 is needed by php-4.3.9-3.22.4.i386
ncurses-devel is needed by php-4.3.9-3.22.4.i386
freetype-devel is needed by php-4.3.9-3.22.4.i386


must i install those by hand? or can i use the default repo for this?
TheScorpio
 
Posts: 5
Joined: 2007/11/22 15:01:37

Re: Install PHP4, old repository?

Postby TheScorpio » 2007/12/18 13:22:34

I've just installed the missing things with
yum install bzip2-devel curl-devel db4-devel expat-devel gmp-devel aspell-devel httpd-devel libjpeg-devel libpng-devel pam-devel pcre-devel libtool libc-client-devel postgresql-devel unixODBC-devel net-snmp-devel elfutils-devel libxslt-devel libxml2-devel ncurses-devel freetype-devel


But again get a few errors... isn't there a repo with the php4 still in it?
TheScorpio
 
Posts: 5
Joined: 2007/11/22 15:01:37

Re: Install PHP4, old repository?

Postby Lenard » 2007/12/18 15:19:11

CentOS 4.X still is supported and has php 4 rpm packages, CentOS 5 was released with php 5.
Lenard
 
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests