Missing Dependency: libexif.so.9

Issues related to software problems.

Missing Dependency: libexif.so.9

Postby Chaki » 2008/01/03 01:13:32

Trying to install mono on CentOS 5, but during the install i keep getting

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package mono-core.i586 0:1.2.6-4.novell set to be updated
--> Running transaction check
--> Processing Dependency: libgdiplus for package: mono-core
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libgdiplus.i386 0:1.2.6-2.rhel4.novell set to be updated
--> Running transaction check
--> Processing Dependency: libexif.so.9 for package: libgdiplus
--> Finished Dependency Resolution
Error: Missing Dependency: libexif.so.9 is needed by package libgdiplus


Is there some easy fix for this or is there some package im missing that i can't find out of?

Been trying to google this and search diffrent places for hours now with no luck so far.

Any suggestions would be more than welcome :)
Chaki
 
Posts: 3
Joined: 2008/01/03 01:09:43

Re: Missing Dependency: libexif.so.9

Postby toracat » 2008/01/03 01:21:22

Chaki wrote:

---> Package mono-core.i586 0:1.2.6-4.novell set to be updated

Are you trying to get it from suse ??? mono is available from CentOS extras repository.
User avatar
toracat
Forum Moderator
 
Posts: 6695
Joined: 2006/09/03 16:37:24
Location: California, US

Re: Missing Dependency: libexif.so.9

Postby Chaki » 2008/01/03 01:27:08

Its trying to do it over yum, and its using the repo file provided from there under centos distro.

Gonna do some checking again and see what it will do.
Chaki
 
Posts: 3
Joined: 2008/01/03 01:09:43

Re: Missing Dependency: libexif.so.9

Postby toracat » 2008/01/03 02:28:27

Just make sure that the extras repository is enabled and do a 'yum install mono-core'. I get:

Code: Select all
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 mono-core               x86_64     1.2.4-2.el5.centos  extras             11 M
Installing for dependencies:
 libgdiplus              x86_64     1.2.5-1.el5.centos  extras            375 k

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
User avatar
toracat
Forum Moderator
 
Posts: 6695
Joined: 2006/09/03 16:37:24
Location: California, US

Re: Missing Dependency: libexif.so.9

Postby Chaki » 2008/01/03 03:46:16

Thanks for the help here, so far i got it going at least with version 1.2.4
yum update however wont update it to 1.2.6 but that is currently just a minor little hitch
i will eventually get around and working i hope.

Thanks for the help so far its been great and fast.
Chaki
 
Posts: 3
Joined: 2008/01/03 01:09:43

Re: Missing Dependency: libexif.so.9

Postby monkey » 2008/02/10 17:53:15

I am having the same problem. What is the the URL of the Mono rpms that I can can use to download the old version to make it work for now?
monkey
 
Posts: 2
Joined: 2008/02/10 17:47:45

Re: Missing Dependency: libexif.so.9

Postby toracat » 2008/02/10 18:24:14

Just make sure the extras repo is enabled. Or use:

yum --enablerepo=extras
User avatar
toracat
Forum Moderator
 
Posts: 6695
Joined: 2006/09/03 16:37:24
Location: California, US

Re: Missing Dependency: libexif.so.9

Postby joaster » 2008/02/10 18:34:15

Hi all,

An hour ago I had the same problem, but I fixed it enabling the 'centosplus' repo.
# vi /etc/yum.repos.d/CentOS-Base.repo => then enabled=1 under [centosplus]
The 'extra' repo is enabled by default and does not fix the problem.

Regards,
Joost.
joaster
 
Posts: 3
Joined: 2008/02/10 18:24:29

Re: Missing Dependency: libexif.so.9

Postby joaster » 2008/02/10 18:52:46

Addition to my previous post: add includepkgs=libgdiplus under [centosplus] to make sure you only use the libgdiplus package from the centosplus repo.
joaster
 
Posts: 3
Joined: 2008/02/10 18:24:29

Re: Missing Dependency: libexif.so.9

Postby joaster » 2008/02/10 19:26:37

Weird though, I just see in toracats post that his libgdiplus package comes from the extras repo.

This is the output I get from yum:
Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
mono-core x86_64 1.2.4-2.el5.centos extras 11 M
Installing for dependencies:
libgdiplus x86_64 1.2.5-1.el5.centos centosplus 375 k

Transaction Summary
=============================================================================
Install 2 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
joaster
 
Posts: 3
Joined: 2008/02/10 18:24:29

Next

Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: No registered users and 2 guests