./configure unable to find X11 libraries

Issues related to software problems.
Post Reply
hoodcanaljim
Posts: 273
Joined: 2006/02/05 17:49:10

./configure unable to find X11 libraries

Post by hoodcanaljim » 2008/01/10 03:43:28

Hi

I am trying to install plugger on firefox 1.5.012 in centos 5.0
during the first step of plugger-5.1.3 ./configure exits with the
error: Unable to find X11 libraries

From reading around the net it appears there should be a
directory /usr/X11R6/lib but the only subdirectory is bin.
I've looked at all the packages that are listed for my installation
that are available and there is nothing listed that looks right. I've
installed everything I see with lib in it for xorg.

Any ideas what I am missing?

Thanks
Jim

list of installed packages

xorg-x11-drv-cyrix-1.1.0-4
xorg-x11-drv-sis-0.9.1-7
xorg-x11-drv-ark-0.6.0-2.1
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-fonts-misc-7.1-2.1.el5
xorg-x11-drv-mouse-1.1.1-1.1
xorg-x11-xfs-1.0.2-4
xorg-x11-drv-vesa-1.3.0-8.1.el5
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-xauth-1.0.1-2.1
xorg-x11-drv-i740-1.1.0-2.1
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-drv-s3-0.4.1-2.1
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-fonts-Type1-7.1-2.1.el5
xorg-x11-server-Xorg-1.1.1-48.26.el5
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-fpit-1.1.0-1.1
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-drv-apm-1.1.1-2.1
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-palmax-1.1.0-1.1
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-drv-neomagic-1.1.1-2.1
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-fonts-100dpi-7.1-2.1.el5
xorg-x11-fonts-truetype-7.1-2.1.el5
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-apps-7.1-4.0.1.el5
xorg-x11-server-Xvfb-1.1.1-48.26.el5
xorg-x11-drv-i810-1.6.5-9.6.el5
xorg-x11-drv-i810-devel-1.6.5-9.6.el5
xorg-x11-twm-1.0.1-3.1
xorg-x11-xinit-1.0.2-13.el5
xorg-x11-utils-7.1-2.fc6
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-drv-glint-1.1.1-4.1
xorg-x11-drv-fbdev-0.3.0-2
xorg-x11-drv-chips-1.1.1-2.1
xorg-x11-drv-elo2300-1.1.0-1.1
xorg-x11-drivers-7.1-4.1.el5
xorg-x11-font-utils-7.1-2
xorg-x11-fonts-75dpi-7.1-2.1.el5
xorg-x11-xtrans-devel-1.0.1-1.1.fc6
xorg-x11-drv-evdev-1.0.0.5-3.el5
xorg-x11-drv-mga-1.4.2-6.el5
xorg-x11-drv-trident-1.2.1-3.fc6
xorg-x11-drv-v4l-0.1.1-4
xorg-x11-drv-via-0.2.1-9
xorg-x11-drv-rendition-4.1.0-3.1
xorg-x11-drv-tdfx-1.2.1-3.1
xorg-x11-drv-ati-6.6.3-3.2.el5
xorg-x11-fonts-base-7.1-2.1.el5
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2.1.el5
xorg-x11-util-macros-1.0.2-4.fc6
xorg-x11-server-sdk-1.1.1-48.26.el5
xorg-x11-drv-keyboard-1.1.0-3
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-drv-nsc-2.8.1-2.1
xorg-x11-drv-tek4957-1.1.0-1.1
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-drv-i128-1.2.0-4
xorg-x11-drv-tseng-1.1.0-3.1
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5
xorg-x11-proto-devel-7.1-9.el5.centos
xorg-x11-xbitmaps-1.0.1-4.1
xorg-x11-server-Xnest-1.1.1-48.26.el5
xorg-x11-drv-nv-2.1.2-1.el5

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E
Contact:

Re: ./configure unable to find X11 libraries

Post by yyagol » 2008/01/10 05:42:49

[code][root@lan-199 ~]# yum info libX11-devel
Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
Name : libX11-devel
Arch : i386
Version: 1.0.3
Release: 8.0.1.el5
Size : 770 k
Repo : installed
Summary: X.Org X11 libX11 development package

Description:
X.Org X11 libX11 development package[/code]

hoodcanaljim
Posts: 273
Joined: 2006/02/05 17:49:10

Re: ./configure unable to find X11 libraries

Post by hoodcanaljim » 2008/01/10 16:14:34

Thanks yyagol

I ran the command "yum info libX11-devel" and got the same response you show. So the Libs are there.
I tried runing "./configure --x-libraries=/usr/lib/" and "/configure --x-libraries=/usr/include/X11/"
but got the same old error.

plugger-5.1.3]# ./configure --x-libraries=/usr/include/X11/

checking whether make sets $(MAKE)... yes
checking how to run the C preprocessor... gcc -E
checking for X... libraries /usr/include/X11/, headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for atexit in -ldl... yes
configure: error: Unable to find X11 libraries


This is the output of "rpm -ql libX11-devel"

/usr/include/X11
/usr/include/X11/ImUtil.h
/usr/include/X11/XKBlib.h
/usr/include/X11/Xcms.h
/usr/include/X11/Xlib.h
/usr/include/X11/XlibConf.h
/usr/include/X11/Xlibint.h
/usr/include/X11/Xlocale.h
/usr/include/X11/Xregion.h
/usr/include/X11/Xresource.h
/usr/include/X11/Xutil.h
/usr/include/X11/cursorfont.h
/usr/lib/libX11.so
/usr/lib/lib/usr/lib/pkgconfig/x11.pc
/usr/share/man/man3/AllPlanes.3x.gz
/usr/share/man/man3/BitmapBitOrder.3x.gz


Thanks Jim

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E
Contact:

Re: ./configure unable to find X11 libraries

Post by yyagol » 2008/01/10 19:38:07

Well you need to install it , make sure its installed

[code]# yum install libX11-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do


# rpm -qa|grep libX11
libX11-1.0.3-8.0.1.el5
libX11-devel-1.0.3-8.0.1.el5[/code]

hoodcanaljim
Posts: 273
Joined: 2006/02/05 17:49:10

Re: ./configure unable to find X11 libraries

Post by hoodcanaljim » 2008/01/10 21:35:56

Sorry yyagol

I must not have made myself clear.
The required files have been on my computer all the time.
NOTE: these are from my computer

plugger-5.1.3]# yum install libX11-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

plugger-5.1.3]# rpm -qa | grep libX11
libX11-devel-1.0.3-8.0.1.el5
libX11-1.0.3-8.0.1.el5

*---------------------------------*
Since they are there I tried pointing at what I though was there location

Output of % rpm -ql libX11-devel
/usr/include/X11
/usr/include/X11/ImUtil.h
/usr/include/X11/XKBlib.h
/usr/include/X11/Xcms.h
/usr/include/X11/Xlib.h
/usr/include/X11/XlibConf.h
/usr/include/X11/Xlibint.h
/usr/include/X11/Xlocale.h
/usr/include/X11/Xregion.h
/usr/include/X11/Xresource.h
/usr/include/X11/Xutil.h
/usr/include/X11/cursorfont.h
/usr/lib/libX11.so
/usr/lib/pkgconfig/x11.pc
/usr/share/man/man3/AllPlanes.3x.gz


So I tried:
plugger-5.1.3]# ./configure --x-libraries=/usr/include/X11/

and got
hecking how to run the C preprocessor... gcc -E
checking for X... libraries /usr/include/X11/, headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for atexit in -ldl... yes
configure: error: Unable to find X11 libraries

And I tried:
plugger-5.1.3]# ./configure --x-libraries=/usr/lib

checking for X... libraries /usr/lib, headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for atexit in -ldl... yes
configure: error: Unable to find X11 libraries

Looks like I still don't know the magic word

Thanks Jim

User avatar
toracat
Forum Moderator
Posts: 7346
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: ./configure unable to find X11 libraries

Post by toracat » 2008/01/10 22:21:03

I read somewhere that plugger is no longer being actively developed and we should use mozplugger.

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E
Contact:

Re: ./configure unable to find X11 libraries

Post by yyagol » 2008/01/11 21:49:28

Its true i read that too , but i did manage to compile this source without any problems
here is the list of devel package installed on my comp , for im not sure which one you do need
hope this helps but i would take [b]toracat[/b] advice and try to use mozplugger . plugger has stoped at 2001 ,
i guess moving on is th right choice

[code]xorg-x11-proto-devel-7.1-9.el5.centos
libXrandr-devel-1.1.1-3.1
libglade2-devel-2.6.0-2
dbus-glib-devel-0.70-5
esound-devel-0.2.36-3
libgnomeui-devel-2.16.0-5.el5
libstdc++-devel-4.1.2-14.el5
libpng-devel-1.2.10-7.1.el5_0.1
libXft-devel-2.1.10-1.1
libwnck-devel-2.16.0-4.fc6
libbonobo-devel-2.16.0-1.fc6
libSM-devel-1.0.1-3.1
librsvg2-devel-2.16.1-1.el5
zlib-devel-1.2.3-3
atk-devel-1.12.2-1.fc6
libXrender-devel-0.9.1-3.1
pango-devel-1.14.9-3.el5.centos
libXi-devel-1.0.1-3.1
libXdmcp-devel-1.0.1-2.1
dbus-devel-1.0.0-6.el5
libgpg-error-devel-1.4-2
libart_lgpl-devel-2.3.17-4
libbonoboui-devel-2.16.0-1.fc6
gnome-desktop-devel-2.16.0-1.el5.centos.1
glibc-devel-2.5-18.el5_1.1
alsa-lib-devel-1.0.14-1.rc4.el5
mesa-libGL-devel-6.5.1-7.5.el5
libXau-devel-1.0.1-3.1
libXinerama-devel-1.0.1-2.1
libXcursor-devel-1.1.7-1.1
libxml2-devel-2.6.26-2.1.2
ORBit2-devel-2.14.3-4.el5
libgcrypt-devel-1.2.3-1
sqldeveloper-1.2.1.32.13-1
audiofile-devel-0.2.6-5
libgnomecanvas-devel-2.14.0-4.1
gnome-keyring-devel-0.6.0-1.fc6
libgsf-devel-1.14.1-6.1
freetype-devel-2.2.1-19.el5
fontconfig-devel-2.4.1-6.el5
libXext-devel-1.0.1-2.1
GConf2-devel-2.14.0-9.el5
libxslt-devel-1.1.17-2
libICE-devel-1.0.1-2.1
libcroco-devel-0.6.1-2.1
cairo-devel-1.2.4-3.el5_1
gtk2-devel-2.10.4-19.el5
glib2-devel-2.12.3-2.fc6
libX11-devel-1.0.3-8.0.1.el5
libXfixes-devel-4.0.1-2.1
libIDL-devel-0.8.7-1.fc6
gnome-vfs2-devel-2.16.2-4.el5
libgnome-devel-2.16.0-6.el5
startup-notification-devel-0.8-4.1
hal-devel-0.5.8.1-25.el5_1.1[/code]

hoodcanaljim
Posts: 273
Joined: 2006/02/05 17:49:10

Re: ./configure unable to find X11 libraries

Post by hoodcanaljim » 2008/01/11 23:56:00

Thanks to everyone who answered this one...

But its time to move on.... I've spun my wheels over this for so long the original problem that caused me to try to load plugger has been "worked around" and will be the subject of a new topic in this forum..

All the files you listed for me, yyagol. Appear to be there so what the hangup is I don't know..

Thanks again
Jim



[quote]
yyagol wrote:
Its true i read that too , but i did manage to compile this source without any problems
here is the list of devel package installed on my comp , for im not sure which one you do need
hope this helps but i would take [b]toracat[/b] advice and try to use mozplugger . plugger has stoped at 2001 ,
i guess moving on is th right choice

[code]xorg-x11-proto-devel-7.1-9.el5.centos
libXrandr-devel-1.1.1-3.1
libglade2-devel-2.6.0-2
dbus-glib-devel-0.70-5
esound-devel-0.2.36-3
libgnomeui-devel-2.16.0-5.el5
libstdc++-devel-4.1.2-14.el5
libpng-devel-1.2.10-7.1.el5_0.1
libXft-devel-2.1.10-1.1
libwnck-devel-2.16.0-4.fc6
<snip>
startup-notification-devel-0.8-4.1
hal-devel-0.5.8.1-25.el5_1.1[/code][/quote]

spankbot
Posts: 7
Joined: 2008/11/12 04:46:33
Contact:

Re: ./configure unable to find X11 libraries

Post by spankbot » 2008/11/12 07:52:02

Someone helped me with this today. There are a whole bunch of devel rpms that need to be installed for you to be able to compile X11 stuff.

The command:

yum groupinfo "X Software Development"

Will list the rpms needed. You can install them all in one shot with

yum groupinstall "X Software Development"

Post Reply