Remote desktop ( Visual GUI)

Issues related to software problems.
seba22
Posts: 8
Joined: 2008/05/22 12:35:29

Remote desktop ( Visual GUI)

Post by seba22 » 2008/05/22 12:42:31

Hi,
I have instaled CentOS version 5 on my webserver.


Now, i'm using SSH for configuration's.

But i need to allow for some users, remote desktop, you know a Visual Gui, KDE desktop, like RDC on Windows Machine.

Is this possible ?

If possible, whats program i need to install on server, and on windows clients.




Next thing is, its possible to allow Visual Remote Desktop by webbrowsher ?
Some users, need acces to files, from internet caffe or office.
Its impossible, to install there any software for remote connection :/
The beetter option will be, some script on www by https protocol.



Regards for any ideas

scottro
Forum Moderator
Posts: 2378
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: Remote desktop ( Visual GUI)

Post by scottro » 2008/05/22 16:58:47

The quick answer is yes, the remote desktop is possible. Go to the wiki and look for the article on FreeNX. Most of us find it much faster than VNC.
Not sure about the second, I've never tried that.

NedSlider
Forum Moderator
Posts: 2887
Joined: 2005/10/28 13:11:50
Location: UK

Re: Remote desktop ( Visual GUI)

Post by NedSlider » 2008/05/22 17:51:58

Regarding your second query, I know VNC has java capabilities and can be used in a java-enabled browser. However, the standard VNC doesn't use encryption and is slow so isn't ideal for remote connections over the Internet.

Maybe someone knows of other alternatives for browser based solutions?

seba22
Posts: 8
Joined: 2008/05/22 12:35:29

Re: Remote desktop ( Visual GUI)

Post by seba22 » 2008/05/24 12:53:17

Hi,

I just came from work, and try to install NoMachine server.

I installed this version:


[code]Installed: freenx.i386 0:0.7.1.svn416-3.el5.centos nx.i386 0:3.0.0-4.el5.centos Dependency Installed: expect.i386 0:5.43.0-5.1 libXcomposite.i386 0:0.3-5.1 Complete! [/code]

next i copy default config
[code]cd /etc/nxserver ; cp node.conf.sample node.conf[/code]


next edit config sshd
[quote][root@serwercentralny nxserver]# vi /etc/ssh/sshd_config [/quote]

This is my config file after modification

[code]
[root@serwercentralny nxserver]# vi /etc/ssh/sshd_config
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication mechanism.
# Depending on your PAM configuration, this may bypass the setting of
# PasswordAuthentication, PermitEmptyPasswords, and
# "PermitRootLogin without-password". If you just want the PAM account and
# session checks to run without PAM authentication, then enable this but set
# ChallengeResponseAuthentication=no
#UsePAM no
UsePAM yes

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#ShowPatchLevel no
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10
#PermitTunnel no

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem sftp /usr/libexec/openssh/sftp-server
DenyGroups deniedssh
[/code]


[code]
Another config file:
[root@serwercentralny nxserver]# vi /etc/nxserver/node.conf
# Linux distribution, you can assume that this dependency is taken care of
# by the tool.
#
# You have questions about the inner workings of the NX technology?
#
# Then you are recommended to first check out the rich and very detailed
# NoMachine documentation and their online Knowledge Base at
#
# http://www.nomachine.com/kb/
#
# Other sources of information are the NoMachine mailing lists
# (nxusers@nomachine.com and nxdevelopers@nomachine.com):
#
# http://www.nomachine.com/mailinglists.php
#
# The FreeNX (freenx-knx@kde.org) list is here:
#
# https://mail.kde.org/mailman/listinfo/freenx-knx
#
# SVN: $Id: node.conf.sample 402 2007-10-14 18:21:43Z fabianx $

#########################################################################
# General FreeNX directives
#########################################################################

# The host name which is used by NX server. It's should be used if it's
# different than the default hostname (as returned by `hostname`)
#SERVER_NAME="$(hostname)"

# The port number where local 'sshd' is listening.
#SSHD_PORT=22


#########################################################################
# Authentication / Security directives
#########################################################################

# Authentication directives

# This adds the usermode to the possible authentication methods
# Usermode means that a user can start the nxserver as his shell
# and connect directly to the right server via a custom client.
#ENABLE_USERMODE_AUTHENTICATION="0"

# This adds the passdb to the possible authentication methods
ENABLE_PASSDB_AUTHENTICATION="1"

# This adds SSH to the possible authentication methods. For it to work sshd
# must be set up at localhost accepting password authentication.
#ENABLE_SSH_AUTHENTICATION="1"


[/code]

and another

[code]

[root@serwercentralny nxserver]# vi /etc/ssh/sshd_config
#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no
PasswordAuthentication yes

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication mechanism.
# Depending on your PAM configuration, this may bypass the setting of
# PasswordAuthentication, PermitEmptyPasswords, and
# "PermitRootLogin without-password". If you just want the PAM account and
# session checks to run without PAM authentication, then enable this but set
# ChallengeResponseAuthentication=no
#UsePAM no
UsePAM yes

[/code]
Next i add accounts
[code]
[root@serwercentralny nxserver]# nxserver --adduser root
NX> 100 NXSERVER - Version 2.1.0-72-SVN OS (GPL)
NX> 1000 NXNODE - Version 2.1.0-72-SVN OS (GPL)
NX> 716 Public key added to: /root/.ssh/authorized_keys2
NX> 1001 Bye.
NX> 999 Bye
[root@serwercentralny nxserver]# nxserver --passwd root
NX> 100 NXSERVER - Version 2.1.0-72-SVN OS (GPL)
New password:
Password changed.
NX> 999 Bye
[/code]

next restart

[code]
[root@serwercentralny nxserver]# service sshd restart
Zatrzymywanie sshd: [ OK ]
Uruchamianie sshd: [ OK ]
[/code]


and it won't work :(

When i try to connect by client i'm getting:

[code]
NX> 203 NXSSH running with pid: 10548
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.0.20 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.
[/code]


Please, let me know, what i do wrong, if you need any information just ask.
I'm not good in linux, but i'm trying ;)

seba22
Posts: 8
Joined: 2008/05/22 12:35:29

Re: Remote desktop ( Visual GUI)

Post by seba22 » 2008/05/24 13:38:02

I forgot to copy Private Key.

But it still won't work.

This is error log:

[code]
Info: Display running with pid '14148' and handler '0x1b10e8'.

NXPROXY - Version 3.2.0

Copyright (C) 2001, 2007 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '12868'.
Session: Starting session at 'Sat May 24 15:36:39 2008'.
Warning: Connected to remote version 3.0.0 with local version 3.2.0.
Info: Connection with remote proxy completed.
Warning: Unrecognized session type 'unix-kde'. Assuming agent session.
Info: Using ADSL link parameters 512/24/1/0.
Info: Using cache parameters 4/4096KB/16384KB/16384KB.
Info: Using pack method 'adaptive-7' with session 'unix-kde'.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: No suitable cache file found.
Info: Forwarding X11 connections to display ':0'.
Info: Listening to font server connections on port '11000'.
Session: Session started at 'Sat May 24 15:36:40 2008'.
Info: Established X server connection.
Info: Using shared memory parameters 0/0K.
Session: Terminating session at 'Sat May 24 15:36:41 2008'.
Session: Session terminated at 'Sat May 24 15:36:41 2008'.
[/code]

User avatar
toracat
Forum Moderator
Posts: 7284
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Remote desktop ( Visual GUI)

Post by toracat » 2008/05/24 13:39:30

My suggestion is to try setting it up by first skipping section [b]2. Key-based authentication[/b] entirely. If you successfully get it to work, you can do the authentication part (if you wish). Also be sure to follow section 3 step by step to install the client.

[EDIT] Just saw the post you added. It may not be an authentication issue then.

seba22
Posts: 8
Joined: 2008/05/22 12:35:29

Re: Remote desktop ( Visual GUI)

Post by seba22 » 2008/05/24 13:45:52

Hi,

Thank you.

I forgot, i don't have KDE on server ;)


When i change to gnome, working ok.

But why NXWin client take 100 % of core 2 duo CPU ?

[url=http://www.bankfotek.pl/view/77932][img]http://www.bankfotek.pl/thumb/77932.jpeg[/img][/url]


This client is UN USERFULL, 100 % CPU, i can't do antyhing :/

Anyone know, how to install something else for remote desktop ?

User avatar
toracat
Forum Moderator
Posts: 7284
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Remote desktop ( Visual GUI)

Post by toracat » 2008/05/24 15:20:13

I currently do not have a Win client. Will test it today myself.

User avatar
toracat
Forum Moderator
Posts: 7284
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Remote desktop ( Visual GUI)

Post by toracat » 2008/05/26 05:10:46

I downloaded nxclient from Nomachine and installed it in Windows running on a core 2 duo laptop. I then connected to a CentOS-5 box. It seems to be working just fine without any cpu issue.

scottro
Forum Moderator
Posts: 2378
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: Remote desktop ( Visual GUI)

Post by scottro » 2008/05/26 10:56:43

I also tried the nomachines client on Windows and I can't duplicate the 100 percent CPU usage. I wonder if it's worth uninstalling it and reinstalling it? (That might be a waste of time, but I haven't heard of the issue before so it might be wort trying.)

Post Reply