libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Issues related to software problems.

libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Postby ralf » 2009/06/23 19:56:05

Hi,

I run CentOS 5.3 which has package libstdc++-4.1.2-44.el5.i386.rpm installed which provides:

libstdc++
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(CXXABI_1.3.1)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.1)
libstdc++.so.6(GLIBCXX_3.4.2)
libstdc++.so.6(GLIBCXX_3.4.3)
libstdc++.so.6(GLIBCXX_3.4.4)
libstdc++.so.6(GLIBCXX_3.4.5)
libstdc++.so.6(GLIBCXX_3.4.6)
libstdc++.so.6(GLIBCXX_3.4.7)
libstdc++.so.6(GLIBCXX_3.4.8)
libstdc++

but NOT libstdc++.so.6(GLIBCXX_3.4.9) which I need for an application I want to install.

The newer version of libstdc++, used by fedora10 is libstdc++-4.3.2-7.i386.rpm, which provides the same as above, plus libstdc++.so.6(GLIBCXX_3.4.9) which I need!!

When testing to upgrade the machine with the fedora package, the machine replies:
[root@ralf Headweb]# rpm -Uvh --test libstdc++-4.3.2-7.i386.rpm
warning: libstdc++-4.3.2-7.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4ebfc273
error: Failed dependencies:
libstdc++ = 4.1.2-44.el5 is needed by (installed) gcc-c++-4.1.2-44.el5.i386
libstdc++ = 4.1.2-44.el5 is needed by (installed) libstdc++-devel-4.1.2-44.el5.i386
[root@ralf Headweb]#

The first warning (NOKEY) is probably harmless,but what about the first lines after the "error:"? It says that version 4.1.2-44.el5 is required by gcc.
The second line on libstdc++-devel is probably easy to solve by upgrading the corresponding -devel package.

Is the "gcc error" serious or could I do a real upgrade with --force to override the error message?
Or should I upgrade the gcc package as well? Is this feasible and/or recommended or is this a major change with severe risks ...?

Appreciate your comments!

Ralf
ralf
 
Posts: 68
Joined: 2005/11/25 20:10:20

Re: libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Postby pschaff » 2009/06/24 21:55:37

All I can say is don't do that!

Please do the "Required reading" and particularly pay attention to the recommendations on software installation. If you really need Fedora core packages, then CentOS is not for you. Run Fedora, either on the bare hardware, or in a virtual machine. Trying to force installation of Fedora versions of core packages on CentOS is a recipe for disaster.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Postby gmcc » 2009/07/22 18:36:09

Hi,

I found your message on "GLIBCXX_3.4.9 not found" and I am going through the same problem as I really need it to run a software package at work (CentOS 5.3, 64-bit).

I have asked help from the support personnel at the company that distributes the software, and I was suggested to install the newer version of libstdc++ used by fedora10 (libstdc++-4.3.2-7.i386.rpm, also the 64-bit version). They have tested it on a virtual machine running CentOS5.3, and it seemed to work fine.

But now the answer to this message is not in agreement with the suggestion, and you say it is a way "to disaster".

If so, can you indicate a solution/proper way to install GLIBCXX_3.4.9 on CentOS5.3?

Note that I am a newbie...

Thanks a lot!

Regina
gmcc
 
Posts: 2
Joined: 2009/07/22 18:21:50

Re: libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Postby ralf » 2009/07/22 21:15:47

Hi Regina,
I tried to find out to which degree I need to install fedora 10 packages. It turned out to be quite a few, and I stil don't have a complete list.... If you start installing one fedore package, you find more and more dependency problems, which require even more fedora10 packages.
I stopped a while ago in digging into this, after having checked the following required packages by using the command $ rpm - Uvh --test

[ralf@ralf ~]$ ll /home/ralf/Download/Headweb/fedora10
total 54940
-rw-rw-r-- 1 ralf ralf 3274011 Jun 24 22:07 binutils-2.18.50.0.9-7.fc10.i386.rpm
-rw-rw-r-- 1 ralf ralf 856491 Jun 24 22:07 binutils-devel-2.18.50.0.9-7.fc10.i386.rpm
-rw-rw-r-- 1 ralf ralf 3240135 Jun 24 22:08 cpp-4.3.2-7.i386.rpm
-rw-rw-r-- 1 ralf ralf 8590552 Jun 24 22:05 gcc-4.3.2-7.i386.rpm
-rw-rw-r-- 1 ralf ralf 4074210 Jun 24 22:00 gcc-c++-4.3.2-7.i386.rpm
-rw-rw-r-- 1 ralf ralf 4999329 Jun 24 22:16 glibc-2.9-2.i386.rpm
-rw-rw-r-- 1 ralf ralf 22727800 Jun 24 22:17 glibc-common-2.9-2.i386.rpm
-rw-rw-r-- 1 ralf ralf 2228772 Jun 24 22:16 glibc-devel-2.9-2.i386.rpm
-rw-rw-r-- 1 ralf ralf 630193 Jun 24 22:16 glibc-headers-2.9-2.i386.rpm
-rw-rw-r-- 1 ralf ralf 401142 Jun 24 22:12 gmp-4.2.2-8.fc10.i386.rpm
-rw-rw-r-- 1 ralf ralf 173161 Jun 24 22:19 gmp-devel-4.2.2-8.fc10.i386.rpm
-rw-rw-r-- 1 ralf ralf 30367 Jun 24 22:20 libcap-2.10-2.fc10.i386.rpm
-rw-rw-r-- 1 ralf ralf 53705 Jun 24 22:08 libgcc-4.3.2-7.i386.rpm
-rw-rw-r-- 1 ralf ralf 82043 Jun 24 22:09 libgomp-4.3.2-7.i386.rpm
-rw-rw-r-- 1 ralf ralf 332230 Jun 23 22:00 libstdc++-4.3.2-7.i386.rpm
-rw-rw-r-- 1 ralf ralf 3973692 Jun 24 22:02 libstdc++-devel-4.3.2-7.i386.rpm
-rw-rw-r-- 1 ralf ralf 152259 Jun 24 22:11 mpfr-2.3.2-1.fc10.i386.rpm
-rw-rw-r-- 1 ralf ralf 193325 Jun 24 22:18 nscd-2.9-2.i386.rpm
[ralf@ralf ~]$

.....and this is still not a solution, it seems, because I still get this:

[root@ralf fedora10]# rpm -Uvh --test *.rpm (applied on all downloaded fedora10 packages above)
warning: binutils-2.18.50.0.9-7.fc10.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4ebfc273
error: Failed dependencies:
libcap.so.1 is needed by (installed) mcstrans-0.2.11-3.el5.i386
libcap.so.1 is needed by (installed) dbus-libs-1.1.2-12.el5.i386
libcap.so.1 is needed by (installed) libcap-devel-1.10-26.i386
libcap.so.1 is needed by (installed) avahi-0.6.16-1.el5_2.1.i386
libcap.so.1 is needed by (installed) sudo-1.6.9p17-3.el5_3.1.i386
libcap.so.1 is needed by (installed) dbus-x11-1.1.2-12.el5.i386
libcap.so.1 is needed by (installed) dbus-1.1.2-12.el5.i386
libcap.so.1 is needed by (installed) ntp-4.2.2p1-9.el5.centos.2.i386
libcap.so.1 is needed by (installed) vsftpd-2.0.5-12.el5_3.1.i386
libcap = 1.10-26 is needed by (installed) libcap-devel-1.10-26.i386
[root@ralf fedora10]#

Could you give some more details on the results from the installation on the virtual machine?

Thanks,

Ralf
ralf
 
Posts: 68
Joined: 2005/11/25 20:10:20

Re: libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Postby abednegoyulo » 2009/07/23 02:41:05

ralf wrote:
which require even more fedora10 packages.


And by the time you finish the dependencies, its now more of a FC10 than a CentOS5.3. To resolve your issue, as pschaff stated

pschaff wrote:
Run Fedora, either on the bare hardware, or in a virtual machine.


The reason why CentOS is CentOS is because of the packages that it uses, not the latest and the greatest but backported ones for the main purpose of being stable. The reason why Fedora is Fedora is because of its cutting edge packages. If you need those cutting edge packages, then it is more suitable to use Fedora than to modify Centos to be more Fedora like.

Think of this: What happens when your modified CentOS breaks in 2am? Where would you seek help? CentOS forums or Fedora forums? I will not be surprised if you would not be getting any help from the CentOS forums because nobody can replicate your system because in order to do so, they must also modify the packages that you have modified, which will make the system less CentOS. If you are going to seek help from the Fedora forums, they might say "you have a CentOS system, please go to CentOS forums for help." I hope this cleared things up on why pschaff suggested that you use Fedora.

I am just curious, why do you choose CentOS over Fedora?
abednegoyulo
 
Posts: 550
Joined: 2007/12/26 06:24:38
Location: 127.0.0.2 44013

Re: libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Postby ralf » 2009/07/23 06:22:44

Hi,

Thanks for your comment/question. The reason for using CentOS is that it is one of the most stable OS. Period. I use CentOs4.7 on my main web/mail sever and CentOS5.3 on 2 desktops.

However, that being said, you also need to be able to run the software you need. Some years ago, I exchanged one or two packages with fedore and that helped me to run some software I need. So I started to do the same thing this time, but I soon realized that I would end up with "fedora" instead of CentOs5. And that is why I stopped, just like you said.

For other linux based software (not running on CentOS) I normally use Ubuntu in VMware. That is what I am doing now with the required software which initiated this thread. For some specific applications I am forced to run XP in VMware (only a couple of times per year).
I find Ubuntu an OS that has an interesting combination of stability and up-to-date software, especially compared to Fedora. If this is going to grow more and keeping the stability as an important requirement, I may consider to change to Ubuntu as my main OS for my desktops, but I don't foresee this change on my server (yet?).

In the mean time I continue with CentOS5 on 2 of my desktops and CentOS4 on my web/mailserver! Thanks for a great OS and a great forum.

Thanks,
Ralf
ralf
 
Posts: 68
Joined: 2005/11/25 20:10:20

Re: libstdc++.so.6: version `GLIBCXX_3.4.9' not found

Postby gmcc » 2009/07/23 11:11:10

Hi Ralf,

Thanks for your update on the Fedora10 packages in CentOS5.

Could you give some more details on the results from the installation on the virtual machine?
Ralf


I can not tell you those details, as It was not me who did the installation on the virtual machine. But, according to, I was not informed on any dependency issues , it seemed that in the virtual machine the software package started to work fine afterwards the Fedora package installation.

Why CentOS? Well, not sure, the informatics personnel so decided. It may be because it is stable, and also because other software we use is compatible with CentOS.

Thanks!

Regina
gmcc
 
Posts: 2
Joined: 2009/07/22 18:21:50


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: No registered users and 0 guests