How install a lot of program

Issues related to software problems.

How install a lot of program

Postby nedonodo » 2010/02/09 15:20:47

Hi,

I'm new about CentOS. I don't know how to work repository system. I'm coming from Ubuntu where I can find a program through apt-get.
I would like to know how I can find a program in repository
I need to install the following software:
1)VLC
2)SIPp
3)Image Magick
4)Speex library (yum install speex speex-devel)

I can install all by source code but it's too long. Can you help me?

Thank you
nedonodo
 
Posts: 5
Joined: 2010/02/09 15:09:23

How install a lot of program

Postby gerald_clark » 2010/02/09 15:36:13

Welcome to CentOS, but please do the required reading.
http://www.centos.org/modules/newbb/vie ... p?forum=47

Also, 'man yum' to learn its capabilities.
gerald_clark
 
Posts: 7162
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: How install a lot of program

Postby nedonodo » 2010/02/09 16:54:55

nedonodo wrote:
Hi,

I'm new about CentOS. I don't know how to work repository system. I'm coming from Ubuntu where I can find a program through apt-get.
I would like to know how I can find a program in repository
I need to install the following software:
1)VLC
2)SIPp
3)Image Magick
4)Speex library (yum install speex speex-devel)

I can install all by source code but it's too long. Can you help me?

Thank you


Thank you. I have solved for VLC and ImageMagick but I can't find SIPp.
Where can I find it?
nedonodo
 
Posts: 5
Joined: 2010/02/09 15:09:23

Re: How install a lot of program

Postby milosb » 2010/02/09 18:11:53

nedonodo wrote:

Thank you. I have solved for VLC and ImageMagick but I can't find SIPp.
Where can I find it?

You can find sipp in epel repository.

Please read:
http://wiki.centos.org/AdditionalResources/Repositories
for available CentOS repositories, as well as:
http://wiki.centos.org/PackageManagement/Yum/Priorities
to make sure you don't make a mess with your packages.

Speex is currently installed on my system, and I may be wrong, but it seems to be coming from one of CentOS Base repositories (the repositories available by default on CentOS).
On the other hand, speex-devel is available in rpmforge repository.
milosb
 
Posts: 661
Joined: 2009/01/18 00:39:15
Location: 44 49′14″N 20 27′44″E

Re: How install a lot of program

Postby pschaff » 2010/02/09 21:42:44

Both speex and speex-devel are in both [base] and [rpmforge]:
Code: Select all
[root@poq1 ~]# yum --disablerepo \* --enablerepo rpmforge info speex speex-devel
Loaded plugins: downloadonly, fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * rpmforge: fr2.rpmfind.net
Excluding Packages from Red Hat Enterprise 5 - RPMforge.net - dag
Finished
Installed Packages
Name       : speex
Arch       : x86_64
Version    : 1.0.5
Release    : 4.el5_1.1
Size       : 302 k
Repo       : installed
Summary    : A voice compression format (codec)
URL        : http://www.speex.org/
License    : BSD
Description: Speex is a patent-free compression format designed especially for
           : speech. It is specialized for voice communications at low bit-rates
           : in the 2-45 kbps range. Possible applications include Voice over IP
           : (VoIP), Internet audio streaming, audio books, and archiving of
           : speech data (e.g. voice mail).

Available Packages
Name       : speex-devel
Arch       : x86_64
Version    : 1.0.5
Release    : 1.el5.rf
Size       : 71 k
Repo       : rpmforge
Summary    : Speex development files
URL        : http://www.speex.org/
License    : BSD
Description: Speex development files.

[root@poq1 ~]# yum --disablerepo \* --enablerepo base info speex speex-devel
Loaded plugins: downloadonly, fastestmirror, priorities
Loading mirror speeds from cached hostfile
Installed Packages
Name       : speex
Arch       : x86_64
Version    : 1.0.5
Release    : 4.el5_1.1
Size       : 302 k
Repo       : installed
Summary    : A voice compression format (codec)
URL        : http://www.speex.org/
License    : BSD
Description: Speex is a patent-free compression format designed especially for
           : speech. It is specialized for voice communications at low bit-rates
           : in the 2-45 kbps range. Possible applications include Voice over IP
           : (VoIP), Internet audio streaming, audio books, and archiving of
           : speech data (e.g. voice mail).

Available Packages
Name       : speex
Arch       : i386
Version    : 1.0.5
Release    : 4.el5_1.1
Size       : 206 k
Repo       : base
Summary    : A voice compression format (codec)
URL        : http://www.speex.org/
License    : BSD
Description: Speex is a patent-free compression format designed especially for
           : speech. It is specialized for voice communications at low bit-rates
           : in the 2-45 kbps range. Possible applications include Voice over IP
           : (VoIP), Internet audio streaming, audio books, and archiving of
           : speech data (e.g. voice mail).

Name       : speex-devel
Arch       : i386
Version    : 1.0.5
Release    : 4.el5_1.1
Size       : 65 k
Repo       : base
Summary    : Development package for speex
URL        : http://www.speex.org/
License    : BSD
Description: Speex is a patent-free compression format designed especially for
           : speech. This package contains development files for speex

Name       : speex-devel
Arch       : x86_64
Version    : 1.0.5
Release    : 4.el5_1.1
Size       : 73 k
Repo       : base
Summary    : Development package for speex
URL        : http://www.speex.org/
License    : BSD
Description: Speex is a patent-free compression format designed especially for
           : speech. This package contains development files for speex

The RPMforge version is older - not sure why it exists.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: How install a lot of program

Postby nedonodo » 2010/02/11 11:24:16

Hi,

The sipp package in EPEL is too old so I have solved installing it from source. The same thing for VLC: I need a version >= 1.0 but in the repository there is version 0.9.9a.
Now I'm trying to install VLC from source but I get the following error


checking for buggy GNU/libc versions... found
configure: error: Buggy GNU/libc (version 2.5 - 2.7) present. VLC would crash; there is no viable
work-around for this. Check with your distribution vendor on how to update the
glibc run-time. Alternatively, build with --disable-nls --disable-mozilla and
be sure to not use LibVLC from other applications/wrappers.
nedonodo
 
Posts: 5
Joined: 2010/02/09 15:09:23

Re: How install a lot of program

Postby nedonodo » 2010/02/11 16:14:42

How can I install GNU\libc version 2.8 or newer?
Thank in advance
nedonodo
 
Posts: 5
Joined: 2010/02/09 15:09:23

Re: How install a lot of program

Postby markkuk » 2010/02/11 18:52:18

nedonodo wrote:
How can I install GNU\libc version 2.8 or newer?

Install a different Linux distribution. Nearly every package depends on glibc so you can't just replace it with a later release.
markkuk
 
Posts: 682
Joined: 2007/09/07 10:56:28
Location: Finland


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests