Yum Authentication

Issues related to software problems.
Post Reply
imbrock
Posts: 2
Joined: 2010/02/16 21:10:01
Contact:

Yum Authentication

Post by imbrock » 2010/02/16 21:26:14

I have setup a CentOS 5.4 repository for internal use. I configured apache to use authentication.

If I type https://username:userpassword@url.of.reposerver:1111/repo/CentOS/5.4/os in my firefox browser I get authenticated and view the contents. When I have tried this in the CentOS-Base.repo I get a yum error detailed below:

https://url.of.reposerver:1111/repo/CentOS/5.4/os/repodata/repomd.xml: [Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.

Here is a sample of my CentOS-Base.repo

[base]
name=CentOS-$releasever - Base
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
baseurl=https://username:userpassword@url.of.reposerver:1111/repo/CentOS/5.4/os
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5

#released updates
[updates]
name=CentOS-$releasever - Updates
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
baseurl=https://username:userpassword@url.of.reposerver:1111/repo/CentOS/5.4/updates
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5

I feel like I may be over-looking something rather simple here...

Also, here is a sample of the authorization from httpd.conf :

#Repository Authentication

AuthType Basic
AuthName "Password Required"
AuthUserFile /etc/httpd/passwords/repo
Require valid-user


Thank you in advance for any assistance!

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Yum Authentication

Post by pschaff » 2010/02/16 21:57:50

Looks like a very old but still active bug. Second hit from a google on[code]yum "HTTP Error 401: Authorization Required"[/code]
https://bugzilla.redhat.com/show_bug.cgi?id=143691

imbrock
Posts: 2
Joined: 2010/02/16 21:10:01
Contact:

Re: Yum Authentication

Post by imbrock » 2010/02/16 22:21:31

Bummer. I did come across that bug report but overlooked it based on how old it was. I appreciate your assistance.

Post Reply