Unable to download required packages with yum install

Issues related to software problems.

Unable to download required packages with yum install

Postby mixxalot » 2010/07/24 04:10:44

Hi all,

I am looking for the following missing packages for CentOS 5.5 (64 bit OS) which are required to install Oracle 11g and Oracle 12.1.1 EBS:

When I run yum install for these packages, the yum command cannot find these versions for CentOS 5.5.

openmotif21-2.1.30-11.EL5.i3861
xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386


binutils-2.17.50.0.6-9.0.1.x86_642
* gcc-4.1.2-14.el5.x86_64
* gcc-c++-4.1.2-14.el5.x86_64
* glibc-2.5-18.i686 (32-bit)
* glibc-2.5-18.x86_64
* glibc-common-2.5-18.x86_64
* glibc-devel-2.5-18.i386 (32-bit)
* glibc-devel-2.5-18.x86_64
* libgcc-4.1.2-14.el5.i386
* libgcc-4.1.2-14.el5.x86_64
* libstdc++-devel-4.1.2-14.el5.i386
* libstdc++-devel-4.1.2-14.el5.x86_64
* libstdc++-4.1.2-14.el5.i386
* libstdc++-4.1.2-14.el5.x86_64
* make-3.81-1.1.x86_64
* gdbm-1.8.0-26.2.1.i386
* gdbm-1.8.0-26.2.1.x86_64
* libXp-1.0.0-8.1.el5.i386
* libXp-1.0.0-8.1.el5.x86_64
* libaio-0.3.106-3.2.i386
* libaio-0.3.106-3.2.x86_64
* libgomp-4.1.2-14.el5.x86_64
* sysstat-7.0.0-3.el5.x86_64
* util-linux-2.13-0.45.el5.x86_64
* compat-libstdc++-296-2.96-138.i386
* compat-libstdc++-33-3.2.3-61.i386

Additionally, the following RPMs are required for an 11gR1 Database (which is bundled with the 12.1.1 release) on the database tier:

* compat-libstdc++-33-3.2.3-61.x86_64
* elfutils-libelf-devel-0.125-3.el5.x86_64
* elfutils-libelf-devel-static-0.125-3.el5.x86_64
* libaio-devel-0.3.106-3.2.x86_64
* unixODBC-2.2.11-7.1.i386
* unixODBC-devel-2.2.11-7.1.i386
* unixODBC-2.2.11-7.1.x86_64
* unixODBC-devel-2.2.11-7.1.x86_64
* kernel-headers-2.6.18-8.el5.x86_64

Any ideas where I can download these for CentOS 5.5? Would I use the same rpms for Red Hat Linux or Oracle Enterprise Linux 5.5?

Thanks
Ben
mixxalot
 
Posts: 1
Joined: 2010/07/24 04:04:03

Unable to download required packages with yum install

Postby pschaff » 2010/07/28 18:40:29

Welcome to the CentOS fora. The following reading is recommended for new users:
Readme First
Installing Software
Where to Find Answers
How to provide information about your system

Your list contains a mix of current 5.5 packages in the repos, obsolete versions (such as the rather ridiculously old kernel-headers-2.6.18-8.el5.x86_64 - current is kernel-headers-2.6.18-194.8.1.el5.x86_64) and packages that are not in any of the usual repos.

About all I can suggest is that:
1. CentOS 5.5 strives to be 100% binary compatible with RHEL 5 update 5. Can't speak with any authority about Oracle Enterprise Linux 5.5 but it should be similar.
2. Install the current versions of packages from the standard CentOS repos.
3. If Oracle requires other packages not in standard repos then they should be providing them,
4. Google knows a lot about how to install oracle 11g on centos-5.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests