Problems installing phpize

Issues related to software problems.

Problems installing phpize

Postby keops17 » 2011/01/09 03:32:05

Code: Select all
 
[root@host yum]# phpize
-bash: phpize: command not found

[root@host yum]# yum install php-devel
Loaded plugins: fastestmirror
Repository utterramblings is listed more than once in the configuration
Loading mirror speeds from cached hostfile
 * addons: centos.fastbull.org
 * base: centos.fastbull.org
 * extras: centos.fastbull.org
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: centos.fastbull.org
Setting up Install Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package php-devel.i386 0:5.2.16-jason.1 set to be updated
--> Processing Dependency: php = 5.2.16-jason.1 for package: php-devel
--> Finished Dependency Resolution
php-devel-5.2.16-jason.1.i386 from utterramblings has depsolving problems
  --> Missing Dependency: php = 5.2.16-jason.1 is needed by package php-devel-5.2.16-jason.1.i386 (utterramblings)
Error: Missing Dependency: php = 5.2.16-jason.1 is needed by package php-devel-5.2.16-jason.1.i386 (utterramblings)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.



The dependencies issue makes sense since I'm running PHP Version 5.3.5 but I'm not sure how to work around this problem. Could use a pointer, or a point in the right direction. Appreciate any help me :-o
keops17
 
Posts: 2
Joined: 2011/01/09 03:26:55

Problems installing phpize

Postby AlanBartlett » 2011/01/09 15:43:43

Welcome to the CentOS fora.

The recommended reading for all new members starts with the FAQ & Readme First.

With regard to the problem you are experiencing, there are a number of things to be corrected.

The first is this --

Repository utterramblings is listed more than once in the configuration

The second is the failing to have the yum-priorities plugin installed and configured.

The third is this --

There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.

Resolve the above and then, if still having problems, execute ./getinfo.sh package & make the output produced available for viewing -- as detailed in How To Provide Information About Your System.
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: Problems installing phpize

Postby keops17 » 2011/01/10 22:40:06

Code: Select all
 
# yum install php-devel
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * addons: centos.fastbull.org
 * base: mi.mirror.garr.it
 * epel: mirror.yandex.ru
 * extras: centos.fastbull.org
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: centos.fastbull.org
317 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package php-devel.i386 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php = 5.1.6-27.el5_5.3 for package: php-devel
--> Running transaction check
---> Package php.i386 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php
--> Processing Dependency: php-cli = 5.1.6-27.el5_5.3 for package: php
--> Finished Dependency Resolution
php-5.1.6-27.el5_5.3.i386 from updates has depsolving problems
  --> Missing Dependency: php-cli = 5.1.6-27.el5_5.3 is needed by package php-5.1.6-27.el5_5.3.i386 (updates)
php-5.1.6-27.el5_5.3.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-5.1.6-27.el5_5.3.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-5.1.6-27.el5_5.3.i386 (updates)
Error: Missing Dependency: php-cli = 5.1.6-27.el5_5.3 is needed by package php-5.1.6-27.el5_5.3.i386 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


I did say, but the problem continues

I'm sorry I had to do what
:-(
keops17
 
Posts: 2
Joined: 2011/01/09 03:26:55

Re: Problems installing phpize

Postby AlanBartlett » 2011/01/10 23:17:19

The next steps of the recovery are mentioned in the output, shown above.


There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.


If you do not already have the yum-utils package already installed, install it --

Code: Select all
[b]yum --disablerepo \* --enablerepo base,updates install yum-utils[/b]

Now execute yum-complete-transaction.
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: No registered users and 2 guests