Install software under Gnome

Issues related to software problems.

Install software under Gnome

Postby cccc » 2011/01/24 03:07:46

hi

Howto install software, for example cfdisk under Gnome on CentOS 5.5?
cccc
 
Posts: 99
Joined: 2008/11/22 19:24:37

Re: Install software under Gnome

Postby scottro » 2011/01/24 03:25:30

Just use yum.

You might want to check out some of the links in my signature, they're often helpful in aiding folks to find information.

I don't run Gnome, so I'm not absolutely certain, but there may be an Add Remove Software menu, either under applications or possibly Administration.

You can also open a terminal (Applications, System Tools, Terminal) and type in

yum install yumex

(using either sudo, if you have it set up, or else doing an su to root first).

Then, you can use yumex as your graphical package manager.


EDIT

By the way, I believe cfdisk is only available from rpmforge. You can check out using that---there's an article on the wiki at wiki.centos.org under the howto section.
scottro
Forum Moderator
 
Posts: 1715
Joined: 2007/09/03 21:18:09
Location: NYC

Re: Install software under Gnome

Postby cccc » 2011/01/24 12:25:18

Thx a lot, but cannot find using Add/Remove Software or yum:

Code: Select all
# cfdisk
bash: cfdisk: command not found

# yum install cfdisk
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.switch.ch
 * base: mirror.switch.ch
 * extras: mirror.switch.ch
 * updates: mirror.switch.ch
Setting up Install Process
No package cfdisk available.
Nothing to do
cccc
 
Posts: 99
Joined: 2008/11/22 19:24:37

Install software under Gnome

Postby pschaff » 2011/01/24 16:14:10

You do not seem to have configured the RPMforge repo. If you need more help please review the recommended reading, particularly How to provide information about your system, and provide the output file from ./getinfo.sh package .
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Install software under Gnome

Postby cccc » 2011/01/28 11:27:50

pschaff wrote:
You do not seem to have configured the RPMforge repo. If you need more help please review the recommended reading, particularly How to provide information about your system, and provide the output file from ./getinfo.sh package .


Thx, I've installed RPMForge according to:

http://wiki.centos.org/AdditionalResour ... s/RPMForge

but get this problem:
Code: Select all
# rpm -i rpmforge-release-0.5.2-2.el6.rf.*.rpm
error: Failed dependencies:
        rpmlib(FileDigests) <= 4.6.0-1 is needed by rpmforge-release-0.5.2-2.el6.rf.i686
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpmforge-release-0.5.2-2.el6.rf.i686
cccc
 
Posts: 99
Joined: 2008/11/22 19:24:37

Re: Install software under Gnome

Postby cccc » 2011/01/28 11:40:24

I've installed rpmforge-release-0.3.6-1.el5.rf.i386.rpm from:

http://rpmforge.sw.be/redhat/el5/en/i38 ... f.i386.rpm

then I have done:
Code: Select all
# yum install yum-priorities

and hope is OK.
cccc
 
Posts: 99
Joined: 2008/11/22 19:24:37

Re: Install software under Gnome

Postby jlehtone » 2011/01/28 14:07:37

Note that none of the repositories (AFAIK) does define priorities by default.
Therefore, you should edit the /etc/yum.repos.d/*.conf as desired.
User avatar
jlehtone
 
Posts: 1431
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Install software under Gnome

Postby cccc » 2011/01/28 14:18:35

jlehtone wrote:
Note that none of the repositories (AFAIK) does define priorities by default.
Therefore, you should edit the /etc/yum.repos.d/*.conf as desired.


Thx, but can you pls give some more details?
I'm new on CentOS.
Is already installed rpmforge-release-0.3.6-1.el5.rf.i386.rpm wrong and should be removed?
cccc
 
Posts: 99
Joined: 2008/11/22 19:24:37

Re: Install software under Gnome

Postby cccc » 2011/01/28 15:39:45

I've removed rpmforge-release-0.3.6-1.el5.rf.i386.rpm and installed rpmforge-release-0.5.2-2.el5.rf.i386.rpm.
Now i have using getinfo.sh package:
Information for package problems.
Code: Select all
== BEGIN uname -rmi ==
2.6.18-194.32.1.el5 i686 i386
== END   uname -rmi ==

== BEGIN rpm -qa \*-release\* ==
centos-release-5-5.el5.centos
rpmforge-release-0.5.2-2.el5.rf
centos-release-notes-5.5-0
== END   rpm -qa \*-release\* ==

== BEGIN cat /etc/redhat-release ==
CentOS release 5.5 (Final)
== END   cat /etc/redhat-release ==

== BEGIN getenforce ==
Enforcing
== END   getenforce ==

== BEGIN rpm -q yum rpm python ==
yum-3.2.22-26.el5.centos
rpm-4.4.2.3-20.el5_5.1
python-2.4.3-27.el5_5.3
== END   rpm -q yum rpm python ==

== BEGIN ls /etc/yum.repos.d ==
CentOS-Base (copy).repo
CentOS-Base.repo
CentOS-Base.repo~
CentOS-Media.repo
mirrors-rpmforge
mirrors-rpmforge-extras
mirrors-rpmforge-testing
rpmforge.repo
== END   ls /etc/yum.repos.d ==

== BEGIN cat /etc/yum.conf ==
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1

# Note: yum-RHN-plugin doesn't honor this.
metadata_expire=1h

# Default.
# installonly_limit = 3

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
== END   cat /etc/yum.conf ==

== BEGIN yum repolist all ==
Loaded plugins: fastestmirror, priorities
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository addons is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration
Loading mirror speeds from cached hostfile
 * addons: mirror.switch.ch
 * base: mirror.switch.ch
 * extras: centos.de-mirror-server.de
 * rpmforge: fr2.rpmfind.net
 * updates: mirror.switch.ch
repo id                  repo name                               status
addons                   CentOS-5 - Addons                       enabled:      0
base                     CentOS-5 - Base                         enabled:  2,599
c5-media                 CentOS-5 - Media                        disabled
centosplus               CentOS-5 - Plus                         disabled
contrib                  CentOS-5 - Contrib                      disabled
extras                   CentOS-5 - Extras                       enabled:    326
rpmforge                 RHEL 5 - RPMforge.net - dag             enabled: 10,369
rpmforge-extras          RHEL 5 - RPMforge.net - extras          disabled
rpmforge-testing         RHEL 5 - RPMforge.net - testing         disabled
updates                  CentOS-5 - Updates                      enabled:    872
repolist: 14,166
== END   yum repolist all ==

== BEGIN egrep 'include|exclude' /etc/yum.repos.d/*.repo ==
== END   egrep 'include|exclude' /etc/yum.repos.d/*.repo ==

== BEGIN sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n ==
== END   sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n ==

== BEGIN rpm -qa kernel\* | sort ==
kernel-2.6.18-194.32.1.el5
kernel-2.6.18-194.el5
== END   rpm -qa kernel\* | sort ==
cccc
 
Posts: 99
Joined: 2008/11/22 19:24:37

Re: Install software under Gnome

Postby pschaff » 2011/01/28 16:40:16

You still have no priorities defined. In each repo definition section in /yum.repos.d/*.repo (such as [base] [updates] [extras] ...) you need to insert a line "priority=N" where 1 <= N <= 99. No such line is the same as "priority=99" the lowest. Highest priority number is the lowest priority, the lowest number is "best" as in golf scores.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Next

Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: No registered users and 1 guest