[SOLVED] matlab launch error in Centos 5.5

Issues related to software problems.

[SOLVED] matlab launch error in Centos 5.5

Postby mattmer » 2011/05/23 17:37:37

Hi,

I am running Centos 5.5. I am ssh'ing from my windows 7 machine (client) into my (server) linux box, with the hopes of running Matlab from the linux box in interactive mode.

When I try to launch matlab, I get:

unable to open display 'localhost:10.0' You will not be able to display graphics on the screen.

When I set my DISPLAY variable in bash, the message now reads:

unable to open display 'client ip address' You will not be able to display graphics on the screen.

I have installed the xorg-x11-xauth package.

A "grep X11 /etc/ssh/sshd_config" gives

#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes

I am using putty as my ssh. I have an x-server package up an running on the client.

What problem am I running into here?

Thanks

PS Fixed. ipconfig on my windows machine shows that my address had been changed by DHCP. Therefore when I was trying to open the remote display I was using the wrong address.
mattmer
 
Posts: 4
Joined: 2011/05/18 13:54:43

[SOLVED] matlab launch error in Centos 5.5

Postby pschaff » 2011/05/23 21:18:07

Welcome to the CentOS fora. Reading FAQ & Readme First is recommended for new users.

Thanks for reporting back with your self-solution. Marking this thread [SOLVED] for posterity.

You may be interested in the Wiki article TipsAndTricks/EmulateFixedAddressByDHCP.
pschaff
Retired Moderator
 
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: No registered users and 5 guests