Installing pycall on python 2.4 errors

Issues related to software problems.

Installing pycall on python 2.4 errors

Postby shyamal » 2011/09/29 10:21:14

Hi,

I have CentOS 5.7 with python 2.4 installed.
I am trying to install pycall 2.0 using pip but first, it gives error that some ".call" not found syntax error.
I tried using "python setup.py install " ended up with same errors.
From googling, i found that pycall 2.0 may not work with python 2.4

So, i want to install python 2.6 (as parallel version with 2.4 - suggested on internet).
Since i am almost a beginner on Linux/Unix, I have no idea how to install this way and finish task of installing pycall2.0

Please Help!
shyamal
 
Posts: 3
Joined: 2011/09/29 09:58:48

Re: Installing pycall on python 2.4 errors

Postby TrevorH » 2011/09/29 11:14:10

If you enable the EPEL repository (and install and configure yum-protectbase and/oryum-priorities) then you can use `yum install python26`
User avatar
TrevorH
Forum Moderator
 
Posts: 9164
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installing pycall on python 2.4 errors

Postby shyamal » 2011/09/29 14:08:42

Thank you,
I am trying to install/enable EPEL from http://www.cyberciti.biz/faq/rhel-fedora-centos-linux-enable-epel-repo/.
It gives critical error

Retrieving http://download.fedora.redhat.com/pub/e ... noarch.rpm
error: skipping http://download.fedora.redhat.com/pub/e ... noarch.rpm - transfer failed - Unknown or unexpected error
warning: u 0x840f158 ctrl 0x840ff70 nrefs != 0 (download.fedora.redhat.com http)


Should I go and find any other EPEL?
please suggest!
shyamal
 
Posts: 3
Joined: 2011/09/29 09:58:48

Re: Installing pycall on python 2.4 errors

Postby TrevorH » 2011/09/29 21:30:13

That's what comes of following old instructions. The file has been update and is now http://download.fedora.redhat.com/pub/e ... noarch.rpm

Once you have python26 installed I believe you will need to invoke python2.6 or python26 instead of python to do your build
User avatar
TrevorH
Forum Moderator
 
Posts: 9164
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Installing pycall on python 2.4 errors

Postby pschaff » 2011/10/01 11:37:20

The OP apparently gave up on pycall 2.0 and started a new thread on pycall 1.4. To avoid fragmenting the discussion, and to hopefully provide a clean path to a solution for pycall on CentOS, that thread has been locked and the discussion on installing pycall should proceed here.

shyamal wrote:
I am trying to install pycall 1.4 using pip but first, it gives error that some ".call" not found syntax error.
I tried using "python setup.py install " ended up with same errors.

Running setup.py install for pycall
warning: no previously-included files matching '*.pyc' found under directory 'docs'
warning: no previously-included files matching '*.pyc' found under directory 'tests'
no previously-included directories found matching 'docs/_build'
File "/usr/lib/python2.4/site-packages/pycall/callfile.py", line 12
from .call import Call
^
SyntaxError: invalid syntax
File "/usr/lib/python2.4/site-packages/pycall/__init__.py", line 4
from .call import *
^
SyntaxError: invalid syntax
Found existing installation: path.py 2.2.2
Uninstalling path.py:
Successfully uninstalled path.py
Running setup.py install for path.py
Successfully installed pycall path.py

please help to locate the problem. nowhere I can find anyone having such issues installing pycall.
I am a newbie and can not even locate if i am missing something.

I am ready to provide remote SSH for remote access!

Thanks
Shyamal Pandya
shyamalpan@gmail.com
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: No registered users and 6 guests