vnc server will not accept connections intermittently

Issues related to software problems.

vnc server will not accept connections intermittently

Postby krausese » 2012/02/07 19:19:15

The vnc client on Windows fails to connect to the vnc server running on CentOS. I need help troubleshooting on the CentOS side please.

I have been using vnc to connect to this CentOS machine for a few years. I never had a problem until last week. Now sometimes I can connect, but most of the time I cannot.

From the Windows machine, I tested using both Ultra VNC and Real VNC. Both fail to connect.

This may be coincidental, but last week I ran yum update. yum updated several packages, and I then rebooted. I noticed that the issue started to happen shortly after this.

$ cat /etc/redhat-release
CentOS release 5.7 (Final)
$ uname -a
Linux t00539292.energy.ge.com 2.6.18-274.17.1.el5 #1 SMP Tue Jan 10 17:25:58 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

The firewall is enabled. Port 5900 is open.

If I attempt to connect from another server using telnet, I see that port 5900 is open, and the vnc server responds.
bash-3.00$ telnet 3.96.192.86 5900
Trying 3.96.192.86...
Connected to 3.96.192.86.
Escape character is '^]'.
RFB 003.007

I am the only CentOS system administrator, so I know that nobody else is making any changes.

How do I troubleshoot this?
krausese
 
Posts: 1
Joined: 2012/02/03 17:31:43

vnc server will not accept connections intermittently

Postby pschaff » 2012/02/10 16:39:14

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

You don't say exactly what happens on the windows side when the connection fails. Have you tried a Linux or browser Java client? Perhaps stating the obvious, but have you checked the logs (/var/log/messages, /var/log/secure, VNC logs) for errors at the time of the connection attempts?
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - Software Support

Who is online

Users browsing this forum: Baidu [Spider] and 4 guests