CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Issues related to hardware problems

CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby xp190 » 2009/03/03 15:35:59

Hi Guys

I'm having a bit of a hard time trying to get CentOS 5.2 to install on a Dell Power Edge 2950 III with the Perc 6/i SAS Raid controller.

After doing some reaserch, I found that others are having a similar issue, however, I'm not able to find a work around for it.

During the installation, the little info box that comes up saying "Loading Megaraid driver" quickly flashes on the screen and leavs behind some
scribbled characters on the screen, then when you get to the drive selection, no drivers for installation are available

The Raid is setup correctly, I have about 10 of these systems, it is configured for RAID 1, with 3 drives, 1 a hot spare.

Dell provides some drivers for the controller however, they do not work with CentOS, using expert mode to perform an install, when I attempt
to load the driver form a floppy, the installer comes back saying that the driver is invalid for this release.

There is no specific CentOS megaraid_sas driver that I could find anywhere, so I was forced to try the Redhat ones.

Going with software raid yields the same results, simply no drive is available to install to.

I'm wondering if someone could guide me in the rigth direction to address this problem, I've seen some people had success with a network install which used the kernel image from another system, I don't have that option, I would like to find a megaraid_sas driver floppy image for CentOS 5.2 which will
work with the Perc6/i controller.

If anyone can provide any assistance, I'd be very grateful.

xp190
xp190
 
Posts: 3
Joined: 2009/03/03 15:22:28

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby pjwelsh » 2009/03/03 21:12:20

I have the 2950's III w/ PERC 6/i. I have recently installed 5.2 on a couple of them without issue. I made it a point to fully initialize the RAID LUNs created prior to doing the OS install. Are you creating REALLLLLYYYY large LUNS? Can you provide any of the dmesg output from one of the ALT-F? screens?

Edit: Can't be that large of LUNs with only RAID 1.
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby xp190 » 2009/03/04 14:22:34

Hi Pj

The Raid was fully initialized, I made sure of that, the size of the RAID is 142GB, I don't think that should be an issue. As for output, it might be a while since that server is now packed up and it's getting swapped for a different one, same model and specs, there was an issue with the branding, so the problem will still be there.

Anything else I can provide to figure out how to solve this?

I know CetOS 5.2 comes with the megaraid driver, and even if I do lspci, the raid shows up, but the installer does not see the drive to install to.
I suspect it has something to do with the megaraid driver failing to load and leaving a bunch of scribbles on the screen, but I'm not sure how to verify it.

xp190
xp190
 
Posts: 3
Joined: 2009/03/03 15:22:28

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby tlevitt » 2009/03/10 22:05:13

I am also experiencing the same issue using the standard CentOS 5.2 installation kernel. Here is the dmesg output which clearly displays the megasas driver breaking:

Code: Select all
<6>megasas: 00.00.03.15-RH1 Wed Nov. 21 10:29:45 PST 2007
<6>megasas: 0x1000:0x0060:0x1028:0x1f0c: bus 1:slot 0:func 0
<6>ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 169
<7>PCI: Setting latency timer of device 0000:01:00.0 to 64
<6>megasas: FW now in Ready state
<6>scsi2 : LSI SAS based MegaRAID driver
<5>  Vendor: SEAGATE   Model: ST3300656SS       Rev: HS0A
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>  Vendor: SEAGATE   Model: ST3300656SS       Rev: HS0A
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>  Vendor: SEAGATE   Model: ST3300656SS       Rev: HS0A
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>  Vendor: SEAGATE   Model: ST3300656SS       Rev: HS0A
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>  Vendor: DP        Model: BACKPLANE         Rev: 1.05
<5>  Type:   Enclosure                          ANSI SCSI revision: 05
<5>  Vendor: DELL      Model: PERC 6/i          Rev: 1.21
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>SCSI device sda: 1754529792 512-byte hdwr sectors (898319 MB)
<5>sda: Write Protect is off
<7>sda: Mode Sense: 1f 00 10 08
<5>SCSI device sda: drive cache: write through w/ FUA
<5>SCSI device sda: 1754529792 512-byte hdwr sectors (898319 MB)
<5>sda: Write Protect is off
<7>sda: Mode Sense: 1f 00 10 08
<5>SCSI device sda: drive cache: write through w/ FUA
<6> sda: sda1 sda2
<5>sd 2:2:0:0: Attached scsi disk sda
<3>irq 169: nobody cared (try booting with the "irqpoll" option)
<4> [<c044e56e>] __report_bad_irq+0x2b/0x69
<4> [<c044e75b>] note_interrupt+0x1af/0x1e8
<4> [<f89512cf>] megasas_isr+0xf/0x43 [megaraid_sas]
<4> [<c044dd9b>] handle_IRQ_event+0x23/0x49
<4> [<c044de5c>] __do_IRQ+0x9b/0xd6
<4> [<c04073f4>] do_IRQ+0x93/0xae
<4> [<c040592e>] common_interrupt+0x1a/0x20
<4> [<c051007b>] acpi_ex_opcode_2A_1T_1R+0x245/0x345
<4> [<c0403ccf>] mwait_idle+0x25/0x38
<4> [<c0521d84>] acpi_processor_idle+0x154/0x3b4
<4> [<c041007b>] query_current_values_with_pending_wait+0xb/0x63
<4> [<c0403c90>] cpu_idle+0x9f/0xb9
<4> =======================
<3>handlers:
<3>[<f89512c0>] (megasas_isr+0x0/0x43 [megaraid_sas])
<0>Disabling IRQ #169


Any ideas?
tlevitt
 
Posts: 5
Joined: 2009/03/10 21:48:47

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby pjwelsh » 2009/03/11 03:19:44

Wow, not sure what's up with that. I had a flawless install and setup with mine on 64bit. No kernel params, no bootup nonsense, it just worked (see more request for info after this junk):

megasas: 00.00.03.15-RH1 Wed Nov. 21 10:29:45 PST 2007
megasas: 0x1000:0x0060:0x1028:0x1f0c: bus 1:slot 0:func 0
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:01:00.0 to 64
megasas: FW now in Ready state
scsi0 : LSI SAS based MegaRAID driver
Vendor: SEAGATE Model: ST3146855SS Rev: S528
Type: Direct-Access ANSI SCSI revision: 05
Vendor: SEAGATE Model: ST3146855SS Rev: S528
Type: Direct-Access ANSI SCSI revision: 05
Vendor: SEAGATE Model: ST3146855SS Rev: S528
Type: Direct-Access ANSI SCSI revision: 05
Vendor: SEAGATE Model: ST3146855SS Rev: S528
Type: Direct-Access ANSI SCSI revision: 05
Vendor: SEAGATE Model: ST3146855SS Rev: S528
Type: Direct-Access ANSI SCSI revision: 05
Vendor: SEAGATE Model: ST3146855SS Rev: S528
Type: Direct-Access ANSI SCSI revision: 05
Vendor: DP Model: BACKPLANE Rev: 1.05
Type: Enclosure ANSI SCSI revision: 05
Vendor: DELL Model: PERC 6/i Rev: 1.21
Type: Direct-Access ANSI SCSI revision: 05
SCSI device sda: 856424448 512-byte hdwr sectors (438489 MB)
sda: Write Protect is off
sda: Mode Sense: 1f 00 10 08
SCSI device sda: drive cache: write through w/ FUA
SCSI device sda: 856424448 512-byte hdwr sectors (438489 MB)
...


So, are you running 64bit and your 32bit? Are you fully updated on PERC BIOS and system BIOS?
My system BIOS is 2.5.0 and the PERC 6/i is 6.1.1-0047
I have google'd and seen people mention either the "noirqdebug" or "irqpoll" kernel options... YMMV.
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby tlevitt » 2009/03/11 04:47:04

This was a 32bit install. bios version 1.5.0, raid firmware version 1.21.02-0528. Booting with the kernel parameter "irqpoll" was unsuccessful in resolving the issue!
tlevitt
 
Posts: 5
Joined: 2009/03/10 21:48:47

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby pjwelsh » 2009/03/11 13:06:41

Your BIOS is WAYYYY behind with a couple of critical fixes. My PERC 6/i firmware number is coming from the "update_firmware" utility provided by Dell for Linux. They have LOTS of useful pieces for system admin stuff like BIOS and frimware update utils, system monitoring and driver enhancements etc.
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby tlevitt » 2009/03/13 16:57:06

pjwelsh wrote:
Your BIOS is WAYYYY behind with a couple of critical fixes.


Oops! I meant to write 2.5.0 in my last post. Just to clarify, the BIOS version I am running is 2.5.0, PERC5 firmware version 1.21.02-0528.
tlevitt
 
Posts: 5
Joined: 2009/03/10 21:48:47

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby pjwelsh » 2009/03/13 19:16:45

Are you willing/able to try 64bit? Our setups look very similar. I have never put 32bit on this version box, however.
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: CentOS 5.2 Dell PE2950 III and Perc 6/i SAS Raid controller

Postby tlevitt » 2009/03/13 21:11:01

The 64bit installation also fails!

Additionally, another odd twist to this issue is that this error is not present while doing a CD based installation. We are experiencing this error only when booting from the stock kernel/initrd via PXE for use with a standard kickstart. The kernel/intird files we are using are located at http://mirror.centos.org/centos/5/os/i3 ... s/pxeboot/ . Perhaps these files are out of sync with the kernel/initrd image found on the cd-iso media?
tlevitt
 
Posts: 5
Joined: 2009/03/10 21:48:47

Next

Return to CentOS 5 - Hardware Support

Who is online

Users browsing this forum: willywep and 3 guests