Centos 5 Gigabit ethernet advise needed

Issues related to hardware problems

Centos 5 Gigabit ethernet advise needed

Postby ikhan42 » 2009/07/07 11:37:53

Hi everyone,

I am setting up a NAS server for a friend of mine and am using Centos 5 for the OS. The motherboard is a ASUS p5q pro motherboard that has an attansic L1 NIC that doesnt seem to work under Centos 5. I have installed an old INTEL 82557 10/100 card in the machine that works fine however my friend want Gigabit Ethernet speed. I am looking to see what cards work on this machine he doesnt want to spend too much more money as he has already spent $2000 on a 8 Hotswap RAID 5, Intel Dual core server with Adaptec SAS/SATA raid controller card in it and has blown his budget.

Can anyone advise what generic NIC's work on Centos 5 ie DLINK, NETGEAR, RealTek, Broadcom SMC. Or is there a HCL of what is supported on Centos 5 as far as NICS are concerned.

Any help would be greatly appreciated

Thanks
ikhan42
ikhan42
 
Posts: 23
Joined: 2009/01/01 10:10:16

Re: Centos 5 Gigabit ethernet advise needed

Postby AlanBartlett » 2009/07/07 12:09:16

The motherboard is a ASUS p5q pro motherboard that has an attansic L1 NIC that doesnt seem to work under Centos 5.

Please check the Vendor:Device ID pairing returned by the following command --

Code: Select all
[b]/sbin/lspci -n | grep "$(/sbin/lspci | awk '/net/ { print $1 }')"[/b]

-- with those listed on the Device IDs page at [url=//elrepo.org]ELRepo[/url].

You may find that the kABI tracking kmod-atl1 package will be appropriate for your NIC.
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: Centos 5 Gigabit ethernet advise needed

Postby ikhan42 » 2009/07/07 22:11:56

Allanjbartlett,

Thanks for the reply the following was the output from the command
05:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
I have looked at the link at ElRepo but the number returned is totally different to what Elrepo has listed. The format on Elrepo is 0000:0000 does this output make any sense to you ?

Thanks again for your help
ikhan42
ikhan42
 
Posts: 23
Joined: 2009/01/01 10:10:16

Re: Centos 5 Gigabit ethernet advise needed

Postby toracat » 2009/07/07 22:32:44

Let me make a guess ... you missed the -n option ! :-o
User avatar
toracat
Forum Moderator
 
Posts: 6695
Joined: 2006/09/03 16:37:24
Location: California, US

Re: Centos 5 Gigabit ethernet advise needed

Postby ikhan42 » 2009/07/07 22:38:24

Allanjbartlett,

I got a driver after all there was a bunch to pick from and I tried each one and abracadabra it worked.

Thanks Again for all your help.

ikhan42
ikhan42
 
Posts: 23
Joined: 2009/01/01 10:10:16

Re: Centos 5 Gigabit ethernet advise needed

Postby AlanBartlett » 2009/07/08 08:01:48

I got a driver after all there was a bunch to pick from and I tried each one and abracadabra it worked.

There are five in total -- three for the 32-bit architecture and two for the 64-bit architecture. The correct version is the one that matches the system's architecture (32- or 64-bit) and kernel type (standard, xen and -- if 32-bit -- PAE). To decide upon the correct package to install, you would look at the output of an uname -rmi command. ;-)

Thanks Again for all your help.

You're welcome. :-)
User avatar
AlanBartlett
Forum Moderator
 
Posts: 8975
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk


Return to CentOS 5 - Hardware Support

Who is online

Users browsing this forum: willywep and 1 guest