"SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Issues related to hardware problems
Post Reply
PeiChen
Posts: 18
Joined: 2010/03/07 21:18:20

"SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Post by PeiChen » 2010/11/20 17:26:20

I'm trying to get my "Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection" card working with CentOS, which is part of my HP laptop on-board motherboard. I know I have to install the firmware, and have followed the wiki instructions, but when I try to bring it up, I get this:

[code]
[root@localhost chenp]# /sbin/ifup wlan0

Determining IP information for wlan0...SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
[/code]
I can't find any other posts on here regarding this error, so I'm a little lost as to what else I need to do to fix this. Can anyone help?

Here's the results of the getinfo.sh script:

[url=http://kigurumi.co.uk/temp/centos101120.txt]CentOS Hardware Script Results[/url]

User avatar
toracat
Forum Moderator
Posts: 7289
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

"SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 39

Post by toracat » 2010/11/20 21:23:39

If you have followed the instructions in the CentOS wiki article, you probably installed the firmware from RPMForge. First, please try installing the latest firmware available from ELRepo ( [url=http://elrepo.org/tiki/iwl3945-firmware]iwl3945-firmware[/url] ). Remove the package from RPMForge ( 15.28.1.8-2.nodist.rf ) and then download and install the ELRepo package ( 15.32.2.9-1.elrepo ).

If you continue to have the same problem, we can do more troubleshooting.

PeiChen
Posts: 18
Joined: 2010/03/07 21:18:20

Re: "SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Post by PeiChen » 2010/11/20 21:46:29

Unfortunately, that didn't work, and I made sure Installed the correct one by disabling and enabling repos, then using "yum info iwl*" afterwards:

[code]
Installed Packages
Name : iwl3945-firmware
Arch : noarch
Version : 15.32.2.9
Release : 1.elrepo
Size : 447 k
Repo : installed
Summary : Firmware for Intel Wireless 3945 network adapter
URL : http://intellinuxwireless.org/
License : Redistributable, no modification permitted
Description: This package provides the firmware required for running an Intel
: Wireless 3945 adapter with the Linux kernel iwl3945 driver.
[/code]
I modprobe'd afterwards to reload the module as per the wiki article, but I still get the same error as before:

[code]
# /sbin/ifup wlan0

Determining IP information for wlan0...SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
[/code]

User avatar
AlanBartlett
Forum Moderator
Posts: 9319
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: "SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Post by AlanBartlett » 2010/11/21 01:26:42

I have reviewed your system information and can see nothing obviously wrong.

I note that you have only [i]NetworkManager[/i] enabled -- that is good, as having both the [i]network[/i] service and [i]NetworkManager[/i] enabled never works correctly. They end up fighting each other for device control.

Please try using the [b]nm-connection-editor[/b] utility to configure your system and then attempt to bring up the connection with [i]NetworkManager[/i], rather then attempting to do it manually.

User avatar
toracat
Forum Moderator
Posts: 7289
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: "SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Post by toracat » 2010/11/21 03:42:23

I apologize in advance if this question sounds nonsense to you but ... is the wireless switch physically on ?

PeiChen
Posts: 18
Joined: 2010/03/07 21:18:20

Re: "SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Post by PeiChen » 2010/11/21 08:47:44

[quote]
AlanBartlett wrote:
I have reviewed your system information and can see nothing obviously wrong.

I note that you have only [i]NetworkManager[/i] enabled -- that is good, as having both the [i]network[/i] service and [i]NetworkManager[/i] enabled never works correctly. They end up fighting each other for device control.

Please try using the [b]nm-connection-editor[/b] utility to configure your system and then attempt to bring up the connection with [i]NetworkManager[/i], rather then attempting to do it manually.[/quote]

I tried that, but there's nothing showing up in the "Wireless" tab

PeiChen
Posts: 18
Joined: 2010/03/07 21:18:20

Re: "SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Post by PeiChen » 2010/11/21 08:49:19

[quote]
toracat wrote:
I apologize in advance if this question sounds nonsense to you but ... is the wireless switch physically on ?[/quote]

Yes. ^_^;

User avatar
AlanBartlett
Forum Moderator
Posts: 9319
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: "SIOCSIFFLAGS: Unknown error 132" with Intel Pro Wireless 3945ABG

Post by AlanBartlett » 2010/11/21 19:23:25

This is a strange situation. :-?

Will you please grep dmesg or the /var/log/messages file for anything logged that is related to the WiFi device.

Post Reply