[SOLVED] Poor HDD performance -- wrong driver?

Issues related to hardware problems

[SOLVED] Poor HDD performance -- wrong driver?

Postby swdavison » 2011/08/21 19:46:04

I'm seeing poor HDD performance on a machine on which I recently loaded CentOS 5.6. I've read some other threads on similar subjects:
https://www.centos.org/modules/newbb/vi ... 7&forum=39
https://www.centos.org/modules/newbb/vi ... 1&forum=39

The /dev/hdaX versus /dev/sdaX distinction (see below) makes me think this issue is different, so I started a new thread.

I think in this case it's a driver issue. Basically I have two questions:
1. Is it a driver issue?
2. If so, how can I make CentOS use the correct driver?

I had been running Ubuntu on the machine in question. The HDD performance seemed okay. The HDD partitions had device names of /dev/sda1, /dev/sda2, etc.

When I installed CentOS 5.6 and repartitioned the drive, the CentOS installer used names like /dev/hda1, /dev/hda2, etc. for the partitions. And that's the way they showed up at run time after booting CentOS.

After installing CentOS 5.6 and seeing the HDD slowdown, I booted a Knoppix live CD for comparison. (Knoppix 6.4.4)

With CentOS, hdparm -t shows a transfer rate of about 2.4 MB/sec. With Knoppix it's about 70 MB/sec.

The machine in question is an HP Pavillion. The HDD is a Western Digital model WDC WD5000AAJS-22YFA0 ("Caviar"). I have two other machines running CentOS 5.6: another HP Pavillion with a Hitachi drive and a homebuilt with a Seagate. In both of those cases the partitions are named /dev/sdaX and the performance is okay.

System information from Knoppix and Centos running on the same hardware is in the following files:

http://nic-nac-project.de/~davison/hddp ... centos.out
http://nic-nac-project.de/~davison/hddp ... noppix.out
http://nic-nac-project.de/~davison/hddp ... centos.out
http://nic-nac-project.de/~davison/hddp ... centos.out
http://nic-nac-project.de/~davison/hddp ... noppix.out
http://nic-nac-project.de/~davison/hddp ... centos.out
http://nic-nac-project.de/~davison/hddp ... noppix.out
http://nic-nac-project.de/~davison/hddp ... centos.out
http://nic-nac-project.de/~davison/hddp ... noppix.out
http://nic-nac-project.de/~davison/hddp ... centos.out
http://nic-nac-project.de/~davison/hddp ... noppix.out

I would much appreciate any suggestions.

(I apologize for crude formatting. Thunderstorms here -- power off and on -- UPSes wailing in anguish.)

Thanks.

Stowe Davison
s.davison@computer.org
swdavison
 
Posts: 5
Joined: 2011/08/21 16:20:29

Re: Poor HDD performance -- wrong driver?

Postby swdavison » 2011/08/22 18:33:18

swdavison
 
Posts: 5
Joined: 2011/08/21 16:20:29

[SOLVED] Poor HDD performance -- wrong driver?

Postby AlanBartlett » 2011/08/22 19:33:21

Welcome to the CentOS fora.

You have obviously done all your reading! Congratulations in solving your issue and thank your from reporting back how you resolved it.

For posterity, and on your behalf, this thread is marked [SOLVED].
User avatar
AlanBartlett
Forum Moderator
 
Posts: 9191
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk


Return to CentOS 5 - Hardware Support

Who is online

Users browsing this forum: No registered users and 0 guests