[SOLVED] A4Tech camera and CentOS 5.7

Issues related to hardware problems

[SOLVED] A4Tech camera and CentOS 5.7

Postby icemans » 2012/02/22 21:05:13

I cannot use my web-camera with Skype in CentOS 5.7. I read this WIKI and tried to install GSPCA but I don't know if I install it success.

Code: Select all
$ uname -r 2.6.18-274.18.1.el5


Code: Select all
$ /sbin/lsusb
Bus 006 Device 001: ID 0000:0000
Bus 006 Device 002: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 Webcam


Thank you in advance!
icemans
 
Posts: 64
Joined: 2012/02/19 21:21:30
Location: Burgas, Bulgaria

[SOLVED] A4Tech camera and CentOS 5.7

Postby pschaff » 2012/02/22 21:53:43

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

That Vendor:DeviceID 0ac8:303b should be supported:
Code: Select all
$ grep -i 0ac8 /lib/modules/*/modules.alias | grep -i 303b
/lib/modules/2.6.18-274.17.1.el5/modules.alias:alias usb:v0AC8p303Bd*dc*dsc*dp*icFFisc*ip* zc0301
/lib/modules/2.6.18-274.18.1.el5/modules.alias:alias usb:v0AC8p303Bd*dc*dsc*dp*icFFisc*ip* zc0301
/lib/modules/2.6.18-274.el5/modules.alias:alias usb:v0AC8p303Bd*dc*dsc*dp*icFFisc*ip* zc0301


Note that the Wiki Webcams page recommends the ELRepo kmod-video4linux package.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: A4Tech camera and CentOS 5.7

Postby icemans » 2012/02/22 22:14:01

I have kmod-video4linux installed from ELRepo but the cam doesn't work?!
icemans
 
Posts: 64
Joined: 2012/02/19 21:21:30
Location: Burgas, Bulgaria

Re: A4Tech camera and CentOS 5.7

Postby pschaff » 2012/02/23 02:32:01

Please elaborate. Did you reboot after installing the kmod package? Does lsmod show the module loaded? Exactly what are the symptoms of "the cam doesn't work"? How did you test it? Any error messages? Anything relevant in dmesg or /var/log/messages?
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: A4Tech camera and CentOS 5.7

Postby icemans » 2012/02/23 08:29:27

Yes, I reboot after installing the package.
Code: Select all
# lsmod
Module                  Size  Used by
autofs4                29253  3
hidp                   22977  2
rfcomm                 42457  0
l2cap                  29761  10 hidp,rfcomm
lockd                  63209  0
sunrpc                149373  2 lockd
cpufreq_ondemand       12493  1
acpi_cpufreq           13641  1
mperf                   6337  1 acpi_cpufreq
ip_conntrack_netbios_ns     6977  0
ipt_REJECT              9537  1
xt_state                6209  2
ip_conntrack           53281  2 ip_conntrack_netbios_ns,xt_state
nfnetlink              10713  1 ip_conntrack
xt_tcpudp               7105  4
iptable_filter          7105  1
ip_tables              17029  1 iptable_filter
ip6_tables             18181  0
x_tables               17349  5 ipt_REJECT,xt_state,xt_tcpudp,ip_tables,ip6_tables
be2iscsi               59093  0
ib_iser                35609  0
rdma_cm                35705  1 ib_iser
ib_cm                  39213  1 rdma_cm
iw_cm                  13125  1 rdma_cm
ib_sa                  39093  2 rdma_cm,ib_cm
ib_mad                 37717  2 ib_cm,ib_sa
ib_core                63557  6 ib_iser,rdma_cm,ib_cm,iw_cm,ib_sa,ib_mad
ib_addr                11717  1 rdma_cm
iscsi_tcp              20041  0
bnx2i                  43229  0
cnic                   50261  1 bnx2i
ipv6                  271393  1 cnic
xfrm_nalgo             13381  1 ipv6
crypto_api             12609  1 xfrm_nalgo
uio                    14793  1 cnic
cxgb3i                 31177  0
libcxgbi               54477  1 cxgb3i
cxgb3                 167193  1 cxgb3i
8021q                  25929  1 cxgb3
libiscsi_tcp           22213  3 iscsi_tcp,cxgb3i,libcxgbi
libiscsi2              42693  7 be2iscsi,ib_iser,iscsi_tcp,bnx2i,cxgb3i,libcxgbi,libiscsi_tcp
scsi_transport_iscsi2    37709  8 be2iscsi,ib_iser,iscsi_tcp,bnx2i,libcxgbi,libiscsi2
scsi_transport_iscsi     6085  1 scsi_transport_iscsi2
fuse                   49237  6
dm_mirror              24393  0
dm_multipath           27213  0
scsi_dh                12481  1 dm_multipath
video                  21193  0
backlight              10049  1 video
sbs                    18533  0
power_meter            16461  0
hwmon                   7365  1 power_meter
i2c_ec                  9025  1 sbs
dell_wmi                8401  0
wmi                    12137  1 dell_wmi
button                 10704  0
battery                13637  0
asus_acpi              19289  0
ac                      9157  0
lp                     15849  0
sr_mod                 19941  0
cdrom                  36577  1 sr_mod
snd_hda_intel         562533  1
snd_seq_dummy           7877  0
snd_seq_oss            32577  0
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                49585  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         11725  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42817  0
snd_mixer_oss          19009  1 snd_pcm_oss
sg                     36717  0
snd_pcm                72133  2 snd_hda_intel,snd_pcm_oss
snd_timer              24517  2 snd_seq,snd_pcm
nvidia              10943024  30
snd_page_alloc         14281  2 snd_hda_intel,snd_pcm
hci_usb                20317  2
snd_hwdep              12869  1 snd_hda_intel
serio_raw              10693  0
gspca_zc3xx            49536  0
gspca_main             26752  1 gspca_zc3xx
snd                    55877  11 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
i2c_i801               12609  0
tpm_tis                16713  0
parport_pc             29157  1
i2c_core               24897  3 i2c_ec,nvidia,i2c_i801
tpm                    19041  1 tpm_tis
videodev               41760  1 gspca_main
pcspkr                  7105  0
soundcore              11553  1 snd
parport                37513  2 lp,parport_pc
atl1e                  73120  0
v4l1_compat            16388  1 videodev
tpm_bios               11073  1 tpm
bluetooth              53797  8 hidp,rfcomm,l2cap,hci_usb
dm_raid45              67273  0
dm_message              6977  1 dm_raid45
dm_region_hash         15681  1 dm_raid45
dm_log                 14785  3 dm_mirror,dm_raid45,dm_region_hash
dm_mod                 63993  4 dm_mirror,dm_multipath,dm_raid45,dm_log
dm_mem_cache            9537  1 dm_raid45
ata_piix               24005  6
libata                156805  1 ata_piix
sd_mod                 25409  7
scsi_mod              144021  12 be2iscsi,ib_iser,iscsi_tcp,bnx2i,libcxgbi,libiscsi2,scsi_transport_iscsi2,scsi_dh,sr_mod,sg,libata,sd_mod
ext3                  125769  2
jbd                    57705  1 ext3
uhci_hcd               25421  0
ohci_hcd               24937  0
ehci_hcd               34125  0


I test the camera with my Skype. The LED indicator of the camera shows that the camera works but there is no picture. When I start the skype from console and test the camera there is no error shown in the console. There is no log in /var/log/messages. Sorry, but English is not very good and it's difficult to explain it.
icemans
 
Posts: 64
Joined: 2012/02/19 21:21:30
Location: Burgas, Bulgaria

Re: A4Tech camera and CentOS 5.7

Postby pschaff » 2012/02/23 13:17:50

That's pretty clear. All I can suggest s looking for updated drivers. You might want to try the CentOS-6 LiveDVD or the ELRepo mainline kernel.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: A4Tech camera and CentOS 5.7

Postby icemans » 2012/02/23 15:06:24

Which driver do I have to update? Does that mean that I have to install Kernel-ml for Enterprise Linux 6 from ELRepo mainline kernel. And could you tell me where is my problem? Thank you!
icemans
 
Posts: 64
Joined: 2012/02/19 21:21:30
Location: Burgas, Bulgaria

Re: A4Tech camera and CentOS 5.7

Postby pschaff » 2012/02/23 15:14:30

No. For 5.7 you want Kernel-ml for Enterprise Linux 5. And no - I can't tell you what your problem is, but testing with the mainline kernel and/or the CentOS-6 LiveCD/DVD could help pin it down. In both cases it should be safe to try, and possible to go back to your current situation - for the kernel-ml by rebooting to the standard kernel and optionally removing kernel-ml, and for the Live media by just rebooting to the installed system without making any changes to it.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: A4Tech camera and CentOS 5.7

Postby icemans » 2012/02/23 15:31:30

OK! I will install Kernel-ml for Enterprise Linux 5, I will test it and then I will remove it - right?! If the camera still doesn't work I will try with CentOS 6 Live CD, right? But if I try with Live CD, how could I test the camera?!
icemans
 
Posts: 64
Joined: 2012/02/19 21:21:30
Location: Burgas, Bulgaria

Re: A4Tech camera and CentOS 5.7

Postby pschaff » 2012/02/23 15:37:44

You can install things like Skype using the LiveCD/DVD - they just won't survive a reboot unless using persistence.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Next

Return to CentOS 5 - Hardware Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 1 guest