installing mcrypt on Parallels Plesk Panel v10.4.4_build1013111102.18 os_CentOS 6

General support questions

installing mcrypt on Parallels Plesk Panel v10.4.4_build1013111102.18 os_CentOS 6

Postby basslion » 2012/07/04 16:55:04

I am trying to install mcrypt extension on my CentOS running PHP 5.3.3.

How do i go about doing this? I have scoured the internet for clues as to how to do this, but all dont cover the entire steps needed.

If i type yum install mcrypt I get the message saying


[root@_ /]# yum install mcrypt
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
Setting up Install Process
No package mcrypt available.
Error: Nothing to do

Any help is greatly appreciated. If you have a Paypal account, ill drop a few dollars in there for your help also.

Thanks
basslion
 
Posts: 2
Joined: 2012/07/04 16:49:57

installing mcrypt on Parallels Plesk Panel v10.4.4_build1013

Postby TrevorH » 2012/07/04 18:06:51

php-mcrypt is in the EPEL repository
User avatar
TrevorH
Forum Moderator
 
Posts: 9166
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: installing mcrypt on Parallels Plesk Panel v10.4.4_build1013111102.18 os_CentOS 6

Postby basslion » 2012/07/04 18:24:58

Being somewhat of a newb, how does one find the EPEL repository? Thanks for your help.
basslion
 
Posts: 2
Joined: 2012/07/04 16:49:57

Re: installing mcrypt on Parallels Plesk Panel v10.4.4_build1013111102.18 os_CentOS 6

Postby TrevorH » 2012/07/04 18:30:18

One goes to http://www.google.com and sticks "EPEL" into the search box and looks at the first thing it comes up with :-)
User avatar
TrevorH
Forum Moderator
 
Posts: 9166
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: installing mcrypt on Parallels Plesk Panel v10.4.4_build1013111102.18 os_CentOS 6

Postby nomad » 2012/07/04 22:32:00

Its true that Google will show you the way but here is the steps needed to get you going.

First install the EPEL repo on your server

# rpm -Uvh http://download.fedoraproject.org/pub/e ... noarch.rpm

Then install the package needed with YUM:

# yum install php-mcrypt

Here is the EPEL FAQ to get you going in the right direction.

Remember to restart apache so the new PHP module is active.

Enjoy
nomad
 
Posts: 6
Joined: 2012/07/04 22:23:30


Return to CentOS 6 - General Support

Who is online

Users browsing this forum: No registered users and 9 guests