after 2 days trying still getting error for freenx

Issues related to configuring your network

after 2 days trying still getting error for freenx

Postby LaLi » 2008/07/11 23:48:38

i am trying for 2 days i am new to centos i installed as on the wiki says and i still can not make a connection to my server


i tried on my personal pc and i installed it successfully but on my web server i can not make it work i get this error if anyone knows how to fix it i tried all steps and still same error





Info: Display running with pid '1324' and handler '0x30284'.

NXPROXY - Version 3.2.0

Copyright (C) 2001, 2007 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '2412'.
Session: Starting session at 'Sat Jul 12 01:45:38 2008'.
Info: Connection with remote proxy completed.
Warning: Unrecognized session type 'unix-gnome'. Assuming agent session.
Info: Using ADSL link parameters 512/24/1/0.
Info: Using cache parameters 4/4096KB/131072KB/131072KB.
Info: Using pack method 'adaptive-7' with session 'unix-gnome'.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: No suitable cache file found.
Info: Forwarding X11 connections to display ':0'.
Info: Listening to font server connections on port '11000'.
Session: Session started at 'Sat Jul 12 01:45:39 2008'.
Warning: Protocol mismatch or no X authentication data.
Session: Terminating session at 'Sat Jul 12 01:45:42 2008'.
Info: Your session was closed before reaching a usable state.
Info: This can be due to the local X server refusing access to the client.
Info: Please check authorization provided by the remote X application.
Session: Session terminated at 'Sat Jul 12 01:45:42 2008'.


LaLi
 
Posts: 6
Joined: 2008/07/11 22:22:10

Re: after 2 days trying still getting error for freenx

Postby pjwelsh » 2008/07/12 01:47:32

I'm a little biased... I kinda like VNC as general rule... if you want to spend less setup time, follow info at http://wiki.centos.org/HowTos/VNC-Server

Pay close attention to the the " VNC-Sever setup with no hassles with vnc-ltsp-config" option ;)

Again, not that I'm biased... :)
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: after 2 days trying still getting error for freenx

Postby scottro » 2008/07/12 03:56:39

One suggestion is completely skip part 2 for the moment, until you get it working. If you do skip part two, then you have to connect with a user account that is on the FreeNX server.

So, you have user john on the server, with a password of 1234. You want to connect as user john.

Another thing that people sometimes skip, or overlook, is importing the key from the server. It's mentioned in the wiki, but for some reason, folks overlook that.

Lastly, make sure that sshd is listening on 127.0.0.1. (For example, if you've set up Linux-VServer, you might have set sshd to only listen on one local address such as 192.168.1.20.) If you haven't touched sshd_config then you can ignore that one.

Can you make normal ssh connections to the machine running FreeNX?
If not, it could be a firewall issue.
scottro
Forum Moderator
 
Posts: 1715
Joined: 2007/09/03 21:18:09
Location: NYC

Re: after 2 days trying still getting error for freenx

Postby LaLi » 2008/07/12 12:49:22

At the

http://wiki.centos.org/HowTos/VNC-Server


There is a mistake at the 4th line it should be

If the server is not installed, install it with the command:[color=CC3333]yum install vnc-server[/color]



Who is responsible for that part look to fix that



1. Installing the required packages

The server package is called 'vnc-server'. Run the command rpm -q vnc-server.

The result will be either package vnc-server is not installed or something like vnc-server-4.0-11.el4.

If the server is not installed, install it with the command: yum install vncserver.

The client program is 'vnc'. You can use the command yum install vnc to install the client if rpm -q vnc shows that it is not already installed.




and now let me try to install it if i have luck
LaLi
 
Posts: 6
Joined: 2008/07/11 22:22:10

Re: after 2 days trying still getting error for freenx

Postby LaLi » 2008/07/12 14:04:22

pjwelsh i treyd all steps and here what i get

can you tell me how to fix this i could not get it work neither:S


please help me

$ x11vnc -nopw -display :0.0
12/07/2008 06:06:23 x11vnc version: 0.9.3 lastmod: 2007-09-30

12/07/2008 06:06:35 ***************************************
12/07/2008 06:06:35 *** XOpenDisplay failed (:0.0)

*** x11vnc was unable to open the X DISPLAY: ":0.0", it cannot continue.
*** There may be "Xlib:" error messages above with details about the failure.

Some tips and guidelines:

* An X server (the one you wish to view) must be running before x11vnc is
started: x11vnc does not start the X server. (however, see the
recent -create option if that is what you really want).

* You must use -display , -OR- set and export your $DISPLAY
environment variable to refer to the display of the desired X server.
- Usually the display is simply ":0" (in fact x11vnc uses this if you forget
to specify it), but in some multi-user situations it could be ":1", ":2",
or even ":137". Ask your administrator or a guru if you are having
difficulty determining what your X DISPLAY is.

* Next, you need to have sufficient permissions (Xauthority)
to connect to the X DISPLAY. Here are some Tips:

- Often, you just need to run x11vnc as the user logged into the X session.
So make sure to be that user when you type x11vnc.
- Being root is usually not enough because the incorrect MIT-MAGIC-COOKIE
file will be accessed. The cookie file contains the secret key that
allows x11vnc to connect to the desired X DISPLAY.
- You can explicity indicate which MIT-MAGIC-COOKIE file should be used
by the -auth option, e.g.:
x11vnc -auth /home/someuser/.Xauthority -display :0
x11vnc -auth /tmp/.gdmzndVlR -display :0
you must have read permission for the auth file.

- If NO ONE is logged into an X session yet, but there is a greeter login
program like "gdm", "kdm", "xdm", or "dtlogin" running, you will need
to find and use the raw display manager MIT-MAGIC-COOKIE file.
Some examples for various display managers:

gdm: -auth /var/gdm/:0.Xauth
kdm: -auth /var/lib/kdm/A:0-crWk72
xdm: -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
dtlogin: -auth /var/dt/A:0-UgaaXa

Only root will have read permission for the file, and so x11vnc must be run
as root. The random characters in the filenames will of course change,
and the directory the cookie file resides in may also be system dependent.
Sometimes the command "ps wwwaux | grep auth" can reveal the file location.

See also: http://www.karlrunge.com/x11vnc/#faq




when i connect i get only grey screen but not the screen fron the x machine
LaLi
 
Posts: 6
Joined: 2008/07/11 22:22:10

Re: after 2 days trying still getting error for freenx

Postby NedSlider » 2008/07/12 14:17:24

LaLi wrote:
At the

http://wiki.centos.org/HowTos/VNC-Server


There is a mistake at the 4th line it should be

If the server is not installed, install it with the command:[color=CC3333]yum install vnc-server[/color]


Who is responsible for that part look to fix that


Thanks - fixed.

The community is responsible - it's a Wiki :-)
NedSlider
 
Posts: 2848
Joined: 2005/10/28 13:11:50
Location: UK

Re: after 2 days trying still getting error for freenx

Postby pjwelsh » 2008/07/13 01:45:09

The x11vnc option is *ONLY* for connecting to the physical console's GUI screen. It is not for starting new vnc sessions. You will want the stock vnc-server or likely easier vnc-ltsp-config option.
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: after 2 days trying still getting error for freenx

Postby LaLi » 2008/07/13 11:37:49

I tried everything and i only got grey screen nothing on it and an X coursor what you think is the problem can you please help me because i am really new into this so if i get screen acces it will be better for me

thank you


i tryed everything from the wiki do i need to make some extra configuration or ?


Please if you could help me


Thank you bye
LaLi
 
Posts: 6
Joined: 2008/07/11 22:22:10

Re: after 2 days trying still getting error for freenx

Postby gerald_clark » 2008/07/14 13:45:48

VNC allows you to connect to an X term.
You must have X and your favorite window manager installed.
Do you?
gerald_clark
 
Posts: 7183
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: after 2 days trying still getting error for freenx

Postby pjwelsh » 2008/07/14 13:57:21

If you want the "heavy" desktop, you could just run, as root:
Code: Select all
yum groupinstall "GNOME Desktop Environment"
will get you the default Gnome stuff. To get a more "light" desktop, you could
Code: Select all
yum groupinstall "XFCE-4.4"

Please note that the XFCE will need the "extras" repo enabled if it is not.
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Next

Return to CentOS 5 - Networking Support

Who is online

Users browsing this forum: No registered users and 2 guests